none
Networks were set to 'Public' by the installation

    Question

  • How do I switch them to Private? (Home or work).

    Network & sharing center has no such option.


    Tuesday, March 13, 2012 1:07 PM

Answers

  • The link to switch between designation of Public or Private networks that was available in Windows 7 has been removed in Windows 8 Consumer Preview.

    The logic that determines whether a connection is Public or Private is now determined by whether sharing is enabled for the interface. To change the sharing setting, take the following steps:

    Access View Available Networks (VANUI) by clicking the network icon in the lower right section of the Desktop taskbar

    1. Right-click the network you want to change to bring up the context menu
    2. Select “Turn sharing on or off”
    3. On the flyout, select "Yes turn on sharing and connect to devices" to designate the connection as Public. Select “No, don’t …” to designate the connection as Private.
    Friday, March 16, 2012 1:01 AM
    Moderator

All replies

  • Hi CostasZ,

    Thanks for posting here.

    May I know the address of default gateway that we assigned to the NIC is accessible from this Windows server 8 host ?
    There is no Home or Work firewall profile in current Windows server 8 consumer preview version. But system will automatically switch to use between “Private” or “Guest or Public ” profile base on the connectivity to the default gateway .

    Thanks.

    Tiger Li


    Tiger Li

    TechNet Community Support

    Wednesday, March 14, 2012 6:08 AM
  • From ipconfig: (I aterisked out the names, the ip address is statically set in the router. The gateway ip is correct, it's the same as the router's).

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : ****************
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : ******

    Ethernet adapter Wired Ethernet Connection:

       Connection-specific DNS Suffix  . : ******
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 00-01-2E-23-C0-22
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::e992:b427:2fff:d653%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.10.100(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Sunday, March 04, 2012 6:19:46 PM
       Lease Expires . . . . . . . . . . : Wednesday, March 14, 2012 12:01:29 PM
       Default Gateway . . . . . . . . . : 192.168.10.1
       DHCP Server . . . . . . . . . . . : 192.168.10.1
       DHCPv6 IAID . . . . . . . . . . . : 318767406
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-E4-AA-3E-00-01-2E-23-C0-22
       DNS Servers . . . . . . . . . . . : 167.206.251.129
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Wednesday, March 14, 2012 3:15 PM
  • H CostasZi,

    Thanks for update.

    So even after properly obtains address form DHCP and accesses internet , system will still recognize and apply “Guest or Public” profile to this interface ?

    Thanks.

    Tiger Li


    Tiger Li

    TechNet Community Support

    Thursday, March 15, 2012 6:40 AM
  • Tiger, I am not sure what you mean with 'recognize and apply'. All I see in Network Sharing Center is that the one network that goes through this interface to the internet is designated as 'Public' and there's no way to modify it. How can I change it to Private? What are the implications of it being 'Public'?
    Thursday, March 15, 2012 12:38 PM
  • The link to switch between designation of Public or Private networks that was available in Windows 7 has been removed in Windows 8 Consumer Preview.

    The logic that determines whether a connection is Public or Private is now determined by whether sharing is enabled for the interface. To change the sharing setting, take the following steps:

    Access View Available Networks (VANUI) by clicking the network icon in the lower right section of the Desktop taskbar

    1. Right-click the network you want to change to bring up the context menu
    2. Select “Turn sharing on or off”
    3. On the flyout, select "Yes turn on sharing and connect to devices" to designate the connection as Public. Select “No, don’t …” to designate the connection as Private.
    Friday, March 16, 2012 1:01 AM
    Moderator
  • I do have sharing on as I do have volume shares visible to other clients. Is that the kind of sharing that would be off if I designate the connection as private? If that is the case then I will leave it as 'Public'. This sounds different than the previous semantic of Public vs Private which described 'Public' as being on a public unstrusted LAN/WAN.
    Friday, March 16, 2012 12:46 PM
  • The steps provided by Tim Quinn work for WLAN and LAN adapters, however...VPN adapters cannot be changed like this.  Anyone have any recommendation on how to change a VPN connection network profile?
    Monday, April 23, 2012 3:52 PM
  • Hi all, I've just found a trick via regedit that seems to work (tested rdp-IN connection without changing firewall rules)

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles\

    open the network profile that you have to change and modify the "Category" value:

    0 = public
    1 = private
    2 = domain

    ciao
    Paolo
    NetOrange Srl

    • Proposed as answer by NetOrange Tuesday, October 16, 2012 10:14 AM
    Tuesday, October 16, 2012 10:04 AM
  • Thank you, Tim, for this post!

    I was wondering where I can change the type of network from Public to Private. I've found that it is necessary to have your network set as Private to be able to create Remote Assistance requests. A friend of mine uses USB Cell Modem to connect to internet and Windows 8 automatically defined network type as Public. That leads her to be unable to request remote assistance.

    Once again, for anybody having problems with requesting remote assistance on Windows 8 when the OS tells you that your PC isn't setup for Remote Assistance, here's what you have to do when you are using dial-up connection:]

    1. Locate the bar graph icon in the notification area that signifies Wi-Fi/Dial-Up network connections and click the icon.

    2. In the Networks sidebar opened at the right locate the dial-up network which you are connected to. It will be marked as Connected next to the network/connection name.

    3. Right-click the selected network name and choose Turn sharing on or off shortcut menu item.

    4. In the Networks bar opened choose Yes, Turn on sharing and connect to devices option to mark your current connection as Home or Work network (that is Private type network):

    5. This should make it possible for you to request remote assistance.


    Well this is the world we live in And these are the hands we're given...



    • Edited by Exotic Hadron Wednesday, October 24, 2012 7:35 PM
    • Proposed as answer by Shane M Monday, January 14, 2013 6:46 PM
    Wednesday, October 24, 2012 7:29 PM
  • On my copy of Windows 8, those keys don't exist. For Windows 8 I've found Exotic Hadron's answer (below) to be the solution. I have no idea why they've made it so annoyingly difficult to fix this problem.

    * Zune provides just an error code.

    * Zune "more info" link provides no useful information.

    * kb 952304 which apparently provides all the answers is, as I write this, is a 404 on all Microsoft sites.

    Just more flame for the Windows 8 Metro UI is half-finished argument. Why remove options from desktop Control Panel? Why not have them in two places, Metro and Desktop. Jumping between Metro and Desktop required to configure a network is very very silly.</rant>

    Friday, January 11, 2013 2:05 AM
  • same

    Prosysco

    Monday, October 7, 2013 3:59 AM
  • Hi all, I've just found a trick via regedit that seems to work (tested rdp-IN connection without changing firewall rules)

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles\

    open the network profile that you have to change and modify the "Category" value:

    0 = public
    1 = private
    2 = domain

    ciao
    Paolo
    NetOrange Srl

    Thanks for this, I tried the other options just didn't work. Not sure if it due to some programs I have installed like VMWare etc. Anyway thanks again.
    Wednesday, May 7, 2014 7:46 PM
  • PSH> Get-NetConnectionProfile

    Name : Unidentified network InterfaceAlias : vEthernet (Local-10) InterfaceIndex : 18 NetworkCategory : Public IPv4Connectivity : LocalNetwork IPv6Connectivity : LocalNetwork

    PSH> Set-NetConnectionProfile  -InterfaceIndex 18 -NetworkCategory Private

    Source:

    http://blogs.msmvps.com/russel/2013/12/29/set-network-location-to-private-in-windows-8-1server-2012-r2/


    Flavio Ribeiro


    • Edited by mastersto Sunday, September 7, 2014 4:59 AM
    • Proposed as answer by r3844c Wednesday, November 19, 2014 5:38 PM
    Sunday, September 7, 2014 4:58 AM