locked
Server Manager - App Svr - Event Error - ID 10016 - Source DistributedCOM RRS feed

  • Question

  • Can someone assist me in resolving this error?

    Server Manager Application Server Error event ID 10016 from DistributedCOM - "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {61738644-F196-11D0-9953-00C04FD919C1} to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    The Even Log Online Help provided guidance (http://technet.microsoft.com/en-us/library/cc726313.aspx) but when I attempted to make resolution the steps did not match myh Component Services file heirachy and unfortunately I don't know enough to work it out for myself.

    I have screenshots but don't know how to attach them here to assist with my help request.

    Thanks - Richard
    Friday, June 19, 2009 10:51 PM

Answers

  • Hi Richard,

     

    How are things going? I have not heard back from you in a few days and wanted to check on the status of the issue. Please let me know how things turned out.

     

    Tim Quan - MSFT

    • Marked as answer by RumpldRich Monday, June 29, 2009 4:54 PM
    Monday, June 29, 2009 1:25 AM

All replies

  • hi there,

    can you let us knwo what is the OS version you are running.

    the key bits here are The application-specific permission settings and {61738644-F196-11D0-9953-00C04FD919C1}

    the first location i would suggest you to check is

    http://support.microsoft.com/kb/290398


    also please do check the MDM permission ( machine debug manager ) under DCOM settings.


    sainath !analyze
    • Proposed as answer by Whoojong Thursday, December 29, 2011 2:31 PM
    • Unproposed as answer by Whoojong Thursday, December 29, 2011 2:31 PM
    Saturday, June 20, 2009 6:33 AM
  • Hi,

     

    The GUID 61738644-F196-11D0-9953-00C04FD919C1 corresponds to the service “IIS WAMREG Admin Service”.

     

    Let’s try the following steps:

     

    1. Click Start -> Run, type "dcomcnfg" in the text box, and click OK.

    2. Expand Console Root\Component Services\Computers\My Computer\DCOM Config

    3. Find "IIS WAMREG Admin Service" in the list, right click, Properties, and on the Security tab, click Customize.

    4. Grant the Network Service account with "Launch and Activation Permissions".

    5. Click OK.

     

    Hope it helps.

     

    Tim Quan - MSFT

    • Proposed as answer by Whoojong Thursday, December 29, 2011 2:31 PM
    Monday, June 22, 2009 11:01 AM
  • Thanks for your responses - I'll make the changes and see if it resolves this issue. I'm only able to work on this part of the day so I apologize for slow responses and actions to your suggestions.

    EDIT POST REPLY: Running mdm.exe /regserver return an error on my system "Windows cannot find 'mdm.exe/regserver'. Make sure you typed the name correctly and then try again. I tried mdm.exe which also could not be located.

    The OS version is Windows Server Enterprise SP2, v.113
    System: 8GB Ram  and Intel Core 2 Duo CPU #8400 @ 3.00GHz by 3.00GHz.
    It is a standalone/single user system used for developing using Hyper-V and BizTalk Server (2009 Beta)

    I'm very new to Server technology (Glad I began with Server 2008! It seems easier than 2003)

    T

    Regards,

    Richard
    • Edited by RumpldRich Monday, June 22, 2009 10:50 PM New and important Info since initial reply.
    Monday, June 22, 2009 10:19 PM
  • hi there,

    did you had a chance to go through the workaround suggested by us ?
    sainath !analyze
    Thursday, June 25, 2009 8:10 AM
  • Hi Sainath - When I tried the workaround part way through the steps outlined in one of the online resources could not be completed because of the error I pointed out in my previous Reply.

    Since mdm.exe/regserver is not located on my system can you suggest how I can fix this so that I can progress through the rest of the steps to this solution?

    I'm unsure about how to do a Server 2008 repair.

    Thanks,

    Richard
    Thursday, June 25, 2009 7:21 PM
  • Hi Ricard,

     

    Although the error code is similar, the exact component that has problem is different from that described in the KB. In the KB, the GUID {0C0A3666-30C9-11D0-8F20-00805F2CD064} refers to Machine Debug Manager. In our case, the GUID {61738644-F196-11D0-9953-00C04FD919C1} corresponds to the service “IIS WAMREG Admin Service”.

     

    Therefore, I am afraid that this KB is not suitable for you to try. Now I suggest trying the steps below:

     

    1. Click Start -> Run, type "dcomcnfg" in the text box, and click OK.

    2. Expand Console Root\Component Services\Computers\My Computer\DCOM Config.

    3. Find "IIS WAMREG Admin Service" in the list, right click, Properties, and on the Security tab, click Customize.

    4. Grant the Network Service account with "Launch and Activation Permissions".

    5. Click OK.

     

    Please let me know the result.

     

    Tim Quan - MSFT

     

    Friday, June 26, 2009 5:19 AM
  • Hi Richard,

     

    How are things going? I have not heard back from you in a few days and wanted to check on the status of the issue. Please let me know how things turned out.

     

    Tim Quan - MSFT

    • Marked as answer by RumpldRich Monday, June 29, 2009 4:54 PM
    Monday, June 29, 2009 1:25 AM
  • Hi Tim,

    That solved the issue. Thank you. I apologize for the late response - I was out of the office on Thursday afternoon (late) and all day Friday.
    The error stopped.

    Thanks for your assistance and follow up.

    Q!
    Monday, June 29, 2009 4:54 PM
  • I have the same issue.  I run Windows Server 2008 Enterprise SP1 terminal server.  Every minute, it reports the following error:
    ______

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {0C0A3666-30C9-11D0-8F20-00805F2CD064}

    to the user PINDLERCORP\csierra SID (S-1-5-21-990400319-699996810-868425949-5543) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
    ______

    This happens with all users that connect into the terminal server.  I didn't want to start manipulating permissions until I run it by someone first.  Does anyone have any recommendation?

    Thanks again.

    Wednesday, October 14, 2009 4:11 PM
  • Same issue, I've tried Tim's fix but all option buttons on the security tab of IIS WAMREG admin Service are disabled.

    I'm loged as admin... any suggestion?

    Wednesday, December 26, 2012 4:42 PM
  • The options are disabled by default with Server 2008 R2 and later. See this blog post to update the settings that let you change this option: http://blogs.msdn.com/b/emeadaxsupport/archive/2010/01/26/unable-to-edit-the-dcom-settings-for-iis-wamreg-admin-service-on-a-windows-server-2008-r2-when-trying-to-configure-kerberos-authentication-for-role-centers.aspx

    1. Run Regedit.exe and browse to "HKEY_CLASSES_ROOT\AppID\{61738644-F196-11D0-9953-00C04FD919C1}" key.
    2. Secondary-mouse click on the {61738644-F196-11D0-9953-00C04FD919C1} key and select Permissions...
    3. Click the Advanced button in the Permissions window and select the Owner tab. Under Change owner to select the local Administrators group and click on Apply, thenOK.
    4. Then under Permissions window, select the local Administrators group and under Permissions for Administrators select Full Control and click on Apply, then OK.
    NOTE: DO NOT modify/change any permissions for the TrustedInstaller account.

    5. Re-run the Component Services management console (dcomcnfg.exe) and you should now be able to modify the settings for IIS WAMREG admin service package.


    Jason Warren
    Infrastructure Architect


    • Edited by Jason Warren Friday, February 22, 2013 5:45 PM put in specific steps
    Friday, February 22, 2013 5:38 PM