Cannot add a disk to a Hyper-V Virtual Machine in Windows 2008 R2


  • Hello,

    I have a newly installed Windows 2008 Enterprise R2 Server, with the Hyper-V role installed. When I try to add a disk to a Virtual Machine (or create a new virtual machine with a disk attached) I get the error message: 

    Cannot open attachment 'F:\Hyper-V\Drives\Test C.vhd'. Error: 'A virtual disk support provider for the specified file was not found.' (7864368). (Virtual machine ID 77AC55CF-D654-4F00-92F8-1137E84062BA)

    The server is an Intel SR2500 ALLX Chassis with all the latest firmware/drivers from Intel. I have 2008 Hyper-V (non R2 version of Windows 2008) running fine on another similar spec server.

    Any help greatly appreciated!


    Monday, January 04, 2010 3:58 PM

All replies

  • What is the source of the VHD?

    The error lends itself to a permissions problem or a VHD format problem.

    If it came from a Hyper-V v1 system, then you have to make sure the previous Hyper-V system was patched up with all patches. 

    There is an incompatibility with VHD from R2 to v1 that there is a patch for, but not from v1 to R2.

    Brian Ehlert (hopefully you have found this useful)
    Monday, January 04, 2010 4:45 PM
  • Hi Brian,

    This is with a newly created VHD using the New Virtual Machine Wizard. I've also tried manually creating a VHD and then attaching it and I get the same error. I even tried "Create VHD" from Disk Management, but no joy!

    I've added every user I can think of to the permissions of the VHD file  (Everyone, Network Service etc) - I am logged on as Domain Administrator.


    Monday, January 04, 2010 4:55 PM
  • Were any drivers updated or are non-stock?

    I recall somthing similar in another thread that ended up being driver related, the other common thing is antivirus running on the parent.

    Brian Ehlert (hopefully you have found this useful)
    Monday, January 04, 2010 9:06 PM
  • Hi Brian - thanks for your response,

    This is basically a clean install - i.e. a fresh build with no 3rd party software or antivirus. 

    The RAID drivers are the latest I can find off the Intel Website. I have also updated all firmware for the motherboard, RAID, Backplane etc. 


    Tuesday, January 05, 2010 9:30 AM
  • Were the RAID drivers necessary?

    Do the RAID drivers have any type of managment software?  (or are they just drivers)
    When management software is involved, it frequently causes problems vs. using 'just a driver'

    Brian Ehlert (hopefully you have found this useful)
    Tuesday, January 05, 2010 4:19 PM
  • Hi,


    I found a similar issue that the root cause was the HBA card. After replaced the HBA card to a old HBA card, the issue disappeared. So I suspect that there are some issue with your RAID card, please remove the RAID and only install virtual machine on a single hard disk to check whether you get the same issue.



    Best Regards,

    Vincent Hu


    • Marked as answer by Vincent HuModerator Monday, January 11, 2010 6:07 AM
    • Unmarked as answer by Colin1001 Monday, January 11, 2010 12:02 PM
    Wednesday, January 06, 2010 8:16 AM
  • Hi Vincent,

    I have connected a single SATA drive directly to motherboard, bypassing RAID and the HBA completely. I've moved the VHD file to this new drive, but it still comes up with this error when I try attach it.

    Any more ideas would be greatly appreciated!

    Monday, January 11, 2010 12:05 PM
  • Hi,


    As you mentioned, the Hyper-V computer is new installed, so we can isolate the influence of other drivers/applications. I recommend that you remove the HBA, install Windows Server 2008 R2 on a single hard disk to check whether you get the same issue.



    Best Regards,

    Vincent Hu


    Tuesday, January 12, 2010 7:17 AM
  • I am having the same error.

    This is a clean windows server 2008 r2 standard edition install.
    The hyper-v  role was added last. I never got a machine working yet, this is the first vm I tried to create. I also tried to create the vhd on a separate drive, nothing.
    Manually changed permissions to that file rw to everyone still doesn't work.
    Reinstalling hyper-v role doesn't work either.

    I cannot reinstall the whole system, it's a production server and that will cause me problems... And I really need hyper-v , being the reason we payed extra for the standard edition of ws2k8. Otherwise we would have web edition.

    Wednesday, January 20, 2010 3:15 PM
  • http://img693.imageshack.us/img693/8176/hyperv.jpg is the error , don't know if it helps.
    Wednesday, January 20, 2010 3:41 PM
  • Was there any type of antivirus / anti-malware installed on the system prior to adding the Hyper-V role?

    (or after adding the Hyper-V Role)

    the next thing that I can thing of are drivers.  Network as well as storage.
    Specifically drivers with management agents or configuration UIs.  These can cause proboems is they are not Hyper-V aware (as there is a hypervisor under this server installation now, it no longer directly owns the hardware).

    Do these VMs ahve snapshots or differencing disks?  Or are they just a straight VHD?

    Do the VMs have ISO disks attached?

    Bing gave me these options:
    http://communities.intel.com/message/79486  (Intel Specific)


    There is the possiblity of hardware (specifically firmware) as the culpret, as well.

    In regards to the statement "I cannot reinstall the whole system, it's a production server"

    I take it that you have a production server that you have some applications / Roles running on and then you added Hyper-V?
    (BTW - this is a configuration that is possible but not recommended as your applications installed in the management operating system can suffer).

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, January 20, 2010 5:06 PM
  • this are straight vhds...
    I tried the registry settings, doesn't work.

    No iso atached to the vm.

    But there is something you might be right. I do have a 3ware raid card, and it does have a web management console. So this might be it... I uninstalled it and still, same error.

    I added hyper-v role when I added the iis role and the dns role.
    Wednesday, January 20, 2010 5:18 PM
  • PRoland,

    Check your device manager, I had issues with my VMBUS Driver not working properly, make sure all the necessary services are up and running, check if the services are running under the correct service account.

    1) Try to install a test machine on your test environment with windows 2008 r2 trial on a sigle disk sata;
    2) Install only hyper-v role and use the wizard to create a VM + VHD, test starting the VM - prepare the image as you wish 
    3) Copy the VHD to your production server and test creating a VM with the VHD you have from the test server.
    4) Let us know about your test.

    Bruno Waqued, MCITP Network Systems Engineer
    Wednesday, January 20, 2010 6:47 PM
  • I am sorry to announce you that  I reinstalled the whole system to windows server 2008 r2 WEB edition and I am going to use some low end software like virtualbox since hyper-v fails in so many ways including linux guest support.

    I hope you all will find a solutions to this, I had to work all night now for this reinstalation
    Wednesday, January 20, 2010 9:55 PM
  • Don't know if you ever resolved this, but I thought I would let you know....I had the exact same issue, same OS....  I found the solution in the following article (I suspect it was the Backup Exec 2010 installation on the same box that flipped the setting in the registry.)


    Hope this helps



    Thursday, June 03, 2010 5:14 PM