none
TS Gateway - SSL over 3389? RRS feed

  • Question

  • I'm connecting to a w2k8r1 box with tsgateway and tswebaccess - when a user connects to a remote app i can see their connection in the tsgateway monitoring but it appears over 3389.  I just want to confirm that when that user connects thru the tsgateway that they are doing ssl ?  I haven't changed the port for RDP in the tsconfig because i dont want to mess around with the firewall but i don want to confirm that i am indeed using ssl over 3389.  When using netstat -a -f it doesn't appear either.
    Wednesday, June 30, 2010 4:50 PM

Answers

  • When you connect via TS Gateway, you connect to the Gateway server over SSL (port 443), but from the Gateway server to the RDP endpoint over 3389.


    Charlie. http://msmvps.com/blogs/russel
    Wednesday, June 30, 2010 7:11 PM
  • Simple suggestion to test. Close off 3389 at the router. If it works, it all came over 443. (It's actually creating a tunnel with 443.)


    Charlie.
    http://msmvps.com/blogs/russel
      "Woody-IT" wrote in message news:cdf57c6e-7857-4891-8c93-20d8e7786138@communitybridge.codeplex.com...

    just to confirm - my one tssserver has tsgateway and web access on it - i am connecting from one client over the internet - so all traffic between the client and tsserver is over 443? even though it is displayed as 3389 in the monitoring section of tsgateway?



    i saw anohter post from someone who said that even though you use tsgateway the rdp client first tries to connect over 3389 which scared me because from what i see in the monitoring console thats exactly what is happening


    Charlie. http://msmvps.com/blogs/russel
    • Marked as answer by Woody-IT Thursday, July 1, 2010 9:27 PM
    Thursday, July 1, 2010 5:50 AM

All replies

  • When you connect via TS Gateway, you connect to the Gateway server over SSL (port 443), but from the Gateway server to the RDP endpoint over 3389.


    Charlie. http://msmvps.com/blogs/russel
    Wednesday, June 30, 2010 7:11 PM
  • just to confirm - my one tssserver has tsgateway and web access on it - i am connecting from one client over the internet - so all traffic between the client and tsserver is over 443?  even though it is displayed as 3389 in the monitoring section of tsgateway?

     

    i saw anohter post from someone who said that even though you use tsgateway the rdp client first tries to connect over 3389 which scared me because from what i see in the monitoring console thats exactly what is happening 

    Wednesday, June 30, 2010 7:38 PM
  • Simple suggestion to test. Close off 3389 at the router. If it works, it all came over 443. (It's actually creating a tunnel with 443.)


    Charlie.
    http://msmvps.com/blogs/russel
      "Woody-IT" wrote in message news:cdf57c6e-7857-4891-8c93-20d8e7786138@communitybridge.codeplex.com...

    just to confirm - my one tssserver has tsgateway and web access on it - i am connecting from one client over the internet - so all traffic between the client and tsserver is over 443? even though it is displayed as 3389 in the monitoring section of tsgateway?



    i saw anohter post from someone who said that even though you use tsgateway the rdp client first tries to connect over 3389 which scared me because from what i see in the monitoring console thats exactly what is happening


    Charlie. http://msmvps.com/blogs/russel
    • Marked as answer by Woody-IT Thursday, July 1, 2010 9:27 PM
    Thursday, July 1, 2010 5:50 AM