The MAD Monitoring thread was unable to connect to WMI, error '0x8004100e'.


  • Hi guys, having big problems with monitoring.

    Server is running sbs server 2003 (premium edition) sp2 with exchange 2003.

    Monitoring was playing up, so followed steps to completely remove.

    After removing I rebooted server and reinstalled monitoring component . during install it prompted for original windows 2003 cd3  so used that (do not have a copy of 2003 sp2 slipstreamed cd) . At the end of the install it advised that some components will not run correctly because service pack 2 disc was not used to reinstall monitoring component.

    Monitoring still didn't work , had errors end of using the configuration wizard (3 out of 4 points did not successfully complete)

    It advised to reinstall the service pack. Download 2003 sp2 and tried to reinstall. Then I got "Access denied" error during install. Tried to troubleshoot that by resetting default security setting as explained in a MS KB. that didn't work.

    I noticed WMI errors in event log so I followed this KB to reregister the Exchange 2003 namespace with WMI(kb/288590) . Got errors while running these commands;

    C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof
    Microsoft (R) 32-bit MOF Compiler Version 5.2.3790.3959
    Copyright (c) Microsoft Corp. 1997-2001. All rights reserved.
    Parsing MOF file: exwmi.mof
    MOF file has been successfully parsed
    Storing data in the repository...
    An error occurred while opening the namespace for object 1 defined on lines 10 -
    Error Number: 0x8004100e, Facility: WMI
    Description: Invalid namespace
    Compiler returned error 0x8004100e

    On top of that I'm getting frequent errors in the event log (that I never seen before), as shown here:

    With all of this in mind, please advise best course of action to resolve this problem that is spiraling out of control

    Sunday, January 10, 2010 12:00 PM