none
IPv6 prefered over IPv4, DisabledComponents Hex 0x20 is ignored RRS feed

All replies

  • Hi ,

    What's the OS version?

    Sometimes NLA passive probe might be indirectly (and falsely) indicating ipv6 availability.

    You might disable passive polling to do a test:

    In the default registry configuration, this registry entry does not exist. You need to create it.

    HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator\DisablePassivePolling
    Key Type: DWORD

    Value: Decimal 1 (True)

    Please note: Before you modify it, back up the registry for restoration in case problems occur.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Thursday, April 2, 2020 7:51 AM

  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, April 6, 2020 1:47 AM
  • Hi ,

    Did you have any updates on this issue?

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, April 7, 2020 2:21 AM
  • Setting DisablePassivePolling to 1 made no difference. 

    I think I forgot to mention a very important fact. Our internal and external DNS zones are the same.

    As a result when clients make DNS queries, IPv4 goes through VPN tunnel and IPv6 goes out via public internet. 

    IPv6 DNS response is 10ms faster than IPv4 and since we don't have internal A records published in the public zone, No such name is returned first from Pubic and then we get an IP for the DNS request from internal zone.  

    It looks like the only solution we have at this point is to tunnel both IPv6 and IPv4 




    Tuesday, April 7, 2020 6:20 PM
  • Hi ,

    Thanks for your posting here and sharing the resolution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, April 8, 2020 2:17 AM