Windows update on 2003 Server looping


  • When I try to run Windows Update on any of my Server 2003 machines I get a looping condition where it says "Checking if your computer has the latest version of Windows updating software for use from the website..." and then "Checking for the latest version of Windows updating software..."

    There are two suspicous entries in the windowsupdate.log:

    WARNING: Digital Signatures on file C:\WINDOWS\SoftwareDistribution\AuthCabs\Downloaded\\ are not trusted: Error 0x800b0001


    FATAL: Update required for C:\WINDOWS\system32\wuweb.dll: target version = 7.4.7600.226, required version = 7.6.7600.256

    Since it's not just one server but ALL 2003 servers, I am guessing it's not something on the server itself.

    Tuesday, August 07, 2012 7:11 PM


All replies

  • Hi,

    FATAL: Update required for C:\WINDOWS\system32\wuweb.dll: target version = 7.4.7600.226, required version = 7.6.7600.256

    You may need to update to a latest service pack. The client has been updated to the new Windows Update Agent, and the new WUAgent cannot talk to an older WSUS3SP2 server.

    You need to install KB2720211 on your WSUS server.

    Kindly post your query in WSUS forum, where you can get better responses from experts. Thanks for your understanding.


    If you found this post helpful, please give it a "Helpful" vote.
    If it answered your question, remember to mark it as an "Answer".
    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    • Edited by iamrafic Tuesday, August 07, 2012 7:38 PM
    Tuesday, August 07, 2012 7:27 PM
  • No WSUS server.  Trying to get updates from Microsoft servers.
    Wednesday, August 08, 2012 2:03 PM
  • Try resetting the Windows Update components and then update. See if that works.

    How do I reset Windows Update components?

    I do not represent the organisation I work for, all the opinions expressed here are my own.

    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    - .... .- -. -.- ... --..-- ... .- -. - --- ... ....

    Wednesday, August 08, 2012 2:34 PM
  • Resetting the components per the linked article did not solve the problem.
    Thursday, August 09, 2012 3:39 PM
  • I am having this EXACT behavior as well on Windows XP SP3.  I go to Start..Microsoft Update.  The system "loops" over and over for about 3-4 minutes jumping between "Checking if your computer has the latest version of Windows updating software for use from the website..." and "Checking for the latest version of Windows updating software..."  

    This occurs even after running the FixIt listed in the KB 971058 link above.  I think Microsoft has broken something with their "new" updater that came out last month.  We did not have these symptoms before updating the updater.

    After 3-4 minutes, IE just becomes unresponsive and hangs.

    Checked WindowsUpdate.log and I also have the "not trusted" warning above as well, same file.

    Update: I now have this issue on SEVERAL systems (every one I've tried) across completely different organizations (unrelated PC's, unrelated networks)---it appears Windows Update has been totally broken in the last few days on Windows XP (probably Server 2003 as well).  If you run Start...All Programs..Microsoft Update, and get prompted to download the newer updater, once you do it, you will get this infinite loop and all updating is now broken.


    • Edited by DNeuwir Saturday, August 11, 2012 4:04 PM
    Saturday, August 11, 2012 3:17 PM
  • Had the same issue on several Sever 2k3 SP2 boxes after getting the "update to the latest version" prompt when checking for updates.  The only "fix" was to stop the Automatic Update Service, delete the 'C:\Windows\SoftwareDistribution' folder and restart the service.  I could then check for/install updates.

    However, this was only a temporary fix.  After a reboot, the problem occurred again. 

    Open to suggestions for permanent fixes.

    • Edited by RMurrayAZ Sunday, August 12, 2012 4:33 PM
    Sunday, August 12, 2012 4:32 PM
  • I am also having the same problem on Windows Server 2003 machines. I noticed in WindowsUpdates.log, there is a download error:

    FATAL: Update required for C:\WINDOWS\system32\wuweb.dll: target version = 7.4.7600.226, required version = 7.6.7600.256
    WARNING: DownloadFileInternal failed for error 0x80190194
    WARNING: DownloadFileInternal failed for error 0x80190194

    When i try to goto the links manually in IE, I cannot download as if the file doesn't exist. At first i thought it was our network blocking it, but I cannot download it outside of the network either.  Is anyone else seeing this also?  Has anyone contacted microsoft by phone and/or have gotten a solution?

    Monday, August 13, 2012 4:10 PM
  • The solution I found here worked for me.

    I used the French version of the Microsoft Update site and it did not loop. It prompted me to install the ActiveX control and then once it got to the page where it asked me if I wanted to do Express or Custom, I closed that windows and ran the English Microsoft Update without issue.

    • Proposed as answer by MrTech86 Tuesday, April 09, 2013 9:10 PM
    • Unproposed as answer by MrTech86 Tuesday, April 09, 2013 9:10 PM
    Tuesday, August 14, 2012 2:43 PM
  • Visting the site in French, then changing back to English worked for me. Thanks!
    Thursday, August 16, 2012 10:14 AM
  • I've been crawling through threads on this all day and have found the following: Loading the above link to the French language windows update site works, but it's not because the language is different. It's because the URL is slightly different.

    The default Windows update link in XP and server 2003 is as follows: (this one doesn't work right)

    If you insert www. into the link -- even if the language is still English -- all of a sudden it starts working again: (this one should fix it)

    A. Conrad Schissler -- Systems Engineer @ StoneRidge Corp.,

    Thursday, August 16, 2012 8:40 PM
  • your link fix worked like a charm A. Conrad Schissler. Well done mate.
    Sunday, August 19, 2012 6:46 AM
  • Thanks man.  Great find!
    Sunday, August 19, 2012 6:35 PM
  • A. Conrad Schissler - Thanks your solution worked great.  I tried a ton of other solutions and none worked.  
    Sunday, August 19, 2012 7:25 PM
  • Can you believe this Micro$oft crap. It's August 23rd and this is STILL busted. I just installed a NEW Server 2003 x64 and the VERY FIRST update broke it. Took me 30 minutes to find this simple solution. What a Joke.

    Thanks A. Conrad. This solution worked perfect for me. Clearly you DON'T work for Micro$oft.

    Rick Turske

    Thursday, August 23, 2012 8:25 PM
  • I had to spin up a new 2003 VM for a legacy app and I wasted like 20 minutes before finding this thread.  Thanks for the tip; inserting www. into the URL worked like a charm.

    Sr System Engineer | Vision One IT Consulting |

    Monday, December 17, 2012 9:12 PM
  • Thanks Foster and Conrad - gread advice!
    Tuesday, April 09, 2013 2:14 PM
  • Thanks for the fix ACS, how strange. I installed three "Windows Server 2003 with SP2 Standard Edition" VMs on the same 2012 Hyper-V Server at the same time with exactly the same input. During install I left the language as en-US but added a German keyboard, set as default and marked the US keyboard for removal at next restart. Two out of three failed with this error, the first one worked.

    This is clearly a language related bug (user languages are sent to the web server via the browser), there must be a combination of new and old HTTP/Request filters on the legacy (XP/2003) "Microsoft Update" site which causes the loop. Adding "www." at the beginning of the URL seems to bypass this filter/configuration-error/bug.

    This is not a bug related to missing updates. I found that quickly clicking the "Change settings" link at the left of the "looping" Microsoft web site allows you to turn off updates which reverts you to the original "Windows Update". I then installed all updates and tried to switch to "Microsoft Update" again, but the problem returned. It's just a problem with "Microsoft Update" then.

    I wouldn't bet on Microsoft fixing this because it's to do with end of life operating systems and their legacy update web sites they probably just left on to keep people happy. At least your workaround is documented here now, Thanks!

    Key Artefacts

    • Edited by Code Chief Thursday, May 16, 2013 7:58 AM
    • Proposed as answer by Ryan Staats Saturday, November 02, 2013 11:23 PM
    Thursday, May 16, 2013 7:57 AM
  • Key Artefacts,

    I totally agree with your assesment.  I have already built 3 fresh install servers with the same result.  Last year going to the french site worked on an old 2003 server.  But the solution does not work on fresh installs.  What  a shame.  This has been broken for a year now and no fix.

    Thursday, September 12, 2013 4:28 PM
  • Thanks Code Chief.  That fix works in this-year.  :)  The ol' 2012 fix of entering the WWW or using French did not work.

    No longer using "Microsoft Update" and simply sticking to "Windows Update" is the fix.

    • Proposed as answer by FXF_VT Tuesday, November 26, 2013 7:00 PM
    • Unproposed as answer by FXF_VT Tuesday, November 26, 2013 7:00 PM
    Saturday, November 02, 2013 11:23 PM
  • Dear,

    I follow your information and resolved the loop.

    Thanks a lot

    Monday, July 14, 2014 8:23 PM
  • None of these fixes work anymore. Instead of fixing the problem, MS took down the pages. 404 error
    Wednesday, September 17, 2014 6:18 PM
  • I resolved the exact issue in my case (2 Windows 2003 SP with August updates, SQL server) with the following steps:

    1. stop automatic updates service, delete SoftwareDistribution folder from C:\Windows\

    2. copy SoftwareDistribution folder from a working Windows 2003 system

    3. start the  automatic updates service,

    Tuesday, September 30, 2014 1:28 PM
  • In fact none of these solutions worked with our old boxes (win server 2K3, SP2)...but the beautiful work around we did was while the screen loops, selected 'Change Settings' option on the flickering screen--> Show beta products & related updates(under advanced) --> apply changes now --> On the next screen again selected click 'here for windows update'.... It listed out all the pending updates... :) 

    Needed to mention, the windowsupdate.log still has the fatal error message... !!

    Hope this help someone out there...



    Sunday, October 19, 2014 2:51 PM
  • Replacing the WindowsDistribution folder worked perfect. Thanks for the post.

    Doug White

    Wednesday, November 12, 2014 3:44 PM
  • Thanks Manjunwang.  This was the only solution that worked for me (in December 2014).
    Friday, December 12, 2014 5:21 PM
  • Thanks Sandeep this was the only solution that worked really appreciate it
    Friday, January 16, 2015 5:08 PM