none
Windows server 2016 setup IDMUUpgradeComplianceCheck Identity Management for UNIX components are installed? RRS feed

  • Question

  • setup has detected that one or more of the Identity Management for UNIX components are installed. To upgrade your server, uninstall these components. For more information about uninstalling these components, see http://go.microsoft.com/fwlink/?LinkId=518378.

    I am trying to upgrade a 2012 r2 DC to 2016, but i cant get past this error in the installer

    I dont have that component installed and i removed via powershell from technet article.  but still dont work.

    I just did one DC but cant do this one.

    What could this be?

    Thanks

    JK


    JK MCP

    Saturday, October 15, 2016 12:33 AM

All replies

  • Still unable to upgrade my Win server 2012 r2 DC because of this issue, i cant find the cause.

    I was able to upgrade the 2nd DC fine its just this 1st DC i cant upgrade to 2016 RTM.

    Can anyone help as i was hoping to raise my domain functionality level but until i upgrade my remaining DC i cant.

    I dont have any roles or features installed that are in any articles about IDMU.

    What could be causing this?

    Please help.

    thanks

    JK


    JK MCP

    Sunday, October 16, 2016 1:45 PM
  • Hi,

    Thanks for your post.

    Since you haven't installed this component, you could try to install it first and then remove it to have a test.

    Install Identity Management for UNIX Components

    https://technet.microsoft.com/en-us/library/cc731178(v=ws.11).aspx

    Remove Identity Management for UNIX Components

    https://technet.microsoft.com/en-us/library/cc725709(v=ws.11).aspx

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 17, 2016 8:17 AM
    Moderator
  • Didnt work,

    Any more ideas?

    Thanks


    JK MCP

    Monday, October 17, 2016 10:20 AM
  • I've got the same issues, but mine is on a Terminal Server. Going to investigate now and will follow up if I find anything good.
    Monday, October 17, 2016 1:18 PM
  • I avoided the issue by altering the file "compliance.ini", adding a semicolon to the line which includes the IDMUUpgradeComplianceCheck. Let's see what happens after the upgrade completes... I'll follow up soon! 

    I have no idea which component is being flagged wrong by this check though. Microsoft...?

    Tuesday, October 18, 2016 12:33 AM
  • Any follow up on this yet? 
    Monday, October 24, 2016 7:18 PM
  • For those that care. I tried Daniel Sarfati's suggestion above. It seemed to upgrade with no issue.


    Thursday, October 27, 2016 6:20 PM
  • Id actually built a new DC before Daniel Sarfati replied.

    Glad to hear someone was helped from my post.

    Thanks

    JK


    JK MCP

    Friday, October 28, 2016 10:16 AM
  • Hi,

    Thanks for sharing your current progress.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 2:57 AM
    Moderator
  • Just had the same problem during my upgrade.

    I was able to solve it by removing the deprecated feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    #
    
    Remove-WindowsFeature RSAT-NIS

    Regards,

    Daniel

    • Proposed as answer by AlvwanModerator Wednesday, January 25, 2017 1:13 PM
    Friday, January 6, 2017 12:36 AM
  • Hi Daniel,

    Thanks for your kindly sharing.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 25, 2017 1:14 PM
    Moderator
  • I had the same problem -- I'd removed the compnonents per the KB, but setup still complained about them.  Following Daniel's suggestion removing RSAT-NIS resolved the issue completely.  Thanks, Daniel!

    Microsoft: Suggest updating your article to include the RSAT tool as well.

    Friday, February 3, 2017 6:40 PM
  • Thanks! Removing RSAT-NIS solved it for me.
    • Edited by Nanoop Thursday, March 16, 2017 7:11 AM
    Thursday, March 16, 2017 7:10 AM
  • Just had the same problem during my upgrade.

    I was able to solve it by removing the deprecated feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    #
    
    Remove-WindowsFeature RSAT-NIS

    Regards,

    Daniel

    it is working  thanx
    Tuesday, July 11, 2017 7:24 PM
  • This did it for me. Please mark it as the answer and thanks Daniel.
    Wednesday, September 20, 2017 12:57 PM
  • This worked perfectly for me, as well. Thank you.
    Friday, November 17, 2017 1:59 AM
  • Its a old thread, but thx faced the issue on a 2nd DC!
    Tuesday, February 6, 2018 10:35 AM
  • remove-windowsfeature rsat-nis worked for me too even though I had already removed all the remote server tools in the features

    Thanks Daniel!


    http://absoblogginlutely.net

    Friday, March 2, 2018 2:27 PM
  • [SOLVED] for me. 

    Thank you!!!
    Friday, March 2, 2018 11:29 PM
  • Thanks!

    I had attempted:

    • Dism.exe /online /disable-feature /featurename:adminui
    • Dism.exe /online /disable-feature /featurename:nis
    • Dism.exe /online /disable-feature /featurename:psync

    Rebooted but no luck.

    My server 2016 upgrade from 2012R2 only continued after I ran:

    Remove-WindowsFeature RSAT-NIS

    (PS indicated the feature was "depreciated" as well)

    Thanks again!

    Monday, March 19, 2018 5:47 PM
  • In my case, this was the registry key causing IDMUUpgradeComplianceCheck to fail:

    HKEY_CLASSES_ROOT\CLSID\{9A899A50-F96B-11D2-AC78-0008C7726CF7}

    After deleting this key, IDMUUpgradeComplianceCheck passed, and setup continued.

    Saturday, October 13, 2018 2:02 AM
  • Thank you Daniel.

    The stupid article that they reference in the error message tells you how to Disable the thing but not how to actually remove it.  This did the trick. 


    Old enough to know better, young enough to try anyway

    Tuesday, December 25, 2018 9:25 PM
  • This worked for me on upgrading Server standard 2012 R2 which had the Rsat tools installed and i was upgrading to Windows 2019 Standard Server
    Friday, April 12, 2019 8:43 AM
  • Lovely.  An installer issue from 2017 that microsoft still hasn't fixed.  Kudos to you Daniel, this one is still broken in server 2019.  Sigh.  Pull it together MSFT.

    If its worth doing, its worth doing right. Just try getting the CFO to pay for that though...

    Friday, April 26, 2019 4:02 PM
  • Just had the same problem during my upgrade.

    I was able to solve it by removing the deprecated feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    #
    
    Remove-WindowsFeature RSAT-NIS

    Regards,

    Daniel

    Worked for me as well. Cheers Daniel
    Sunday, June 16, 2019 9:20 PM
  • I was able to solve it by removing feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    Remove-WindowsFeature RSAT-NIS
    Thursday, August 8, 2019 10:24 AM
  • Thanks Daniel, this fixed the issue for me.

    Microsoft, please update the article referenced by the setup error to include this fix.

    Wednesday, August 28, 2019 10:54 AM
  • Just had the same problem during my upgrade.

    I was able to solve it by removing the deprecated feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    #
    
    Remove-WindowsFeature RSAT-NIS

    Regards,

    Daniel

    Great! It worked to me!
    Thursday, November 21, 2019 3:08 PM
  • Just had the same problem during my upgrade.

    I was able to solve it by removing the deprecated feature "RSAT-NIS" using Powershell:

    # Run as Administrator.
    #
    
    Remove-WindowsFeature RSAT-NIS

    Regards,

    Daniel

    Solved for me as well

    Sunday, March 29, 2020 3:06 AM
  • Worked for me in Server 2019.  Had tried everything from MS article.  Was going to bypass the actual check (Edit sources\compliance.ini: Remove or comment the line which contains "IDMUUpgradeComplianceCheck") but tried this first.  Thanks Daniel
    Wednesday, May 6, 2020 8:36 AM