Remote management problem of server on workgroup network


  • I am setting up a new Windows server (2012 Core) remotely managed from a Windows 8 machine, both are on a workgroup not a domain, and I'm having a real issue with server manager.

    What's working:  I have server manager able to find the server and pull basic management info back.  I can open Computer Management for the remote machine and powershell and remote desktop just fine.  I can also use Hyper-V Manager, at least it starts and discovers the server.

    What's not working: When I go to File and Storage Services in Server Manager and try to refresh the volume or disk information I get an error.

    "Error occurred during enumeration of disks: The WinRM client cannot process the request.  If authentication scheme is different from Kerberos..."

    The message goes on to tell me that I should have the server name in the trustedhosts list - I've actually done that.  I was getting this error yesterday to just pull the basic management info and get the computer management working.  The problem in this case was the firewall on both the client and server.  On the client I've disabled the firewall.  On the server I have enabled the remote volume management rules and the event log rules.  That got the Server Manager working and the Computer Management working.  

    One thing is that once I'm in the Computer Management app I can see the disks and storage fine, I just can't see it from Server Manager.

    Any help would be appreciated.

    Tuesday, November 27, 2012 3:54 AM


All replies

  • Tim, Thanks for the link, I had used that as one of the references early on so had done all those steps.

    I re-verified MMC with the disk management snap-in and Computer Management work fine but Server Manager only works for the basic discovery not the File and Storage Services.  Does Server Manager use WinRM where the other two don't?  I'm going to try just turning off the firewall altogether on the server as an experiment to see if that's it or something else.

    Wednesday, November 28, 2012 3:47 AM
  • Verify that you have created on server user with SAME username and password as on windows 8 pc. Grant it administrator rights on server. Turn off firewalls. Check that remote management services (RPC etc.) on server up and running. I think it helps.

    Wednesday, November 28, 2012 3:58 AM
  • Thanks guys, I did an experiment and turned off firewalls on both sides completely, still no joy.

    Next experiment, I ran the winrm commands from the command line of the client machine to enumerate the Win32_DiskDrive, Win32_logicalDisk, MSFT_PhysicalDisk, Win32_Volume classes and all executed fine.  Does anyone know what WMI classes Server Manager tries to enumerate when doing the file and storage services?  I can manually try all of those classes to see if they work.  At this point I'm wondering if there's some bug in Server Manager since I can run the winrm commands from the command line without a problem.

    Wednesday, November 28, 2012 4:37 AM
  • For everyone looking to do this, I have resolved this issue and documented the full steps in my personal blog.

    Windows Server Remote Management

    Hope this helps other folks working on this.

    • Marked as answer by B787-9 Wednesday, January 16, 2013 6:51 PM
    Wednesday, January 16, 2013 6:51 PM