none
Windows Server 2012 R2 Session Broker - Offline Server Detection

    Question

  • We have two Windows Server 2012 R2 VMs, RDS3 and RDS4, configured with RDCB and RDSH role.

    RDCB is configured in High Availability mode with DB on RDS3.

    Everything works fine when both servers are running.

    However, when RDS4 is offline, we still see RDS3 redirecting to RDS4.

    Following events are logged on RDS3:

    --------------------------------------------------------------------------------------------------------------

    Log Name:      Microsoft-Windows-TerminalServices-SessionBroker-Client/Operational
    Source:        Microsoft-Windows-TerminalServices-SessionBroker-Client
    Date:          5/12/2014 11:49:50 AM
    Event ID:      1307
    Task Category: RD Connection Broker Client processes request from a user
    Level:         Verbose
    Keywords:      
    User:          NETWORK SERVICE
    Computer:      RDS3.sysnet.local
    Description:
    Remote Desktop Connection Broker Client successfully redirected the user sysnet\testuser to the endpoint RDS4.sysnet.local.
    Ip Address of the end point = 192.168.1.45

    ------------------------------------------------------------------------------------------------------

    And then after 5 minutes following is logged.

    ------------------------------------------------------------------------------------------------------

    Log Name:      Microsoft-Windows-TerminalServices-SessionBroker/Operational
    Source:        Microsoft-Windows-TerminalServices-SessionBroker
    Date:          5/12/2014 11:55:19 AM
    Event ID:      819
    Task Category: RD Connection Broker processes connection request
    Level:         Verbose
    Keywords:      
    User:          NETWORK SERVICE
    Computer:      RDS3.sysnet.local
    Description:
    This connection request has timed out. User could not log on to the end point within the alloted time. Remote Desktop Connection Broker will stop monitoring this connection request.

    Why is the offline member detection not working?

    We have also checked the settings in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tssdis\Parameters as per following:

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/050ed3c2-1356-4c69-8337-1be735494670/session-broker-heartbeat-solution?forum=winserverTS

    Dinesh Sharma

    Monday, May 12, 2014 6:42 AM

Answers

  • the thread you've posted should be working, it doesn't mention anything about graceful or not, it's doing a heartbeat ping so regardless of how you took the box down it should still work. I'm wondering if this is not having the desired effect because you're sharing the role of RDSH and RDCB
    Friday, May 23, 2014 6:53 PM
  • OK, here is the problem I finally figured out.

    The problem is seen when RDCB host also cohosts RDSH role and is part of same deployment.

    Although the deployment wizard allows that, but i don't think it is supported. RDCB will not redirect to it's own RDSH even if it is member of session collection.

    Everything works fine when RDCB is on a different server.

    • Marked as answer by Dinesh_Sharma Monday, July 21, 2014 4:50 AM
    Monday, July 21, 2014 4:49 AM

All replies

  • It looks to be expected behaviour. Since you have an existing connection on the server it is trying to redirect to the same session. However the session host is down hence it is unable to connect.

    However  as far as I know any new connections shouldn't be affected.


    Hari Kumar --- Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights

    Monday, May 12, 2014 8:35 AM
  • No, it's about new connections. I created a new user and tried to log on to this farm for the first time. It is trying to send each and every connection to RDS4 which is offline. Even if there are some disconnected sessions on an offline server, they should be purged on detecting the server as offline.
    Monday, May 12, 2014 10:31 AM
  • As far as I know I can tell you this. Is the connection broker gracefully shutdown or turned off/unplugged from network? If it doesn't shutdown gracefully then it is expected to see this behaviour. It will still use DNS round robin to encounter the RDCB and it will fail if the RDCB is not available. Only a graceful shutdown will mark the DB as offline so that active connection broker is used for new connection.

    Hari Kumar --- Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights

    Wednesday, May 21, 2014 2:27 AM
  • "If it doesn't shutdown gracefully then it is expected to see this behaviour. It will still use DNS round robin to encounter the RDCB and it will fail if the RDCB is not available. Only a graceful shutdown will mark the DB as offline so that active connection broker is used for new connection."

    So you mean to say, when two connection brokers are configured in HA mode, then the HA is only good if one of the connection broker is gracefully shutdown. This really beats the purpose of HA. What if I loose the hardware ? My point is very simple. Active connection broker is redirecting users to a dead RDSH, and even after getting eventid 819 the offline detection mechanism should kick off and remove that RDSH from DB.


    • Edited by Dinesh_Sharma Saturday, May 24, 2014 4:43 AM Quoting Hari's Comment
    Friday, May 23, 2014 11:46 AM
  • the thread you've posted should be working, it doesn't mention anything about graceful or not, it's doing a heartbeat ping so regardless of how you took the box down it should still work. I'm wondering if this is not having the desired effect because you're sharing the role of RDSH and RDCB
    Friday, May 23, 2014 6:53 PM
  • OK, here is the problem I finally figured out.

    The problem is seen when RDCB host also cohosts RDSH role and is part of same deployment.

    Although the deployment wizard allows that, but i don't think it is supported. RDCB will not redirect to it's own RDSH even if it is member of session collection.

    Everything works fine when RDCB is on a different server.

    • Marked as answer by Dinesh_Sharma Monday, July 21, 2014 4:50 AM
    Monday, July 21, 2014 4:49 AM