locked
Timesync issues with NTP after Linux VM restart RRS feed

  • Question

  • Hello experts,

    I have a Custom Linux VM running on Windows Server 2012 R2 Hyper-V. I have Linux Integration Services v3.4 installed and running.

    When I configure NTP server, the VM time is getting updated correctly with the time from the NTP server.

    But when I reboot my VM, the time is getting updated only after a significant delay (~8 minutes). 

    Conversely, if I remove NTP server setting from my VM, time is not getting updated with local time. Only after VM reboots, the time gets updated with local time.

    I have tried configuring "divider=10' in my kernel commandline with no success.

    Anyone got an idea on how to get the time syncing correctly with the NTP server after VM reboot ?

    Regards,

    Saleem

    • Moved by BrianEhMVP Wednesday, August 12, 2015 4:21 PM
    Tuesday, August 11, 2015 1:50 PM

All replies

  • Hi Saleem,

    check the Settings of your Linux VM inside the Hyper-V Manager. There are settings for the Integration Services.

    One of these setings are for the Time synchronization between the Host and the Guest -->

    

    -marian


    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke# If this answer was helpfull, plz mark it as asnwered! Thanks#

    • Proposed as answer by Alex Lv Monday, August 17, 2015 6:03 AM
    Tuesday, August 11, 2015 3:31 PM
  • Hi Marian,

    Yes. I enabled the Time synchronization option in Settings due to which I am facing the issue.

    If I uncheck this Time sync option, then Time is updating correctly with NTP server with reload.

    - Saleem

    Wednesday, August 12, 2015 12:19 PM
  • Time synchronization only happens on VM start with Linux guests. We recommend using NTP to update the guest's clock otherwise the clock will drift.


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    • Proposed as answer by Alex Lv Monday, August 17, 2015 6:03 AM
    • Unproposed as answer by A Saleem Monday, August 17, 2015 6:52 AM
    Thursday, August 13, 2015 11:05 PM
  • Yes. But the problem is with the time delay in updating the time with NTP after a VM restart.

    With the "Time Synchronization" option checked in VM asettings, I am getting a delay of approx. 10 minutes to sync with NTP time after the VM restarts.

    -Saleem_

    Monday, August 17, 2015 6:52 AM
  • With the option checked, the time should be set once during VM start and should have no effect on NTP. You mention LIS 3.4 drivers integrated into your customer kernel, you might consider integrating the latest upstream drivers as many updates and fixes are included.

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    • Proposed as answer by Alex Lv Thursday, August 27, 2015 7:14 AM
    Monday, August 17, 2015 7:48 AM