locked
BSOD Hyper-V Server 2012 R2 - Critical Process Died RRS feed

  • Question

  • I am running Windows Hyper-V Server 2012 R2 (Server Core) on three servers.  Unfortunately none of them have identical hardware configurations - thus I can't easily tell if there is some compatibility problem between a Microsoft update and my hardware.  All three systems are setup to automatically download updates.

    A few weeks ago one of the systems seemed to be rebooting regularly.  After connecting a monitor I saw a BSOD with a message "Critical Process Died."  I'm not 100% certain of this, but these BSOD reboot problems seemed to have started shortly after getting a recent automatic update(s)?

    I have checked the Event Logs and looked for dumps or other logs, but haven't been able to locate anything that explained the chronic BSOD failures on the one server.  Nor have I found anything that tells me what critical process died.

    After various attempts to fix the problem were unsuccessful I reformatted the drive and reinstalled Hyper-V Server 2012 R2.  The server seems to work okay with the intial re-installation of Hyper-V Server 2012 R2.

    I configured the server and then start to download all the availlable patches.  After one (or two?) reboots I typically find only a single patch (KB2919355) left to be installed.  This seems to be the equivalent of the Windows 8.1 Update (and thus a required patch to get further patches)?

    Typically when I try and install KB2919355 I'll get a BSOD during the installation process.  I have also tried rebooting and looking for new patches, after the initial BSOD, and I'll get a list of some other patches.  KB2919355 seems to be a group of fixes?  And it seems as though some part of KB2919355 got installed, but then I get the BSOD.  And after the reboot what I'm seeing is the list of the group (from KB2919355) which did not get installed due to the BSOD?

    I continued on (rebooting if a BSOD occurred) and eventually got all patches installed.  But I still get occasional BSOD failures with Critical Process Died message.  The message says something about writing information to disk with 0% complete, but that number never changes.  After a while the system simply reboots.

    After all patches were installed I came across the following commands and tried to use them.  The first time I attempted to use DISM I got a BSOD failure.  But I was eventually able to run both SFC and DISM.  Neither seemed to show any problems were found.

    sfc /scannow

    dism /online /cleanup-image /restorehealth

    In one (of several) attempts to re-install Hyper-V Server 2012 R2 I made sure my BIOS was updated to the latest version and got the most recent driver for my Areca ARC-1222 controller.  Of the three servers one has the Areca RAID6 controller, one has an LSI RAID6 controller, and one is using Storage Spaces.  The LSI and SS systems have the same type of CPU, motherboard, and RAM. My Areca system has an older type of CPU, motherboard, and RAM.

    This morning I tried to re-install Hyper-V Server 2012 R2 again.  After the first group of patches were installed and a reboot I got another large list of patches.  I don't recall off hand if this was the exact same order of patches that happened on prior attempts or not?  I had thought there was only one large list of patches, reboot, and then KB2919355 was the only remaining patch?  While trying to install this second large list of patches I got a BSOD.  I didn't notice whether or not KB2919355 was included in this second list or not?  These kind of inconsistent results/observations are why I'm not 100% sure that KB2919355 is causing my BSOD problems.  I believe KB2919355 is installed and working on my other two systems?  Which might imply some type of a hardware problem with this system?

    Unless someone has a better suggestion then later tonight I'll try re-installing Hyper-V Sever 2012 R2 again, but stopping before KB2919355 gets installed.  It seems to me the system is stable at this point, but I'll leave it that way for several hours to verify I don't get another BSOD.  If I don't have any problems without KB2919355 installed that implies my hardware is okay.  Although I suppose there could be some incompatibility between KB2919355 and my hardware and not simply a software problem with KB2919355?

    I would appreciate suggestions others may have on how to rectify this problem.  Especially any thoughts on how to determine what critical process is failing and causing the BSOD.

    I did come across a webpage about a whole list of symptoms related to KB2919355, but my specific problem didn't seem to be mentioned.

    http://social.technet.microsoft.com/Forums/en-US/c203334f-7ae5-4716-aeb5-0fa3d60da216/kb2919355-issues-being-investigatedtracked?forum=winserver8gen

    Thanks for any assistance.

    Theokrat



    • Edited by WindOfChange Wednesday, June 4, 2014 8:14 PM Correction to Title
    • Changed type Alex Lv Thursday, June 5, 2014 3:39 AM
    • Changed type WindOfChange Tuesday, June 10, 2014 2:13 PM
    Friday, May 30, 2014 4:09 PM

Answers

  • The Areca ARC-1222 RAID controller seems to have been the source of the BSOD problems.  I attached a single drive to one SATA port and was able to perform a full re-installation of Hyper-V Server 2012 R2 without any problems.

    The RAID controller was still attached, but not used as the boot drive.  The system has been running for over 12 hours without any problems.


    Theokrat

    • Marked as answer by WindOfChange Tuesday, June 10, 2014 2:13 PM
    Tuesday, June 10, 2014 1:42 PM

All replies

  • During another re-installation of Hyper-V Server 2012 R2 I got a BSOD when trying to install the first set of patches.  So that eliminated KB2919355 as a suspect.

    I installed Windows 7 on the machine and ran the memory tester in the Extended mode.  That took several hours to complete, but did not find any problems.

    I got into the Areca RAID BIOS and found that one drive of my RAID6 configuration showed up as "failed."  Since this is a cheap SATA drive I suspect it simply had a time-out and I added it back into the RAID array and started a rebuild.

    Somehow the audible alarm on my RAID controller seems to have been turned off.  But it is also odd that the RAID BIOS didn't seem to show any error during the many times I rebooted the computer.

    I am in the process of re-installing Hyper-V Server 2012 R2 now.  

    If this was the source of my problem and the BSOD was due to not being able to communicate with the RAID controller that seems a bit odd.  Shouldn't Hyper-V have been able to continue to run for a time or at least given me a more descriptive error message (pointing to the HDD)?

    Also the RAID controller itself should have continued to function, albeit slower than normal, with the one failed drive?


    Theokrat

    Sunday, June 1, 2014 1:51 PM
  • Completed the RAID rebuild then tried to install a fresh copy of Hyper-V Server 2012 R2.  System crashed with the same BSOD "Critical Process Died" while trying to install the first set of patches.

    Still have not been able to locate any log or explanation for exactly what the critical process is that keeps dying.


    Theokrat

    Monday, June 2, 2014 2:35 AM

  • Hi,

    Unfortunately, the available information is not enough to have a clear view of the occurred behavior, it is not an efficient way to work in this community since we may need more resources, for example memory (an application) dump or ETL trace, which is not appropriate to handle in the community. I‘d like to suggest that you submit a service request to MS Professional tech support service so that a dedicated Support Professional can further assist with this request.

    Please visit the below link to see the various paid support options that are available to better meet your needs.
    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone


    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, June 5, 2014 3:39 AM
  • Alex,

    I'll wait a while to see if anyone else has run into a similar problem as mine.  They may have a suggestion on how to resolve the issue that is less involved than what you're describing?

    My RAID controller, for the first time, put out an alert I'd never seen before.  Something about the CPU being undervolted.  I haven't had time quite yet to swap out the power supply, but I'm wondering if that is somehow flaky and causing this odd failure?

    I used Windows 7 to run a stress memory test and that didn't find any problems.  I also ran Prime95 to stress the CPU and the system seemed to crash once while I was away for several hours?  As it was back at the logon screen when I returned.  I wasn't sure if Prime95 finished it's run and somehow caused the system to reboot?  Or if the same Critical Process Died happened?

    Thanks.


    Theokrat

    Thursday, June 5, 2014 2:22 PM
  • Sorry, I have not help for you, but I have same problem on my HP notebook after install this patch 2919355 (clean install, no trith party except some win auto install drivers...). OS w8.1ent. So it seems like win problem, not hw or driver... Minidump is not writen, so I can not analyze crash...

    This cumulative patch is ugly. In my case it have 890MB, and kill my notebook with charm, now second time an counting :o).

    Regards

    JL



    • Edited by lundakjiri Thursday, June 5, 2014 3:41 PM
    Thursday, June 5, 2014 3:02 PM
  • I tried swapping the power supply, but still ran into the BSOD.  I've run a stress test of the CPU and memory.  Didn't find any obvious problems.

    I'm starting to suspect a problem with the RAID controller and am planning to get a seperate drive and boot from that drive and use the RAID drives as data disks to stress test them.  If the problem is with the RAID controller I'm expecting I will not get the BSOD errors, but should get some type of error when trying to stress test the RAID drives?

    If anyone else has run into this problem I'm still looking for suggestions on how to isolate and/or fix the root cause.


    Theokrat

    Monday, June 9, 2014 2:53 PM
  • The Areca ARC-1222 RAID controller seems to have been the source of the BSOD problems.  I attached a single drive to one SATA port and was able to perform a full re-installation of Hyper-V Server 2012 R2 without any problems.

    The RAID controller was still attached, but not used as the boot drive.  The system has been running for over 12 hours without any problems.


    Theokrat

    • Marked as answer by WindOfChange Tuesday, June 10, 2014 2:13 PM
    Tuesday, June 10, 2014 1:42 PM
  • FYI - I see on newegg.com reviews quite a few other people have been having similar problems with this RAID controller.  One mentioned getting the same CPU undervolt error I saw.

    It's too bad that Microsoft didn't give a more descriptive error message, i.e., more than just "Critical Process Died." Given the problems with the RAID controller (and thus the HDD) I can understand why no error was logged.  But I'd expect the error message itself to point me towards the HDD.

    I wasted a lot of time trying to stress the CPU, RAM, replace the power supply, etc.  Since the RAID controller log itself wasn't showing any errors I did not initially suspect that could be the root cause of my BSOD problems.


    Theokrat

    Wednesday, June 11, 2014 5:48 PM
  • Hi Theokrat,

    I know that your post is already answered, but I'd like to share something with you:
    As I was going to reinstall one DL380 G7 running Hyper-V 2012 R2, I entered the Array Config Utility and deleted the Array while the server was running. Array Controller was a P410i.

    The result was "A Critical Process Died"

    So maybe something killed you Array.

    Best Regards,
    Jens


    jensit.wordpress.com

    Friday, February 27, 2015 5:08 PM
  • A few days after resizing the VHD size had the same problem with a virtual server, summarizing what I did to solve was power off the virtual server, copy to another local and delete. After return from the copy "died of error" disappeared.
    Tuesday, October 27, 2015 8:08 PM
  • Hey i have similar issue with a hyper v guest server on 2016

     before the guest was 2008 and have always critical object termination bsod

    and now i create new machine guest srv2016

    and have the same problem and now h" critical process died"

    https://social.technet.microsoft.com/Forums/en-US/450761a2-ed56-478f-90b1-94e5c53a6c62/my-guest-hyperv-on-2008-r2-bsod-critical-object-termination?forum=winserverhyperv

    i need really to understand

    the physic server is DL380 G7 and have p410i controller too

    how u resolve this issue ?

    Saturday, April 27, 2019 5:05 PM