none
Screen lock timeout Group Policy RRS feed

  • Question

  • Hello,

     

    I am trying to create a GP to enforce a screen lock timeout for my Windows 7 Pro 64 bit clients (but not necessarily a screensaver) that belong to a Windows 2003 Server 32 bit domain. 

     

    I have attempted the following from both a Windows 2003 Server and also from a Windows 2007 Pro 64 bit client using Remote Server Administration Tools but cannot get the GP to take effect on a test OU & test Windows 7 Pro 64 bit client.

     

    After adding a linked GPO, I have enabled the following under UserConfig\AdministrativeTemplates\Control Panel\Personalization

     

    1. Enable screen saver
    2. Force specific screen saver (tried adding one & also leaving as blank)
    3. Password protect the screen saver
    4. Screen saver timeout to 60 seconds

     

    Once done, I ran gpupdate /force on the client & it successfully applied the default domain policy.

     

    I must be missing a step or two so any helpful suggestions would be appreciated.

     

    Thank you…

     

    Wednesday, June 19, 2013 2:17 PM

Answers

  • Thanks for all the replies.  I will continue this when I return from vacation.

    • Marked as answer by xmr25 Monday, June 24, 2013 3:50 PM
    Monday, June 24, 2013 3:50 PM

All replies

  • This is what we use and it works

    If you check rsop does it show that the settings are being applied?

    Wednesday, June 19, 2013 2:22 PM
  • Thanks for your reply JepthaT.

    When I try to run RSOP logging from W2003 srvr AD Users & Computers on the client, I get an error.  Please see screenshot below.

    I confirmed RPC is running on both the server & client & WMI is also running on the client.

    I also found a few of these in event logs on the client:

    Thank you


    Wednesday, June 19, 2013 3:26 PM
  • Funny - I didn't know that there's an event source "gupdate"... Who created this event?

    And where to did you link your GPO? Since this is a user setting, it must (!) be linked to an OU where users reside. Unless you do some loopback...


    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!

    Wednesday, June 19, 2013 3:52 PM
  • Thanks for all the replies.  I will continue this when I return from vacation.

    • Marked as answer by xmr25 Monday, June 24, 2013 3:50 PM
    Monday, June 24, 2013 3:50 PM
  • update? 
    Monday, March 23, 2015 5:57 PM
  • To Lock Workstation you will use following command: 

    %windir%\system32\rundll32.exe user32.dll,LockWorkStation

    In GPO: Enable ScreenSaver. Enable Screen server executable name with the above. Enable and set Screen Server time out. 

    Let me know if it worked. 

    • Proposed as answer by AAACopyJeff Friday, March 4, 2016 1:43 AM
    Monday, March 23, 2015 6:51 PM
  • Worked for me, thanks MikekMS
    Monday, October 12, 2015 6:08 PM
  • Thanks dude. Works like a charm
    Tuesday, April 5, 2016 10:30 PM