none
Remote Desktop Connection disconnects every 10 mins (externally) RRS feed

  • Question

  • Hi,

    Just wondering if anyone could help me. I have a new Dell T440 in a school and RDC is disconnecting every 10 min or so. Please note this only happens when connecting to the server from an external site. If I am on a PC within school and create an RDC session its fine!

    I have done the below and rebooted but it’s made no difference.

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Connections\

    Configure keep-alive connection interval     Enabled

    Keep-Alive interval:     1

    Using Hyper-v the server hosts three Virtual servers, Sims, file & print and the DC.  I can connect to any of these remotely via RDC and the connection is stable. The issue just seems to be with the Dells physical version of Server 2016. I have connected Dell and worked with them to upgrade to the latest firmwares and Drivers. Following this Dell has now advised me to log ticket with MS.

    This one has stumped me tbh. I have event gone down the route of replacing the router and switches but that's also made no difference either. I am loathed to rebuild the server without exploring every other avenue first. 

    Any help would be really appreciated.

    Cheers

    Mick


    Mikehawo

    Monday, September 16, 2019 7:32 AM

All replies

  • Hi,

     

    1. Could you please confirm that whether this disconnection occurred during active remote session or idle/minimized session?

     

    2. May I know if you are using same user account when remote from outside or inside? If yes, kindly check if any session limit GPO has been enabled on the account.

     

    3. Please also check if any timeout setting in router/firewall/NAT device.

     

    Best Regards,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 17, 2019 3:00 AM
  • Hi Jenny

    The session times out while you are using it. Disconnects for about 30 seconds then reconnects. It does this constantly.

    I have tried using both the built in Administrator account and my own domain admin account. - still the same.

    I have been in touch with the schools broadband supplier and I have had them check all the router settings and firewall. They assure me all is correct. If you think about it though it cant be the router or the switches otherwise the virtual servers that are being hosted on the server would surely have the same problem, but they don't.

    I have checked on group policy as per other guides and I cant see anything that could cause it. I'm at the school this afternoon again so I can send you the event logs and some screen dumps of the GPO is you like?

    Cheers

    Mick


    Mikehawo

    Tuesday, September 17, 2019 6:55 AM
  • Hi,

     

    1.Quoted possible cause of router and firewall setting from TP, that's why we suggest to check firewall setting as well.

     

    The common case is having idle sessions disconnect after 10/15/20 minutes because of a router firewall device set to terminate idle TCP sessions after 10/15/20 minutes.  Enabling RD keep-alives as I suggested above usually fixes this.  Another way to solve for this issue is to adjust the timeout setting in router/firewall/NAT device that is causing the issue.

     

    https://social.technet.microsoft.com/Forums/en-US/84d53e86-a464-4e77-b448-d89af5787863/remote-desktop-users-getting-disconnected-every-910-minutes?forum=winserverTS

     

    2. For GPO of timeout of settings, please refer to first point in below link:

     

    Remote Desktop Timeout settings

     

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/00c2252b-8ec0-489f-8da2-07a434a9b5a2/forum-faq-restrict-number-of-active-sessions-in-rds-2012-and-2012-r2?forum=winserverTS

     

    3.Per your description, issue only occurred when remote from externally, which leads us to think about the difference between internal and external as well as accounts used during two sessions. When sharing details, please always remove your personal data as this is a public forum to protect your info.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 18, 2019 2:01 AM
  • Hi,

    I am checking to see how things are going there on this issue. Is there any update? 

     

    And you can mark helpful reply as Answer, which would be very efficient for other forum community members to find useful information.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 24, 2019 2:23 AM