none
Task Scheduler - task creation error on Windows 2008 Server x64

    Question

  • Hi,

    I have a problem with Task Scheduler on my Windows 2008 x64 Server.

    The main problem is if I try to create a tasks from the Task Scheduler, when the dropdown box for 'Configure for' is selected as "Windows Server 2003, Windows XP, or Windows 2000" - is selected, when I press OK to create the task an error pops up "An error has occurred for task 'name', The following error was reported: 2148073494" and the task is not created.

    If I select the 'Configure For' box as "Windows 2008, Windows Vista etc" it creates fine.

    Why this is a problem is I also can't create scheduled tasks from any programs - ViceVersa or Sophos - both report permissions errors when creating the task. This used to work a few months ago.

    I'm guessing this could be due to invalid registry permissions somewhere but I can't 'see' anything wrong... Someone suggested

    Any ideas are most welcome.

    Thanks in advance :)
    • Moved by Karen Ji Wednesday, June 16, 2010 7:04 AM (From:Windows Server 2008 R2 General)
    Tuesday, June 15, 2010 11:13 PM

Answers

  • Hi My_public_identity,

     

    What do you mean by “NB task” that cannot configure for Windows 2003, XP? Can you create the same task in other computers successfully? What task are you trying to create?

     

    Please make sure your task script is not surrounded with quotes in the Program/Script entry of Action tab.

     

    For the other programs, I’m not sure how they work and what kind of permission they need. I suggest you contacting the vendor for further support.

     

    If nothing would work after you’ve tried all that you can think of. I would suggest performing an in-place upgrade to fix the corrupt files if the server is not a DC.

     

    Regards,

    Karen Ji


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Karen Ji Monday, June 21, 2010 1:34 AM
    Thursday, June 17, 2010 7:12 AM
  • Just an update to this - I finally figured out the problem and fixed it!!

    It's really simple, just go to "C:\Documents and Settings\All Users\Microsoft\Crypto\RSA"

    RENAME or delete the folder "S-1-5-18"  

    Try creating a Task -> The problem is now fixed!! You don't even have to restart the computer, the S-1-5-18 folder is re-created automatically :)

    Wednesday, August 18, 2010 1:58 PM

All replies

  • Hi My_public_identity,

     

    If you convert the error code 2148073494 to hexadecimal, it’s 0x80090016, which means keyset does not exist. It occurs because the Protected Storage service is not started. Please start the service by typing net start "protected storage" at a command prompt and see whether the problem goes away.

     

    Additionally, I don’t quite understand your meaning of “I also can't create scheduled tasks from any programs”. Could you please provide more information about it?

     

    1.       What kind of task do you need to create?

    2.       Does the user account that the task run as has the local administrator rights?

    3.       Are there any error logs in the event viewer for the task scheduler? Please post the error here for further troubleshooting.

     

    If you would like to set a task to run a batch job with a non-admin account, please grant user read and execute permissions to Cmd.exe that the batch job runs under. To do this, please follow these steps:

     

    1.

        Click Start, and then click Windows Explorer.

    2.

         Locate and then right-click the Cmd.exe file. The Cmd.exe file is located in the %windir%\System32 folder.

    3.

         Click Properties.

    4.

         Click the Security tab.

    5.

         Click Add.

    6.

         In the Enter the object names to select box, type the user name that the batch job runs under, and then click OK two times.
         Note When you add the user, the user is automatically granted Read and Execute permissions.

    7.

         Click Yes when you are prompted to continue.

    Alternatively, you can also grant read and execute permissions for the Cmd.exe file to the Batch group, which permits all batch processes to run the command processor. To do this, please follow the steps below.

     

    1.

        Click Start, and then click Windows Explorer.

    2.

         Locate and then right-click the Cmd.exe file. The Cmd.exe file is located in the %windir%\System32 folder.

    3.

         Click Properties.

    4.

         Click the Security tab.

    5.

         Click Add.

    6.

         In the Enter the object names to select box, type the user name that the batch job runs under, and then click OK two times.
         Note When you add the user, the user is automatically granted Read and Execute permissions.

    7.

         Click Yes when you are prompted to continue.

     

    Regards,

    Karen Ji


    This posting is provided "AS IS" with no warranties, and confers no rights.

     

    On July 1st we will be making this forum read only. After receiving a lot of feedback from the community, it was decided that this forum is a duplication and therefore redundant of the General Forum. So, until July 1st, we will start asking customers to redirect their questions to the General Forum. On June 11th, CSS engineers will move any new threads to the General Forum.

     

    Please post a reply to the announcement thread if you have any feedback on this decision or the process. You can also email WSSDComm@microsoft.com.

    Wednesday, June 16, 2010 8:38 AM
  • Hi Karen,

    Thanks for your reply.

    Unfortunately the protected storage service was already started, I tried restarting it but it made no difference. I also checked that it was running under the Local System account but that did not make any difference.

    I tried changing the permissions of cmd.exe to everyone but this didn't make any difference either - I can't even CREATE the task yet alone run one.

    NB task creation works fine when i select Configure for: Windows 2008 etc.. but when I select Configure For: Windows 2003, Windows XP thats when it fails to create.

    As for other programs - if for example I go to Sophos Antivirus, Scheduled scans and try and schedule a scan, it then says "Invalid Permissions" when it actually goes to create the scheduled scan - which would normally create the job in task manager - so the problem is clearly related.

    This also occurs in the Synchronisation program ViceVersa which has a "scheduled task" dialog - the task also fails to create - when it asks for the 'username and password to create the account' its says "invalid password" regardless of what user account (domain admin, local admin, etc) is used.

    These programs work fine from our other Windows 2008 server, just this particular one is broken - i'd imagine i'd have the same problem with any program that attempts to create a scheduled task in task scheduler.

    In the Event viewer the following errors are generated:

    Task Compatibility module failed to update task "User_Feed_Synchronization-{D93C0FC4-CEC0-4970-BC82-A6B3C3C85D55}.job"  to the required status 0. Additional Data: Error Value: 2148073494.

    Task Compatibility module failed to update task "User_Feed_Synchronization-{D93C0FC4-CEC0-4970-BC82-A6B3C3C85D55}.job" . Additional Data: Error Value: 2148073494.

    Task Scheduler failed to start Task Engine ""  process due to an error occurring in "LUAIsElevatedToken" . Command="taskeng.exe" . Additional Data: Error Value: 2147943645.

     

    Hopefully that yeilds some answers...

    Thanks in advance :)

     

    Thursday, June 17, 2010 12:31 AM
  • Hi My_public_identity,

     

    What do you mean by “NB task” that cannot configure for Windows 2003, XP? Can you create the same task in other computers successfully? What task are you trying to create?

     

    Please make sure your task script is not surrounded with quotes in the Program/Script entry of Action tab.

     

    For the other programs, I’m not sure how they work and what kind of permission they need. I suggest you contacting the vendor for further support.

     

    If nothing would work after you’ve tried all that you can think of. I would suggest performing an in-place upgrade to fix the corrupt files if the server is not a DC.

     

    Regards,

    Karen Ji


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Karen Ji Monday, June 21, 2010 1:34 AM
    Thursday, June 17, 2010 7:12 AM
  • Thanks for your reply,

    by "NB Task" i meant "Note Well" .. basically if you go to Task Scheduler... Click Create Task... Create ANY task - ie type in a name.. select Action as say calc.exe for the calculator... select the dropdown box at the bottom of the dialog as "Configure For: Windows 2003, XP"  and press OK then it fails with that error message..


    If i change that dropdown box to "Configure for: Windows 2008, Windows Vista" etc.. then the task is created without error.

    Your right - I'm probably just going to have to cut my losses and do an inplace upgrade... but i'm just trying to exhaust all possibilities first as the system is heavily used (terminal server). :)

    Thursday, June 17, 2010 7:22 AM
  • Hi My_public_identity,

    Please make sure to select "Configure for: Windows 2003, xp" on the general tab first, then set other triggers and actions. Some triggers and actions won't work on Windows 2003, XP.

    If nothing would work after you've tried all that, an in-place upgrade is the last option.

    Regards,

    Karen Ji


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 21, 2010 1:37 AM
  • Hi Karen,

    Thanks for trying to help, unfortunately that didn't work, I'll have to do an in-place upgrade sometime.

     

    Tuesday, June 22, 2010 1:25 AM
  • Just an update to this - I finally figured out the problem and fixed it!!

    It's really simple, just go to "C:\Documents and Settings\All Users\Microsoft\Crypto\RSA"

    RENAME or delete the folder "S-1-5-18"  

    Try creating a Task -> The problem is now fixed!! You don't even have to restart the computer, the S-1-5-18 folder is re-created automatically :)

    Wednesday, August 18, 2010 1:58 PM