DistributedCOM Error ID 10010


  • In My Windows server 2008 R2 OS in the Event Viewer there is an error pertains as DistributedCOM Error ID 10010 states-(The server {AAC1009F-AB33-48F9-9A21-7F5B88426A2E} did not register with DCOM within the required timeout.) What is this error? And What is the remedy for this error?

    - System
    - Provider
    [ Name] Microsoft-Windows-DistributedCOM
    [ Guid] {1B562E86-B7AA-4131-BADC-B6F3A001407E}
    [ EventSourceName] DCOM
    - EventID 10010
    [ Qualifiers] 49152
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2011-12-04T10:52:59.000000000Z
    EventRecordID 24862
    - Execution
    [ ProcessID] 0
    [ ThreadID] 0
    Channel System
    - EventData
    param1 {AAC1009F-AB33-48F9-9A21-7F5B88426A2E}

    Sunday, December 04, 2011 6:26 PM


  • DCOM Event ID 10010



    1. NTFS permissions have been locked down.

    2. Dll's have become unregistered (check to see if they are corrupted).

    3. The service failed to start or is at either starting/Stopping state (hung).

    4. An application tries to restart the service repeatedly.

    5. Bug in the 3rd party or custom application.

    6. RPC service has "Allow Service to Interact with Desktop" checked.

    7. A dependant service starts before the service throwing the error.

    8. Permission of application is set incorrectly.



    1. Check the Check NTFS permissions (DCOM) .

    2. With the AppGUID, find what application it is and try Re-registering exe's (DCOM)

    3. Stop and try restarting the service.

    4. Disable 3rd party services and startup items, go thru the process of elimination.

    5. Check for an update from the software vendor.

    6. Uncheck the "Allow Service to Interact with Desktop" within the RPC service and reboot.

    7. 193888 How to Delay Loading of Specific Services .

    8. Check the DCOM Check NTFS permissions (DCOM) specific to the application.




    PS: Sometimes SP1 helps (... if you have not applied it yet.)
    Sunday, December 04, 2011 6:38 PM