none
Remote desktop audio quality

    Question

  • Hello

     

    I am using a Windows 7 SP1 computer to control a Windows 2008 Server R2 via Remote Desktop software with audio redirection to the remote client. Everything is working fine other than the audio quality is terrible (synthetic speech almost illegible, not to mention music). Bandwidth is not an issue. I searched around and found this sentence in a document:

     

    The audio remoting stack caps the audio signal being transmitted to 22 kilohertz (kHz), resulting in a maximum theoretical bandwidth of 86 KBps. The RDP stack then compresses the audio signal further by using in-box audio codecs. The choice of the codec is determined by codecs supported by the client and server, as well as the bandwidth available between the client and the server.

     

     I also found a setting in the Group Policy editor that relates to the audio quality and set that to "high". It made no noticeable difference.

     

    Any idea ? 

     

    Thanks

    tci

    Tuesday, August 16, 2011 2:38 PM

Answers

  • Hi,

    On the Server

    1. Please make sure that SP1 is installed

    2. Please set the following GP setting if you have not already:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

    Limit audio playback quality     Enabled

    Audio Quality:     High

    You can do this in the server's local policy if you want using gpedit.msc, or via a domain-based GPO using gpmc.msc.  Please verify that the policy is being applied using the following commands on the server (run in an administrator command prompt):

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    On the Client PC

    1. In the .rdp file that you use to connect to the server, make sure you have the following line:

    audioqualitymode:i:2

    2. Please verify that the connection between the client and server is stable and low-latency, using ping, netmon, etc.  There should be no lost packets and preferrably low response time numbers.

    Thanks.

    -TP

    Wednesday, August 17, 2011 5:17 AM
    Moderator
  • Hi,

    It may be the latency of your connection that is affecting it.  Occasionally I have played .wma and .mp3 files remotely and they sound fine.  This is over built-in notebook speakers so not exactly high-fidelity, but it sounded fine to me.

    I just did a quick test and played a .wma song and it was clear.  This is from a server with <30ms ping times and excellent bandwidth.

    Most of the .rdp file settings are documented here:

    RDP Settings for Remote Desktop Services in Windows Server 2008 R2

    http://technet.microsoft.com/en-us/library/ff393699(WS.10).aspx

    -TP

    Friday, August 19, 2011 8:24 PM
    Moderator

All replies

  • What audio driver you see on the Windows 2008 R2 Server when you RDP to it? You need to ensure appropriate audio drivers are configured on both server and client devices.

     

     


    You are the Knowledge You have…
    MyWordPress; MyBlogSpot; MyMicrosoft; MyCitrix;
    MyVMWare; MySymantec; MyLinkedIn; MyFaceBook; MyGReader;
    Wednesday, August 17, 2011 4:46 AM
  • Hi,

    On the Server

    1. Please make sure that SP1 is installed

    2. Please set the following GP setting if you have not already:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

    Limit audio playback quality     Enabled

    Audio Quality:     High

    You can do this in the server's local policy if you want using gpedit.msc, or via a domain-based GPO using gpmc.msc.  Please verify that the policy is being applied using the following commands on the server (run in an administrator command prompt):

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    On the Client PC

    1. In the .rdp file that you use to connect to the server, make sure you have the following line:

    audioqualitymode:i:2

    2. Please verify that the connection between the client and server is stable and low-latency, using ping, netmon, etc.  There should be no lost packets and preferrably low response time numbers.

    Thanks.

    -TP

    Wednesday, August 17, 2011 5:17 AM
    Moderator
  • On the server I see only "Remote Audio" which has no settings.

    The client has its Realtek drivers that are working great for everything else ....

    Wednesday, August 17, 2011 2:36 PM
  • Thanks TP !

    The only thing missing was the line in the .RDP file that was not there and I added it. It seems that there is a slight improvement in the legibility of the synthesized speech which makes it bareable. This is work related and was really important.... I was hoping to be able to listen to music but that still sounds as if it is coming from a broken small radio :(

    My ping to the server is around 180ms, it is pretty stable and high badwidth, no packet loss at all over long periods of time ... Is there something else I can do, or is this as far as it goes?

     

    Is there any documentation about the options in the .RDP file ? 

     

    Thanks a Lot !

    tci

    • Proposed as answer by Funder Friday, July 10, 2015 8:09 AM
    • Unproposed as answer by Funder Friday, July 10, 2015 8:09 AM
    Wednesday, August 17, 2011 2:43 PM
  • Hi,

    It may be the latency of your connection that is affecting it.  Occasionally I have played .wma and .mp3 files remotely and they sound fine.  This is over built-in notebook speakers so not exactly high-fidelity, but it sounded fine to me.

    I just did a quick test and played a .wma song and it was clear.  This is from a server with <30ms ping times and excellent bandwidth.

    Most of the .rdp file settings are documented here:

    RDP Settings for Remote Desktop Services in Windows Server 2008 R2

    http://technet.microsoft.com/en-us/library/ff393699(WS.10).aspx

    -TP

    Friday, August 19, 2011 8:24 PM
    Moderator