locked
Cannot Install Server-Gui-Mgmt-Infra on Windows Hyper-V Core Server RRS feed

  • Question

  • Hi,

    i installed the Windows 2012 Server Core Hyper-V DVD on a Server. Now i like to install the  Server-Gui-Mgmt-Infra Tools to create a Virtual Mashine etc..... I have copyed the Install.Wim File from a Full Server DVD to the Hyper-V Server an Mounted the Install.Wim file. But when i try to install the Server-Gui-Mgmt-Infra Feature i become this Error:

    Install-WindowsFeature Server-Gui-Mgmt-Infra –Source c:\wimmount\Windows\winsxs

    Name was not found!!!

    How can i istall this Feature!?!?! What i am doing wrong!?

    Monday, October 15, 2012 8:14 AM

Answers

  • The .wim file from the installation iso has multiple images in it.  You need to be specific.

    • Create a folder to mount a Windows Imaging File (WIM) in with the command
      mkdir c:\mountdir
    • Determine the index number for Server Datacenter using this command at an
      elevated command prompt: Dism /get-wiminfo /wimfile:<drive>:sources\install.wim
    • Mount the WIM file using this command at an elevated command prompt:
      Dism /mount-wim /WimFile:<drive>:\sources\install.wim /Index:<#_from_step_2> /MountDir:c:\mountdir /readonly
    • Then run your PowerShell command - Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell Restart Source c:\mountdir\windows\winsxs

    However, if you have a full install or a Windows 8 install elsewhere in your environment, you can easily do remote management from one of those environments.  By default, Windows Server 2012 installs configured to be remotely managed.  Using the Remote Server Administration Toolkit (RSAT) from either system, you can launch the Hyper-V console for the core installation.  Running it remotely works the same as it does locally.  Quick.  Easy.  Painless.


    tim

    • Proposed as answer by Yan Li_ Wednesday, October 17, 2012 6:15 AM
    • Marked as answer by Yan Li_ Wednesday, October 17, 2012 6:20 AM
    Monday, October 15, 2012 1:50 PM

All replies

  • That's because its not meant for server core edition, You could use server 2012 or windows 8 to manage server core server but its a pain to get the setup to work.
    Monday, October 15, 2012 1:06 PM
  • The .wim file from the installation iso has multiple images in it.  You need to be specific.

    • Create a folder to mount a Windows Imaging File (WIM) in with the command
      mkdir c:\mountdir
    • Determine the index number for Server Datacenter using this command at an
      elevated command prompt: Dism /get-wiminfo /wimfile:<drive>:sources\install.wim
    • Mount the WIM file using this command at an elevated command prompt:
      Dism /mount-wim /WimFile:<drive>:\sources\install.wim /Index:<#_from_step_2> /MountDir:c:\mountdir /readonly
    • Then run your PowerShell command - Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell Restart Source c:\mountdir\windows\winsxs

    However, if you have a full install or a Windows 8 install elsewhere in your environment, you can easily do remote management from one of those environments.  By default, Windows Server 2012 installs configured to be remotely managed.  Using the Remote Server Administration Toolkit (RSAT) from either system, you can launch the Hyper-V console for the core installation.  Running it remotely works the same as it does locally.  Quick.  Easy.  Painless.


    tim

    • Proposed as answer by Yan Li_ Wednesday, October 17, 2012 6:15 AM
    • Marked as answer by Yan Li_ Wednesday, October 17, 2012 6:20 AM
    Monday, October 15, 2012 1:50 PM
  • Hi Tim,

    I have followed your steps to install the GUI on my Server 2012 Core, but I get the below error.

    PS C:\>  Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell -Restart
    -Source c:\mountdir\windows\winsxs
    Install-WindowsFeature : ArgumentNotValid: The role, role service, or feature name is not valid: 'Server-Gui-Mgmt-Infra,Server-Gui-Shell'. The name was not found.
    At line:1 char:2
    +  Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell -Restart
    -Source  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidArgument: (Server-Gui-Mgmt-Infra,Server-G
       ui-Shell:String) [Install-WindowsFeature], Exception
        + FullyQualifiedErrorId : NameDoesNotExist,Microsoft.Windows.ServerManager
       .Commands.AddWindowsFeatureCommand

    Success Restart Needed Exit Code      Feature Result
    ------- -------------- ---------      --------------
    False   No             InvalidArgs    {}

    I tried both with Index 2 and 4, but it just didn't work.

    What am I doing wrong?

    Thanks

    Wednesday, October 31, 2012 8:01 PM
  • Hi Daniel, Did you solve this because i have the same problem.
    I Hope you can help me out...

    regards,.

    Marc


    MarcH

    Wednesday, November 21, 2012 1:53 PM
  • Hi Marc,

    No, I was not able to resolve the issue. I can install Windows 2012 standard with GUI and then remove the GUI interface with any issue and then add it back again.

    Saturday, November 24, 2012 1:14 AM
  • I think your syntax is incorrect. Try this:

    Install-WindowsFeature server-gui-mgmt-infra,server-gui-shell -source:wim:d:\sources\install.wim:4

    You are missing ':' after source in your syntax. Check this blog: http://blogs.technet.com/b/askds/archive/2012/09/20/windows-server-2012-shell-game.aspx

    Monday, January 7, 2013 5:36 AM
  • I too am stuck at your point. 
    Saturday, March 2, 2013 5:46 AM
  • Hi Tim, I try to install in your way but i got an error same as Daniel. I am stuck at Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell Restart Source c:\mountdir\windows\winsxs

    It is not recognized the command at Server-Gui-Mgmt-Infra,Server-Gui-Shell Restart Source c:\mountdir\windows\winsxs

    Thanks

    Friday, February 21, 2014 3:42 AM
  • I am getting the same error as well, it will now accept this command

    Install-WindowsFeature Server-Gui-Mgmt-Infra, Server-Gui-Shell -Source c:\mountdir\windows\winsxs

    Anyone able to offer assistance on why this will not work? I have watched numerous CBT nuggets, YouTube videos and researched the commands. Clearly this is the recommended command but will not run on my server..

    Thanks

    Monday, March 3, 2014 5:31 PM
  • I ´ve solved this in a lab.

    I used the following command, with the DVD in my "D" unit.

    Install-WindowsFeature Server-GUI-Mgmt-Infra,Server-GUI-Shell -Restart –Source wim:D:\sources\install.wim:2

    Change 2 by 4 if your version is DataCenter instead of Standard.

    Bye!



    Tuesday, April 8, 2014 3:06 PM
  • Install-WindowsFeature Server-GUI-Mgmt-Infra,Server-GUI-Shell -Restart –Source wim:D:\sources\install.wim:2

    did not work either?  No ":" after source is definitely incorrect.  Anyone , REALLY solve this yet?

    Wednesday, November 18, 2015 9:26 PM
  • That´s probably because you are using the Free version of Hyper-v.

    IT

    Tuesday, January 17, 2017 4:19 PM
  • hi already did the procedure but the error is still the same.


    Friday, October 20, 2017 5:34 AM
  • I have tried many solutions but only worked for me is to run setup.exe from DVD source.

    OR

    cd D:\

    Run setup.exe ( Follow the on screen instructions to proceed and select the version / desktop experience you want and install it ).


    • Edited by asim_52 Wednesday, March 28, 2018 10:05 AM Forgot to add instruction.
    Wednesday, March 28, 2018 10:03 AM
  • Wow!!! holly crap... after hours of following everyone's cmd line instructions... this is the only one that works!!!! thanks ... glad I found this thread
    Friday, May 11, 2018 1:26 AM
  • I spent ages messing around with commands, can't believe it was this simple! Thank you so much!
    Tuesday, February 18, 2020 10:18 AM