none
The WinRM service is not listening for WS-Management requests. Event ID 10149

    Question

  • Dears,

    One -domain joined- server has Windows Remote Management not working even after running the command WINRM QUICKCONFIG and Enable-PSRemoting many times successfully.. I still can't connect to this server using WMI commands.

    I checked the event log and found Event ID 10149 The WinRM service is not listening for WS-Management requests.

      - Windows Firewall is turned off and network traffic is opened between my client and all servers.

      - Other servers has WMI working fine and I can manage them.

      - The server is batched with last updates.

      - OS : Windows Server 2012 R2 Datacenter

      - Server role is Hyper-V host

    Please help what can we do to fix this issue..

    Thanks,

    A Seyam

    Tuesday, November 10, 2015 7:01 AM

Answers

  • I opened a ticket with Microsoft and the issue is now solved

    As I mentioned before I scanned the port 5985 and I found the server listening for this port on the loopback IP '127.0.0.1' only not on all interfaces as it should.

    • And running the command 'netsh http show iplisten' show the loopback IP address in the Listen Address of HTTP:

    IP addresses present in the IP listen list:

    -------------------------------------------

    127.0.0.1

    So the server was listening for HTTP requests on the loopback interface only

    • So we ran the command 'netsh http delete iplisten 127.0.0.1' to delete it. After that we were able to connect to WinRM remotely.

    I'm not sure what may caused this issue but hopefully it may help someone else..


    • Marked as answer by A Seyam Monday, November 16, 2015 9:06 AM
    • Edited by A Seyam Monday, November 16, 2015 9:06 AM
    Monday, November 16, 2015 9:06 AM

All replies

  • Hi,

    Based on this page:

    https://technet.microsoft.com/en-us/library/dd363600%28v=ws.10%29.aspx

    [quote]
    * User Action

    If you did not intentionally stop the service, use the following command to see the WinRM configuration:
    winrm enumerate winrm/config/listener

    * Resolve

    Create a listener for the WinRM service
    Type winrm quickconfig to create a listener for the WinRM service.

    * Verify

    Use the winrm command line tool to create a request to the WinRM service to verify that the service is listening on the network.
    To make a request, type winrm get winrm/config -r:<computer>, where computer is the name of the remote computer where the winrm service is running.

    [/quote]


    Tuesday, November 10, 2015 8:40 AM
  • I tried this and problem still exists..
    Wednesday, November 11, 2015 8:21 AM
  • Turn back on the firewall and enable default rules on any profile (public/domain/private) for ' Windows Remote Management (HTTP-In)' and 'Windows Management Instrumentation'

    Does the winrm enumerate winrm/config/listener command shows a listener?

    Is the service WinRM running and starting automatically?

    Sure, there are no GPO configuring services, firewall rules/state, WinRM? Verify by running rsop.msc or gpresult.exe

    Wednesday, November 11, 2015 2:12 PM
  • Yes it shows a listener which is configured by the GPO

    Listener [Source="GPO"]
        Address = *
        Transport = HTTP
        Port = 5985
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 10.0.180.83, 10.0.182.8, 10.0.183.8, 127.0.0.1, 169.254.8.158, ::1, fe80::5efe:10.0.180.83%28, fe80::5
    efe:10.0.182.8%36, fe80::5efe:10.0.183.8%30, fe80::5efe:169.254.8.158%29, fe80::208b:d081:1cde:8468%34, fe80::3915:cc3c:
    dd95:7b16%32, fe80::90ab:e7bc:3b68:43e2%38, fe80::e463:a7f:1f10:17c%37

    I turned on the firewall and the WinRM service is running

    Thursday, November 12, 2015 8:59 AM
  • I noticed also that scanning the server for port 5985 shows that the server is listening on the loopback address only "127.0.0.1" not all interfaces as it should do..

    C:\Windows\system32>netstat -ano | findstr 5985
      TCP    127.0.0.1:5985         0.0.0.0:0              LISTENING       4

    Thursday, November 12, 2015 9:14 AM
  • The listener looks good.

    You'll now need to inspect firewall rules. Check that 'Windows Remote Management (HTTP-In)' rules are enabled on any profile (Domain, Public and Private).

    You'll need to pay attention to the 'scope' tab and its 'remote computers' field. By default you should have 'Any Ip Address' unless there's a custom (more restrictive) filter. Have also a look at the 'Computers' tab, by default nothing is checked.

    Thursday, November 12, 2015 9:17 AM
  • Be careful if you are on a Wi-Fi connection.  Be sure firewall profile in use is only for "private" networks.


    \_(ツ)_/


    Thursday, November 12, 2015 12:32 PM
    Moderator
  • I opened a ticket with Microsoft and the issue is now solved

    As I mentioned before I scanned the port 5985 and I found the server listening for this port on the loopback IP '127.0.0.1' only not on all interfaces as it should.

    • And running the command 'netsh http show iplisten' show the loopback IP address in the Listen Address of HTTP:

    IP addresses present in the IP listen list:

    -------------------------------------------

    127.0.0.1

    So the server was listening for HTTP requests on the loopback interface only

    • So we ran the command 'netsh http delete iplisten 127.0.0.1' to delete it. After that we were able to connect to WinRM remotely.

    I'm not sure what may caused this issue but hopefully it may help someone else..


    • Marked as answer by A Seyam Monday, November 16, 2015 9:06 AM
    • Edited by A Seyam Monday, November 16, 2015 9:06 AM
    Monday, November 16, 2015 9:06 AM
  • Hi Seyam,

    It's good to know that you got the problem solved, and many thanks for your sharing.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 18, 2015 3:17 AM
    Moderator
  • Thank you very much  ..... Your WinRM Command works for me :)
    Thursday, October 12, 2017 2:18 PM
  • IP addresses present in the IP listen list:
    -------------------------------------------

    C:\Users\Administrator.JOSIMARS>netsh http show iplisten

    I am not seeing any ipaddress here

    IP addresses present in the IP listen list:
    -------------------------------------------

    C:\Users\Administrator.JOSIMARS>winrm enumerate winrm/config/listener
    Listener [Source="GPO"]
        Address = *
        Transport = HTTP
        Port = 5985
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 192.168.1.139

    Listener [Source="Compatibility"]
        Address = *
        Transport = HTTP
        Port = 80
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 192.168.1.139

    C:\Users\Administrator.JOSIMARS>netsh http show iplisten

    IP addresses present in the IP listen list:
    -------------------------------------------

    C:\Users\Administrator.JOSIMARS>ipconfig

    Windows IP Configuration


    Ethernet adapter Ethernet:

       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::c029:2383:c022:cfb7%3
       IPv4 Address. . . . . . . . . . . : 192.168.1.139
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.1

    Tunnel adapter isatap.{22E85114-A07D-4BF0-BFF4-D7C1E12C3843}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :

    C:\Users\Administrator.JOSIMARS> winrm get winrm/config/service
    Service
        RootSDDL = O:NSG:BAD:P(A;;GA;;;BA)(A;;GR;;;IU)S:P(AU;FA;GA;;;WD)(AU;SA;GXGW;;;WD)
        MaxConcurrentOperations = 4294967295
        MaxConcurrentOperationsPerUser = 1500
        EnumerationTimeoutms = 240000
        MaxConnections = 300
        MaxPacketRetrievalTimeSeconds = 120
        AllowUnencrypted = true [Source="GPO"]
        Auth
            Basic = true [Source="GPO"]
            Kerberos = true
            Negotiate = true
            Certificate = false
            CredSSP = true
            CbtHardeningLevel = Relaxed
        DefaultPorts
            HTTP = 5985
            HTTPS = 5986
        IPv4Filter = 192.168.1.1 - 192.168.1.254 [Source="GPO"]
        IPv6Filter = "*" [Source="GPO"]
        EnableCompatibilityHttpListener = true [Source="GPO"]
        EnableCompatibilityHttpsListener = false
        CertificateThumbprint
        AllowRemoteAccess = true [Source="GPO"]

    C:\Users\Administrator.JOSIMARS> cd
    C:\Users\Administrator.JOSIMARS

    C:\Users\Administrator.JOSIMARS>cd ..

    C:\Users>cd ..

    C:\>cd windows

    C:\Windows>cd system32

    C:\Windows\System32>netstat -ano | findstr 5985
      TCP    0.0.0.0:5985           0.0.0.0:0              LISTENING       4 NOR here
      TCP    [::]:5985              [::]:0                 LISTENING       4
      TCP    [fe80::c029:2383:c022:cfb7%3]:5985  [fe80::c029:2383:c022:cfb7%3]:52760  TIME_WAIT       0
      TCP    [fe80::c029:2383:c022:cfb7%3]:5985  [fe80::c029:2383:c022:cfb7%3]:52761  TIME_WAIT       0


    Paul Drummond

    Sunday, November 5, 2017 1:50 AM
  • As I result I cannot install SCVMM it is failing

    Paul Drummond

    Sunday, November 5, 2017 1:51 AM
  • Please do not add questions to another users thread.  You must start your own thread with complete information.  Your question cannot be understood because it is not about the original issue which has been answered.

    \_(ツ)_/

    Sunday, November 5, 2017 2:06 AM
    Moderator
  • Fixed it for me, thanks so much! I was checking everything for the past 3 hours..
    Tuesday, April 10, 2018 5:28 AM