AD RMS unable to remove


  • Hi, 
    I have a problem, 
    I have tryed to  install the RMS on a Windows Server 2008 x64, but probably I have make some mess, so I want to remove the role to make a new installation,
    But when I try to uninstall the AD RMS Role, I receive this error message:

    Active Directory Rights Management Services

    Active Directory Rights Management Services: Removal failed

    <Error>: Attempt to perform custom actions before un-installing Active Directory Rights Management Server failed. Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index at System.Collections.CollectionBase.System.Collections.IList.get_Item(Int32 index) at System.DirectoryServices.PropertyValueCollection.get_Item(Int32 index) at Microsoft.RightsManagementServices.Configuration.ProvisionHelper.GetPort(String strTargetComputer, String strIIsService, String strSiteindex, Boolean fSSL) at Microsoft.RightsManagementServices.Configuration.ProvUtils.GetWebsites(String strTargetComputerName, String strIIsWebService) at Microsoft.RightsManagementServices.Configuration.ProvUtils.IsProvisioned() at Microsoft.RightsManagementServices.Configuration.ProvisioningBase.Unprovision() at Microsoft.RightsManagementServices.Configuration.ProvisionerBase.Unprovision() at Microsoft.RightsManagementServices.Configuration.CmdLineHandler.Run()

    The following role services were not removed:

    Active Directory Rights Management Server

    Do you have any idea how to remove the services?

    Many thanks
    Friday, September 26, 2008 10:35 AM

All replies

  • Did you ever find a resolution for this issue? I have Server 2008 x86 Enterprise and get the same error when trying to remove RMS from my server.
    Wednesday, November 12, 2008 6:18 PM
  •  I have same error. Can anyone help?
    Tuesday, December 23, 2008 9:56 PM
  •  I received a good hint in an other forum.
    Remove another website in IIS. Only the default was left over.
    Then uninstall is work.
    Wednesday, December 24, 2008 11:41 AM

  • Hi all

    Please follow the below mentioed the Tech article to removed the AD RMS.

    Hope for help


    Tomorrow's life is too late. Live today.
    • Proposed as answer by Devaraju K Monday, July 13, 2009 10:21 PM
    Sunday, July 12, 2009 1:23 AM
  • Hi!

    Yes... It works, but other steps by TechNet is required.
    • Proposed as answer by Devaraju K Monday, August 17, 2009 7:48 AM
    Monday, July 27, 2009 10:03 AM
  • Yeah, I've solved this (or at least a very similar problem).

    Go into the IIS manager and find the site that you're using for ADRMS. Right click it and choose "Edit Bindings". Make sure there are two entries, one for HTTP (with the correct host header) and one for HTTPS. Then try removing ADRMS.

    But first, read this:

    If you remove the ADRMS role without decommissioning it, you may not be able to install it again later. So first decommission it as described in deva_1002's link.
    Thursday, August 20, 2009 4:55 PM
  • after trying to debug further, it seems that the db and the iis app was not created.  The message log states that the login for user failed because the db doesn't exist.  I think this is benign as i think the collection refers to iis, but if the site or subsite doesn't exist, hence the index out of range exception.  I can relate to this as not catching the exception in a try catch block.
    Thursday, August 27, 2009 4:06 AM
  • the article you refer to is usless because during the process the exceptions occur.
    Saturday, September 12, 2009 5:01 PM
  • Hi Fabrizio,

    I find that post is a little late to answer its, but perceived that he did not have a reply with solution. The solution that I found, was the following one. Before removing the RMS I was in the IIS and I removed all the existing sites, also the Default WebSite. A done time this procedure was possible the removal of Role ADRMS successfully. I wait to have helped.
    Daniel Marreiro
    Wednesday, May 19, 2010 8:25 PM
  • I have the same issue. I removed the IIS default website and still no joy. Any other ideeas? I tried also through powershell with the -force parameter.

    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 01, 2012 12:35 PM
  • Hello,

    the AD RMS forum is the better one to ask about this

    Best regards

    Meinolf Weber
    Microsoft MVP - Directory Services
    My Blog:

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, March 01, 2012 8:03 PM