none
Connector software won't load after installing WSE 2016 RRS feed

  • Question

  • When I type in http://servername/connect from any client I get an error message:

    erver Error in '/Connect' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    I can see the server, including seeing shared folders and my computers and users show up on the server.

    I attempted to connect directly in the server by opening a browser on the server and typing http://servername/connect and i got the following error:

    Server Error in '/Connect' Application.

    Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.1b431300-7aa7-48a2-864f-871bc9e204be.log' is denied.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.UnauthorizedAccessException: Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.1b431300-7aa7-48a2-864f-871bc9e204be.log' is denied. 

    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user. 

    To grant ASP.NET access to a file, right-click the file in File Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

    Source Error: 
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 
    [UnauthorizedAccessException: Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.1b431300-7aa7-48a2-864f-871bc9e204be.log' is denied.]
       System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +419
       System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) +1322
       System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize) +132
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.TraceListeners.RotatingFileStreamFactory.CreateFileStream(Int32 fileNumber, FileMode fileMode) +279
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.TraceListeners.RotatingLogTraceListener.UpdateWriter(String message) +71
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.TraceListeners.LogTraceListener.Write(String message) +94
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.TraceListeners.LogTraceListener.TraceData(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, Object data) +175
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.LogTraceSource.TraceData(TraceEventType eventType, Int32 id, LogEventInfo logEventInfo) +252
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.LogOrchestrator.Write(LogEventInfo log) +656
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.Log.Write(Object value, IEnumerable`1 categories, Int32 priority, Int32 eventId, TraceEventType severity, String description) +158
       Microsoft.WindowsServerSolutions.Diagnostics.Logging.Log.WriteInfo(Object value, String category) +47
       Microsoft.WindowsServerSolutions.Client.Website.Utils.CheckCache(String key, Int32 type, Int32 maxNumber, Int32 cacheDuration) +392
       Microsoft.WindowsServerSolutions.Client.Website.Utils.IsValidRequest() +623
       Microsoft.WindowsServerSolutions.Client.Website.Default.OnInit(EventArgs e) +36
       System.Web.UI.Control.InitRecursive(Control namingContainer) +166
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +464
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1586.0

    The file it claims it cannot write to does not even appear to be there.

    Any thoughts would be appreciated.

    Thanks,

    Ed

    Thursday, December 29, 2016 1:12 AM

Answers

All replies

  • Is this a fresh install of WSE 2016?  You have not installed anything else on the server?  I would probably reinstall since you have not connected any clients.

    Grey

    Thursday, December 29, 2016 5:02 AM
    Moderator
  • Hi,

    I want to confirm with you that if this problem only happens on specific client device? Have you tried to connect another other client to the Essentials Server?

    If both client and Essentials Server are on the same network, make sure that you have manually configured the Preferred DNS Server as the Essentials Server’s IP address on the client. then, try to connect via “http://<Essentials Server IP address>/connect” to check the result.

    Besides, on the Essentials Server, open IE and try to access “http://localhost/” and “http://localhost/connect/”, check to see if corresponding webpage will be displayed. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 29, 2016 6:15 AM
    Moderator
  • Thank you both for your reply.

    To answer Grey's question this was an upgrade of WSE 2012 r2.  Literally everything else seems to work fine.

    To answer Eve's question, since I cannot pull up the connector page on the server itself that would seem to be a problem, however I have tried from several client computers all displaying the first message above.

    If I type in http://localhost/ then the remote web access page comes up fine on both server and client.

    Frankly I don't even care if the page works but I cannot find the connector software anywhere on the server or Microsoft's site.

    Thanks,

    Ed

    Thursday, December 29, 2016 2:22 PM
  • Well I do not know.  In the comments section he says it is for 2016  The .msi download

    the connector fires up a download from MS, it is no longer contained on the server

    https://blogs.msmvps.com/bradley/2016/08/11/windows-10-anniversary-update-and-essentials-r2/


    Grey

    Thursday, December 29, 2016 2:36 PM
    Moderator
  • Thank you again for responding Grey.

    I tried the msi download and it asked me to remove the connector software I had installed for the WSE 2012 r2 client on a pc.  Then reran the msi install and it does not start or even give an error.

    It is very odd to me that Microsoft is not clearly defining what that file is for especially when it is on the WSE 2012 download page.

    Thanks,

    Ed

    Thursday, December 29, 2016 3:36 PM
  • here is what is on the server

    C:\Program Files (x86)\Windows Server\Bin\WebApps\Client\Package\en-US


    Grey

    Thursday, December 29, 2016 4:19 PM
    Moderator
  • I think we are finally getting somewhere.  Thank you Grey for all your help so far.  All my searching could not find what you found and that is the WSE 2016 connector.

    Now for whatever reason I have a new problem.  When I run it this is what I get when it says select the server you want to connect to:

    Cannot get information from the servername.  Please contact your server administrator. (I tried to post the screenshot of this error but it says I can't post an image until my account is verified.  I have checked my email but no verification email has arrived.)

    Thoughts?

    Thanks,

    Ed

    Thursday, December 29, 2016 8:43 PM
  • try renaming the file with the ip of the server


    Grey

    Thursday, December 29, 2016 10:59 PM
    Moderator
  • I had this identical thing happen on a new server essentials install just a week ago.  I was trying to add a new client and got the same error you did.  I then tried the connector install from an existing client and the same thing happened.

    In my case the key to the solution was in the security permissions. I followed the trail to the ASP.NET machine permissions and there were some in there that were not enough, I changed them to full control.  I then restarted the server and it took about 10 minutes for everything to settle down and start working. All the clients could access the install.

    Sorry I can't be more specific but I can be if I go back to the logs, which I can't do right now. And I have no idea how that changed from the original install when the clients could indeed install.


    • Edited by Jose Suro Thursday, December 29, 2016 11:25 PM spelling
    Thursday, December 29, 2016 11:22 PM

  • Exception Details: System.UnauthorizedAccessException: Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.1b431300-7aa7-48a2-864f-871bc9e204be.log' is denied. 

    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user. 

    To grant ASP.NET access to a file, right-click the file in File Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.


    Forgot to do this but your quote above is the key and I did get exactly the same message.I went with Full Control.

    This post should be below the one I posted first but it is not for some reason. Look for my original post below.
    • Edited by Jose Suro Thursday, December 29, 2016 11:41 PM
    Thursday, December 29, 2016 11:38 PM
  • Thank you both for your replies.  Grey I tried your suggestion but it did not work.  It does see the server but I get the same error message.  I am wondering if this has something to do with port 80 or IIS since I also discovered remote access throws an error about not being able to access port 80.

    Jose, I looked at my ASP.NET permissions and I believe they are set properly however I will continue to follow that trail as well.

    Thanks,

    Ed

    Thursday, December 29, 2016 11:39 PM
  • You can always run Roberts tool

    https://windowsserveressentials.com/2014/02/14/windows-server-essentialsconfiguration-troubleshooter/

    You can share your screenshots in dropbox or OneDrive and post the link here


    Grey

    Thursday, December 29, 2016 11:45 PM
    Moderator
  • Thanks again Grey.  Here you go:

    https://1drv.ms/u/s!AvkyH3U60B4khPFVVtQIyFC2wglBNg

    Thanks,

    Ed

    Friday, December 30, 2016 12:35 AM
  • Great job on running the tool.  Though you could have posted the results here.  I want to see the error screenshot.  The web server may be the issue, well of course it is an issue.  I am just surprised the "standalone" connector will not run.

    DNS on the client PC is pointed at the server?


    Grey

    Friday, December 30, 2016 12:42 AM
    Moderator
  • Just to verify, you had a happy WSE 2012R2 SKU  (not server standard with the role) and got the WSE 2016 SKU, ran setup from the desktop and selected upgrade?

    Is this a Thecus or homebuilt with software from Newegg the like


    Grey

    Friday, December 30, 2016 12:45 AM
    Moderator
  • Yes DNS on the client pc is pointed at the server.

    And yes I have been using WSE 2012R2 since it came out and was very happy.  I did run setup from the desktop and selected upgrade.

    Friday, December 30, 2016 1:00 AM
  • And yes I have been using WSE 2012R2 since it came out and was very happy

    So why did you upgrade <grin>


    Grey

    Friday, December 30, 2016 1:08 AM
    Moderator
  • Because I love the pain. :)

    I am seriously at a loss as to what to do now.

    Friday, December 30, 2016 1:28 AM
  • I pinged Robert to see if he could adapt his tool to check the .net whatever idea.

    In the meantime if you have a pc you could stick a hard drive in and do a fresh install of wse 2016 you could compare stuff in IIS Admin.

    only requirement is 2gb ram 120gb free space  Or a virtual machine


    Grey

    Friday, December 30, 2016 1:38 AM
    Moderator
  • May I ask Jose where exactly did you go to increase the ASP.NET permissions?
    Friday, December 30, 2016 2:32 AM
  • I know this is a shot in the dark but in doing some research I came across this link:

    https://support.microsoft.com/en-us/kb/823379

    Under cause could this be what happened when  I did the upgrade?

    Ed

    Friday, December 30, 2016 2:49 AM
  • how about this?


    Grey

    Friday, December 30, 2016 8:03 AM
    Moderator
  • Jose, I looked at my ASP.NET permissions and I believe they are set properly however I will continue to follow that trail as well.

    Thanks,

    Ed

    The permissions you need to change are in the ProgramData folder as per the denial of access message:

    'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.1b431300-7aa7-48a2-864f-871bc9e204be.log'

    What I did was to change the permissions of the "Microsoft" folder.  I gave the SYSTEM and Administrators "FULL CONTROL", with a check mark on grant permission to  all child items below that folder.  The reason is that some of the log files are created on the fly so there is no way to permit them directly.

    I then rebooted the server and some minutes later it all started working again.

    Friday, December 30, 2016 12:49 PM
  • Thank you for your help Jose but in looking at the permissions for both system and administrators on the Microsoft folder they already had full control.

    Thanks,

    Ed

    Friday, December 30, 2016 3:42 PM
  • Grey,

    Are you suggesting I give full control to IIS_USERS?

    Thanks,

    Ed

    Friday, December 30, 2016 3:43 PM
  • No I was just showing you what mine had.  Not full, but read/execute

    Grey

    Friday, December 30, 2016 9:20 PM
    Moderator
  • Got it thank you.
    Friday, December 30, 2016 9:34 PM
  • Are you still troubleshooting this?

    Robert Pearman Cloud & Datacentre MVP
    @titlerequired | LinkedIn | Google+
    Facebook | Windows Server Essentials.com

    Monday, January 2, 2017 8:12 PM
    Moderator
  • Yes and it is driving me crazy.  May just have to reinstall and start from scratch.

    Thanks,

    Ed

    Monday, January 2, 2017 8:15 PM
  • Im just running through another upgrade. Will let you know what i find.

    Edit:

    Upgrade Complete, Same issue here for me.

    Will update shortly.

    Edit:

    Added 'Network Service' Read&Write Permission to c:\programData\Microsoft\Windows Server\Logs

    Seems to have removed the errors and the /connect page loads as expected.


    Robert Pearman Cloud & Datacentre MVP
    @titlerequired | LinkedIn | Google+
    Facebook | Windows Server Essentials.com



    Tuesday, January 3, 2017 9:31 AM
    Moderator
  • Hi,

    I am checking to see how things are going there on this issue. Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 6, 2017 2:42 AM
    Moderator
  • Thankyou, Thankyou, Thankyou. I had the same problem and this fixed it for me.
    Saturday, October 28, 2017 11:22 AM
  • if you add /remote at the end of the localhost, the website should load. this is intentional to rule out any issues with work folders.
    Thursday, November 2, 2017 7:59 AM
  • Hi Grey

    i can confirm i have the same issue, also when upgrading from wse2012r2. i was also very happy with wse2012 and upgraded as i wanted storage spaces optimization feature.

    I followed the thread to the point of changing permissions, but for me they are greyed out, cant change the IIS user or System user to have full control over the folder.


    Any advice? will keep reading the post 

    Thursday, November 2, 2017 8:10 AM
  • For me, admin and system user have already full control over windows server directory
    Thursday, November 2, 2017 8:14 AM
  • i don't have the Network Service user at all for the c:\programData\Microsoft\Windows Server\Logs

    will add it just now and report back.

    Thursday, November 2, 2017 8:18 AM
  • Hi Guys

    Adding Network Service for the C:\programData\Microsoft\Windows Server\Logs and setting it up with full permissions, worked for me as well.

    Thank you

    Thursday, November 2, 2017 8:24 AM