Access Denied when moving Windws 2003 iSCSI volume to 2008 R2 file server


  • I've been trying to move some iSCSI volumes from an old Windows 2003 file server, to a new Windows 2008 R2 file server, and two of them I just went into the Equallogic management, set the disk offline after disconnecting it from the server, then changing the accesss restriction to the IQN or IP address of the other host, and then connected them on the 2008 host and they worked fine. I've tried now to move 3 more volumes doing exactly the same thing, and when I try to open them on the new file server, I get an Access Denied error. I can look at the permissions on the volume, and domain admins (of which I'm logged in as) have full control and is set as owner. I've checked effective permissions with my account and it shows I should have full access. I've checked the persmissions on the ones that I was able to move successfully and they're the same. I can move the volumes back to the 2003 file server and they come back up just fine. Any ideas?
    Monday, January 21, 2013 8:48 PM

All replies

  • Hi,

    Check if it is caused by UAC. You could test to add your account specifically to the volume with Full Control permission and see if issue still exists.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    Wednesday, January 23, 2013 8:23 AM
  • ok I did this on one of the volumes I was having the problem with (only one I can test with right now) and then I was able to access it. My account is a member of Domain Admins, and Domain Admins had full control of this volume already. I also removed myself and added the local Administrators group with Full Control and could not access it again, so I'm a little confused as to whats going on...

    Wednesday, January 23, 2013 5:26 PM
  • OK so I tried moving another SAN volume last night, got the access denied message, added myself with full control (domain admins already had full control), and I'm still getting access denied. Any other ideas / explanations? This is really hampering my file server upgrade. I could just replicate to a new DFS share, but I'm also nearly out of SAN space at the moment so thats not a very good option either.

    Tuesday, January 29, 2013 5:27 PM
  • Also, it seems that if I'm able to share the volume by giving my account full control, sharing the volume, then removing myself, the shared folder when accessed over the network uses the correct permissions, so I can access it because I'm a domain admin, but locally I still get access denied.
    Tuesday, January 29, 2013 5:35 PM
  • We have the exact same issue. Trying to move 2003 ISCSI volumes to0 2008R2.  One comes up, the other comes up fine in disk management, but I cannot browse to it.  I have been through every setting I can think of.  If I connect them both back to 2003 servers, they both work fine.  If I connect both of them to a single 2008R2 server, I can only browse to one of them.  The other I can't browse. Any ideas?

    Sunday, November 10, 2013 7:12 PM