Error: Error 1335. The cabinet file '' required for this installation is corrupt and cannot be used.


  • Hello,

    On multiple computers in my office (Windows domain environment) - Server 2008 R2, Vista Enterprise x86, Win 7 Enterprise x86 - I am receiving the error:

     "Error 1335 The cabinet file '' required for this installation is corrupt and cannot be used" 

    while installing programs via the network AND the error occurs when copying the install folder then running it locally.  I run the setup.exe as administrator, but problems still occur.  The error gives me three options, "Abort", "Retry" or "Ignore".  Sometimes, though rarely, hitting "retry" will allow the install to continue.  Usually, I have to abort and try the install later.  If I attempt the install later from a network location, it may work.  If I attempt the install from a installer copied to the local C: drive, it will always fail if it fails the first time.

    This error has occured for several different programs - Adobe Acrobat Standard 9, NetBackup 7.1 (server), nVidia display drivers, etc. - AND on multiple computers.  These computers are connected at different locations of the office (server room, IT room, office desks, etc).  I've had no other reported network problems or any issues copying data over outside of this. 

    Has anyone encountered problems where the for any program coming over the network gets corrupt?  It seems somewhere during the install process (when running from a network location) or copying the installer over something causes the file to not be read properly.  Any ideas what would cause this?

    Thanks for any suggestions!

    Friday, November 04, 2011 3:34 PM

All replies

  • I suspect this could be due to Windows Installer service, not very sure though. On any sample machine (not on all) where you are getting this error, try to unregister & register Windows Installer service and check if it resolves the issue.

    You can check the following URL for the instructions to fix Windows Installer issues. I understand that, the URL talks about some different error however, you can try it on one machine if you wish to do so...

    View Santosh  Bhandarkar's profile on LinkedIn
    Friday, November 04, 2011 6:10 PM
  • Hello,

    it seems that you have not copied all source files.

    Please copy file that is used for installation.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Friday, November 04, 2011 8:29 PM
  • Unfortunately that doesn't appear to be the issue.  I have recopied the install folder for each of the programs, but problems the error occurs at the same point during the installs.  Also, I tried installing the program over the network but encountered the same error. 

    I checked the MD5 checksum of both the original and destination copy and they match, so I know it should be copying from the source ok. The source of the installers vary for the programs involved - nVidia drivers were directly downloaded from their website, Adobe Acrobat from a local file server, NetBackup from a remote file server, etc.

    This error occurs for different programs - Adobe Acrobat Standard, NetBackup, nVidia display drivers - on multiple computers, but only in one office location (that I am aware of).  It isn't an Windows Firewall issue or antivirus program issue, as I attempted the install on a freshly imaged computer that did not yet have Symanted Endpoint Protection instsalled yet and had Windows Firewall disabled.



    Friday, November 04, 2011 9:41 PM
  • I did a MSIEXEC /unregister then MSIEXEC /register and attempted an install but the issue continues. 

    For some unknown reason though, I attempted again to install Adobe Acrobat on a couple laptops that would error out before and now it installs without a problem.  The install source is the same, and I did not change anything on these 2 laptops since the last install attempt (not even a reboot).  The only thing that changed is the time of day.


    Friday, November 04, 2011 9:45 PM
  • Please refer to this blog for the fix :



    Sunday, April 22, 2012 5:52 PM