Cannot start imported Hyper-V VM: The Security ID structure is invalid (0x80070539). RRS feed

  • Question

  • I haven't seen any mention of this in any of the forums. I'm attempting to import a virtual machine to a Server 2012 R2 Hyper-V system. Normally this is fairly straight-forward. However, the imported virtual machine will not start. I'm getting the following error message:

    [Window Title]
    Hyper-V Manager

    [Main Instruction]
    An error occurred while attempting to start the selected virtual machine(s).

    'Unnamed VM' could not initialize.

    An attempt to read or update virtual machine configuration failed.

    [Expanded Information]
    'Unnamed VM' could not initialize. (Virtual machine ID )

    'Unnamed VM' could not read or update virtual machine configuration: The security ID structure is invalid. (0x80070539). (Virtual machine ID 223C7883-08C2-43ED-B5D1-7ABFC0940F64)

    I'm not familiar with what is going on here. Any ideas?

    Thank you.

    Monday, January 13, 2014 6:05 PM


All replies

  • Hi,

    1. Make a backup first. make sure no snapshot.

    2. remove the VM Configuration that you have import in.

    3. Try create a new configuration and map back the virtual disk

    4. Test Boot up the VM and let us know if this work

    Lai (My blog:- http://www.ms4u.info)

    Wednesday, January 15, 2014 9:10 AM
  • Can you check if this thread helps - http://social.technet.microsoft.com/Forums/windowsserver/en-US/fbf80eb7-9a8b-48c2-9611-15fac92de89e/restored-vms-and-vhds-and-lost-security-settings?forum=winserverhyperv


    Wednesday, January 15, 2014 11:03 AM
  • Different error message. " The security ID structure is invalid"

    Lai (My blog:- http://www.ms4u.info)

    Thursday, January 16, 2014 2:34 AM
  • Thanks for the replies.

    Praveen, the thread you linked to seems promising, although as Lai pointed out, it's not exactly the same. I'll give it a try tomorrow and see what happens.

    Thursday, January 16, 2014 3:54 AM
  • Hi michael,

    please try execute this powershell command.

    Grant-VmConnect Access -username (user account to boot the VM) -VmName (VM name).

    See if this work. I just tested and work on my side. For more detail, you can refer to http://www.ms4u.info/2014/01/cannot-start-imported-hyper-v-vm.html

    Lai (My blog:- http://www.ms4u.info)

    • Marked as answer by Elton_Ji Monday, January 27, 2014 7:21 AM
    Friday, January 17, 2014 1:42 PM
  • Hello Mikael,

    Please advise from which Hyper-V version did you export this VM?


    Sunday, January 19, 2014 9:04 AM
  • The command worked. Grant-VmConnectAccess
    Tuesday, July 15, 2014 2:46 PM
  • I was having the same issue - this worked for me as well!!

    Thanks Lai, big help!


    Paul E Coz

    Friday, April 24, 2015 3:13 PM