none
RemoteFX Dual Remote Screens displayed on a 3 Monitor workstation RRS feed

  • Question

  • Hi

    I seem to be running into an issue getting RemoteFX running with anything less than all my local screens.

    For instance:

    My local Workstation has 3 monitors all running at 1280x1024

    In hyper-v I add the RemoteFX adapter and set it to 2 screens with a resolution of 1280x1024

    When I connect to the Remote session I only get a single monitor displayed and when checking the “Screen Resolution” on the Remote session it shows monitor 2 as detached.

    If However I add a 3<sup>rd</sup> monitor to the VM and tick “use all my monitors” I get a fully functioning 3 screen session in the resolution I want with the ability to stream HD Video “impressed by the way” without any problems at all.

    I have read the documents several times and the fail back to single monitor “sounds like what is happening” but this should only occur when:

    • If you request a resolution that is not supported, RemoteFX defaults to a single monitor session at a lower supported resolution.
    • If you request a resolution that is higher than the maximum resolution assigned to that virtual desktop, your session will default to a single monitor session at a lower resolution.
    • If you request a greater number of monitors than the maximum number assigned to a virtual desktop, your session will default to a single monitor session.
    • If you request a resolution that is not supported, you will get a single monitor RemoteFX-enabled session at a lower supported resolution.
    • If you request a resolution that is higher than the maximum resolution assigned to that virtual desktop, your session will fall back to a single monitor lower resolution session.  

    From this list I can only think that the Client “local workstation” is requesting more Screens than the VM is capable of so failing the presentation back to a single screen, however I thought the Client side Group Policy “Computer\AT\WC\RDS\RDSH\Limit maximum number of monitors [Enabled, 2]””that has been set” was meant to force the client connection to only request 2 screens?

    So what am I missing, any help would be great!

    Many thanks

    James

    • Moved by BrianEhMVP Monday, July 30, 2012 2:33 PM (From:Hyper-V)
    Sunday, July 29, 2012 9:17 AM

All replies

  • I have seen my post has been moved from the Hyper-V section is this correct given as these are VM's that are having an issue and not a Terminal Server ?

    Many thanks

    James

    Monday, July 30, 2012 5:44 PM
  • Hi,

    Detach one monitor(one of the three) and then try to set two monitors in RemoteFX adapter to see whether you get the same issue.

    By the way, the following post discussed a similar issue, you can refer to:

    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/d77fdbe7-9013-4419-b549-34cba585d8e8/

    Wednesday, August 1, 2012 7:49 AM
    Moderator
  • That is not 100% the same issue but fairly close:

    My issue is I don't want to use all monitors that I have 3<4 (within spec) where his is he can’t as the technology is limited to 6>4 (out of spec)

    A good point is made though why would you not at least try to draw 4 out of 6 by default?

    According to: http://blogs.msdn.com/b/rds/archive/2009/07/01/using-multiple-monitors-in-remote-desktop-session.aspx

    You should be able to Support mixed resolutions & Layouts as well as limit the number of monitors redirected by using the “Maximum number of monitors” Group policy or in the case of TS server by setting the property under RDP-tcp settings.

    I have tried your suggestion assuming you mean detach local monitor “as remote cannot be done?” and get the same behaviour: I detach the 3<sup>rd</sup> local monitor, connect to VDI using multimon I get 2 screens “RemoteFX” if I then minimize the session and reattach the 3<sup>rd</sup> monitor the RDP session no longer snaps to screen/screens and it requires you to scroll across it.

    I have now read allot on this subject but keep coming to a dead end as no forum or post gets to the cause or a solution but instead just stops at about the same place I am at, and it is starting to look like a BUG in Microsoft’s software.

    Group Policy

    From my understanding and backed up by testing and documentation the Group policy for maximum monitors is to be set on the targeted device ether a Windows 7/2008R2 sp1 ENT physical Desktop with multiple monitors or a Windows 7/2008R2 sp1 ENT virtual desktop with multiple monitors Via RemoteFX.

    Testing has shown that this group policy is it at best pointless or at worst just broken and these are the situations I have tested so far that support this conclusion:  you have a remote host with 3 monitors attached you connect from your local workstation also with 3 monitors using the multimon switch & everything works as expected “3 out of 3”. Now on the remote host you set the group policy to max 2 monitors & reboot to make sure policy takes effect.

    After the reboot you connect again with the multimon switch enabled and receive just 1 monitor “fail back action?” you cannot make any changes to setting remotely as this is a limitation of RDP? So you logoff the remote session  & on your local workstation disable/detach one of your local monitors “2 connected locally, limited to 2 remotely” then re-establish connection to remote host still using the multimon switch and sure enough you get “2 out of 2” with the 3<sup>rd</sup> disabled on both ends.

    Now change the Group policy setting on the remote workstation back to “not configured” this will enable all/ any monitors again & reboot to ensure Group policy is applied. From the local workstation still only using 2 monitors locally RDP to remote host once again using the multimon switch, this time you will receive a remote desktop session across both local screens as expected and if you check the resolution tab on the remote workstation only 2 monitors will be listed.

    I have also tested on a 2008R2 sp1 server and have found that unless the setting for the same or greater number of monitors that I have locally is set it defaults to 1.

    So is the group policy:

    1. Broken as it cannot impose any useful hard limit
    2. Pointless as a workstation with fewer monitors will automatically get the correct screen size, resolution and quantity by default and so the setting serves no purpose but to hinder.   

    IMHO there is no chance that the behaviour I have seen was requested or put in the design brief as it makes 0 sense, I can imagine a setting being requested as we would want “and it is worded” to limit the maximum number of monitors “so 3 remote and 1-4 local would get 1-3”. Or a setting for minimum number of monitors as this would be very useful especially to traders or people that have lots of applications open and running in specific orders, so that if someone with less monitors tries to connect they can’t thus stopping them from jumbling up their display. Currently I have not seen ether action but instead some fairly nonsensical lowbred that would only work if you are only going to connect from machines with 1 or 2 screens.

    RemoteFX Maximum number of monitors:

    The other logical place to set the maximum number of monitors presented to a VDI “and thus a remote connection” would be with the “Maximum number of monitors:” dropdown on the RemoteFX video Adapter page in hyper-v or scvmm but this has no real effect apart from delivering a set number of RemoteFX enabled interfaces into a VDI. Again if the number of monitors you have locally don’t match the RemoteFX setting you get the failback of 1, you can see the other enabled interfaces as detached in the VDI though.

    I have got to a point where I no longer know what I can test or change and my findings are pointing to ether a MS BUG or a fairly big clanger that has been Actively non-documented.

    Again any help would be greatly appreciated   

    Many thanks

    James


    Saturday, August 4, 2012 6:26 PM