VM cannot access to a host-share using Hyper-V


  • Hi,

    I have a Windows Server 2008 with Hyper-V.  SP2 is installed.  When I try to access a host-share from a vm, I get one of the following error messages:

    An unexpected network error occurred.


    The specified network name is no longer available.

    When I select the host in the network enviroment, I get this error:

    "\\host cannot be accessed.  You might not have permission to use this network resource.  Contact the administrator of the server to find out if you have access permissions.

    The specified server cannot perform the requested operation."

    What can I do?
    Thanks Gerd
    Wednesday, August 12, 2009 9:12 AM

All replies

  • Hi Gerd,

    what kind of Virtual Network are you using? (External, Private or Internal) Are you able to ping the host? Are you able to access other resources on the network? Can you access the hosts resources from another machine (bare metal)?

    kind regards,
    Floris van der Ploeg
    • Proposed as answer by Mike veschi Tuesday, June 14, 2011 3:24 AM
    Wednesday, August 12, 2009 10:26 AM
  • Hi Floris,

    < what kind of Virtual Network are you using? (External, Private or Internal)


    < Are you able to ping the host?


    < Are you able to access other resources on the network?


    < Can you access the hosts resources from another machine (bare metal)?


    I'm desperate

    Thanks and kind regards
    Gerd Koehler
    Wednesday, August 12, 2009 1:43 PM
  • Is your Root Partition joined in a domain, but your Guest OS isn't?
    Did you try using the net use command, providing a username:

    net use * \\host\c$ /user:DOMAIN\SomeUser

    Wednesday, August 12, 2009 3:07 PM
  • The Root Partition (Host) is in a workgroup, the Guest is joined in a domain (domaincontroller is also a Guest).
    The name of the workgroup is the same as the domain name.

    net use * \\name of host\c$ /user:name of host\administrator password

    I get one of the following error messages: System error 59 or System error 64

    Wednesday, August 12, 2009 3:23 PM
  • Hi,

    Thank you for posting here.

    Please help to collect the following information for research.

    1. Did you try to use IP address to visit each other? If not, please try IP address directly.

    2. Did you setup any IPSec policy in VM Domain? If so, please try to disable them and test.

    3. Help to collect MPS Report on bother VM and Host system.

    a. Download proper MPS Report tool from the website below.

    Microsoft Product Support Reports

    b. Double-click to run it, if requirement is not met, please follow the wizard to download and install them. After that, click Next, when the "Select the diagnostics you want to run" page appears, select "General", <and other necessary catalog>, click Next.

    c. After collecting all log files, choose "Save the results", choose a folder to save <Computername> file. Please use Windows Live SkyDrive ( to upload the file and then give us the download address.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, August 13, 2009 2:31 AM
  • Hello,

    Can the VM access shares on other hosts?  Did you disable the firewall on the parent partition?  Do you get the same problem with a second VM?


    Nathan Lasnoski
    Thursday, August 13, 2009 3:21 AM
  • Hi Nathan,

    <Can the VM access shares on other hosts?

    yes, this is ok

    <Did you disable the firewall on the parent partition?

    yes, i do

    <Do you get the same problem with a second VM?

    yes, unfortunately

    Thanks Gerd
    Thursday, August 13, 2009 8:10 AM
  • Hi,

    <1. Did you try to use IP address to visit each other? If not, please try IP address directly.

    The same effect with IP adress.

    <2. Did you setup any IPSec policy in VM Domain? If so, please try to disable them and test.

    No, i don't.

    <3. Help to collect MPS Report on bother VM and Host system.

    The files are available in

    Vhost is the Host-System with Windows Server 2008, SBSSERV ist the VM with Windows Server 2008 SBS

    Thanks Gerd

    Thursday, August 13, 2009 9:38 AM
  • Hi,

    Thank you for update. However, the log files are not in English and some important data cannot be read. In order to troubleshoot this problem efficiently, please post in local language forum.

    At the same time, I would like to provide some general troubleshooting information:

    Check SMB Signing settings.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 14, 2009 9:58 AM
  • geko1603, did you solve this issue? I have perfectly the same problem. Thanks in advance!
    Monday, October 12, 2009 9:02 PM
  • I am also have this issue, with one minor difference, I can not even ping the host.  The host and the VM do not see each other at all, but both access the network.

    I checked my SMB Signing Settings and they match.
    Wednesday, October 28, 2009 4:26 PM
  • I've got the same problem. Any update or news?
    I've created new test environment with W2k8 R2 host and guest connected with Internal only network. Clean installation, same IPv4 subnet, no DNS, no GW, all services bound, Windows Firewall turned off, one single share on each, result always the same from guest:
    net view \\
    System error 53 occurred.
    The network path was not found.

    From host is all ok:
    net view \\
    Shared resources at \\ 
    Share name  Type  Used as  Comment
    WINAPP      Disk
    The command completed successfully.

    Tried so many combination, but I can't figure it out. PLEASE HELP.


    Thursday, January 14, 2010 8:09 PM
  • I have the exact same problem here.  I have tried all the solutions above, but with no luck.  From the host, I have browse just fine, from the VM I can see everything but the host.
    Saturday, January 30, 2010 6:26 PM
  • I have the same problem now for a month.  The share works for a while, then drops off with resource is no longer available or the name is no longer on the network, but I can still ping it.  Other 2008 guests and hosts can access the host fine.  the 2003 guest is the one having the problem.  Have uninstalled integration services, and put it back.  uninstalled all the nic's and hyper v networking and re-setup.  Still this one guest will not stay connected to a network share to the guest.  Browsing the Guest is intermittant.  Help
    Saturday, February 13, 2010 7:25 AM
  • Is this a p2v?

    Are you using the same server somewhere else on the network?

    If so try changing the MAC address on the VM. ie 00-00-00-00-00-00 to 00-00-00-00-00-01

    Even if the MAC on the VM is different i have seen this issue and a number of other networking issues.

    Friday, February 19, 2010 4:27 AM
  • Yes, I've tried to change MAC address just to be sure. No help :(

    BTW I've made a couple of test also with W2k3 guest and the result is basically the same:
    System error 64 occurred.
    The specified network name is no longer available.
    Net view from the host to guest without a problem.

    It’s just unbelievable and ANY SUGGESTION IS GREATLY APPRECIATED.

    Friday, March 05, 2010 2:33 AM
  • Having the exact same issue, I guess. I have two hyper-v hosts, both configured identically (at least from what I can tell). On one I can access host shares from any guest, on the other not. The shares are working and available to all the other machines on the network, just not the guests on this one host. I can even ping the host IP from the guests using the name of the host and the IP of the host.

    My guests are multiple OSes like WinXP, W2K8R2, W2K3. The host is W2K8SP1.

    When I try to connect a share from the guest I get either
    An unexpected network error occurred.
    The specified network name is no longer available.

    I've already spent days trying to solve this problem, no luck so far. Anyone has an idea?

    cheers, Stefan Home of Royal TS and LogSmith for OpsMgr
    Wednesday, March 10, 2010 7:30 AM
  • I also have the same problem.  Has anyone found a solution?

    I have two VM servers with identical hardware and identical (as far as I can tell) network config.  One has this problem, while the other doesn't!

    Thursday, April 15, 2010 12:45 AM
  • Not really a solution but I ended up in reinstalling. Tried many things and after a week of frustration I started setup. Once reinstalled from scratch, I configured everything as it was before, started the very sane VMs and it worked as expected.
    cheers, Stefan Home of Royal TS and LogSmith for OpsMgr
    Saturday, April 17, 2010 3:14 PM
  • Stefan would you please tell us what setting you have achieved eventually?

    In my case it depends on what the guest os is. Like in Win7 or R2, it's less luck than in XP.

    Sunday, April 18, 2010 3:16 PM
  • My problem was on Windows 2008 Hyper-V and independent from the guest OS (XP, 2003, 2008 even 2008R2). I had two NICs in my hyper-v box, but used just one. My 2nd hyper-v box was configured identically (though it was a different hardware with different NICs) and from there, everything was just fine. Even when I moved VMs from my non-functioning hyper-v box to the functioning one, everything was fine and vice versa, when I moved a VM from the functioning box to the non-functioning, I wasn't able to access the host-shares anymore. So in my case it was clearly a problem of the hyper-v box!

    When I gave up, I reinstalled using Windows 2008R2 put all my guests on it and it just works. No special settings, except that I always disable IPv6 immediately when I install a new server.

    cheers, Stefan Home of Royal TS and LogSmith for OpsMgr
    Monday, April 19, 2010 8:27 AM
  • Hi Stefan,

    after a while I'm curious what do you think was the problem in your setup? Has this occurred to you again?
    I've been unable to resolve this issue for almost 6 (six!) months. I haven't reinstalled host yet as you suggested, because I thought there will be a simple resolution. Now I've got a dozen of guests and a virtual TMG routing between external, private and internal network, so it's getting complicated to troubleshoot. But the inability to access host shares still remains on Internal only network with or without TMG :(


    PS: I've been using Royal TS for all my RD work and I love it. All the best...

    Thursday, May 13, 2010 12:30 PM
  • Hi Dawid!

    Thanks for the kind words about Royal TS.

    I never was able to pinpoint the problem and as far as I know from the various threads in the forums out there, no one else was.

    All I can say, and my last incident with Hyper-V on R2 proved that, networking on Hyper-V is very flaky. Here's what happened: I bought a new Dell (R310) server, Hyper-V certified, pretty new chipset and all, installed Hyper-V R2, moved some virtual machines from my old Dell server (R300) to it, started them and guess what? Networking in the guest OS was not working at all. I couldn't get the virtual driver to start. Device manager always complained that the device couldn't be initialized. Even the legacy network device didn't start. I tried everything, like pointing to the drivers manually, trying different network drivers on the host system, talked to some guys @ MS, nothing  really solved the issue. After studying all the threads on the internet, I realized that there may be a problem with the on-board network card - which was a broadcom extreme II and decided to spend another 150 EUR to buy a Intel Server Dual Port Network Adapter. Keep in mind that networking on the host was working perfectly fine in any way - just the guest OSes of all kinds didn't work. It turns out that using the Intel card solved the issue. Everything worked fine.

    To sum up: networking is very flaky, certified for Hyper-V doesn't mean anything, nobody I asked - even @ MS could explain why this happened (to be fair, I didn't open a support call so we will never find out what happened in my case)

    And the most important thing: never use broadcom! poor driver quality as it seems.
    And the 2nd most important thing - if you can: try to avoid hyper-v, as long as it is in such a premature state.


    cheers, Stefan Home of Royal TS and LogSmith for OpsMgr
    Sunday, May 16, 2010 4:46 PM
  • Have the same Problem, I can ping from the VM to host, also from host to VM, but I can not join the domain, no smb access.


    I tried:


    1. HOST as DC, cannot join the domain with a VM


    2. VM as DC, cannot join the domain with HOST


    Always with Windows Server 2008 R2 Enterprise (as vm and host), newest Driver for all Components (Intel S5000PSL Server), also only microsoft driver.

    Tried 5-6 times fresh install.



    Monday, May 17, 2010 7:30 AM
  • Seems like you do not have the Virtual Network Configuration set up properly in Hyper-V and on your host machine. Getting it to work is simple and is not dependent on the the specific drivers used in most cases. You just need to do the following,

    1. Enable Virtual Networking (Use Internal mode)

    2. Enable ICS so that the Virtual machines get automatic IPs through DHCP

    3. Make sure that the Virtual Network ID used in the Virtual Network Adapter configuration matches your Virtual Network Configuration.

    Follow the steps mentioned in this blog below to Enable Shared Folders in Hyper-V



    Manesh K
    Friday, May 28, 2010 4:35 PM
  • Manesh,

    you are kidding, right? Please read the WHOLE thread, think about it, maybe learn "a bit" about networking (if you are interested) and reconsider to delete your post. No offense, but it's really not appropriate and will confuse others who could contribute to fix this specific network issue, which I assure you can NOT be solved by ICS.


    Friday, May 28, 2010 11:13 PM
  • Hi Dawid,

    Unlike what you are thinking, I am not kidding.

    My post was an answer to the original question that had started this thread, I had reached this thread the first time when I was googling for ways to configure Hyper-V and I was getting the same error message. And when I resolved the issue, I replied to this thread with what I had done to resolve the issue and put that as 'solution to one of the different ways that you could get that error'. I thought it would help someone who was stuck just like me. True, I had not read the whole thread but didnt see any reason to do that because there was no answers marked as answer.

    And about the line below from your early post,
    "Please read the WHOLE thread, think about it, maybe learn "a bit" about networking (if you are interested) and reconsider to delete your post"

    Whoa.. whoa.. that's strong language. :P

    Good day buddy!

    Manesh K
    Wednesday, June 02, 2010 5:12 AM
  • No solution found so far. I believe this is a bug with Hyper-V R2. I started to experience the exact same problem after upgraded to R2. It was working with the same network configuration across a dozen guests prior to the R2 upgrade.  Anyone found the fix, please post it here.

    Thank you!


    Wednesday, June 09, 2010 6:36 PM
  • More and more customers are encounting this problem, which is, VM can not access to a host-share using Hyper-V, but there is no other network problem at the same time.

    I would like to submit a case to Microsoft and ask for investigation on this issue, I will update the latest news from MS to this place. Hope we can find the solution or explaination from Microsoft soon.


    James Chiang

    Monday, June 14, 2010 2:10 AM
  • Thanks James,

    that'd be really great, if you can share MS explanation, because this error, bug or whatever it is, is driving too many people crazy.


    Friday, June 18, 2010 12:59 AM
  • Disabling TCP Autotuning seems to help resolve the problem - check out the link below


    Monday, June 28, 2010 12:39 PM
  • I have the same problem.  For months now.  I can see the shares, then poof they are gone.  Later on, back again then poof gone.  Four other VM's, 2003 and 2008 X64 and 32 can see the host shares just fine with no problems.  Only the one VM  (the production one!) Can not keep a connection.  I saw an issue on Symantec AV, 11 and that is the only thing going on with this host, but all the other VM's work just fine.  For the record, I have no AD or domain controller, just the router doing DNS.  It is just workgroup host and guests.  I tried wins, but that did not fix it.  Ready to try a repair install, would hate to have to take two days and migrate all the data to a new install!
    Wednesday, July 07, 2010 2:47 AM
  • Okay well nothing from nothing leaves something.

    On the guest:
    I flush the dns cache, -> ipconfig/flushdns
    Flush the arp cache -> netsh interface ip delete arpcache
    and so far she is holding together captin'

    I try to disable tcpoffloading and autotuning on guest next if this does not work
    TCP Offloading -> netsh int tcp set global chimney=disabled
    Autotuning -> netsh interface tcp set global autotuning=disabled

    I have seen the above two create real problems with Vista when enabled.  And when you get right down to it, Windows 2008 (pre R2) is "Vista Server"  :-)  Best of luck!

    Wednesday, July 07, 2010 3:24 AM
  • Have the same problem if using one network card.. virt. guest can't join domain (host is DC), access shares...

    Like workaround used two physical network cards on host (one dedicated only to virtual guests, other network card dedicated to host). Problem disapeared (from guest can access host shares, join domain)..

    But it would be nice to have solution with one network card (without private, internal network creation, legacy networks cards, etc.))....


    Tuesday, July 27, 2010 1:13 PM
  • After a dozens of days of investigating and realizing that this issue isn't just about SMB communication I've found the solution (at least on my Hyper-V R2 server):

    netsh interface tcp set global NetDMA = DISABLED

    Just run this command on your host and check the NetDMA State with command:
    netsh interface tcp show global

    TCP Global Parameters


    Receive-Side Scaling State          : enabled

    Chimney Offload State               : automatic

    NetDMA State                        : disabled

    Direct Cache Acess (DCA)            : disabled

    Receive Window Auto-Tuning Level    : normal

    Add-On Congestion Control Provider  : ctcp

    ECN Capability                      : disabled

    RFC 1323 Timestamps                 : disabled

    So in my opinion, there is no need to change Chimney Offload State, Auto-Tuning Level or mess around with network adapter advanced properties and definitely nothing on the guest OS. But Network Direct Memory Access is another story and looks like Server 2008 R2 is walking in Server 2008 shoes ( Also be aware of running Intel I/OAT on the Hyper-V host.

    Thanks everybody, although I have to point out that it'd be easier to find a solution if every one who isn’t really sure about the topic starts his post with something like "IMHO".

    Wednesday, August 04, 2010 3:05 AM
  • I have tried everything. Another SIX hours today. I seem to be able to copy files just fine, but when I try to run an application like NTBackup, it bombs out with delayed write failure. Ready to make the $200 call to Microsoft and watch them attack the sysetm with regedits and voodo commands !
    H e l p........
    Sunday, September 19, 2010 2:00 AM
  • i'm doing that today on the hyper-v host and i can access shares from internal VMs and when i want to connect to SCVMM console it give me an authantication error. the SCVMM server and the console installed on VM on the hyper-v host.

    Monday, November 08, 2010 11:08 PM
  • I finally gave up, got another server, loaded R2, and it works flawlessly.  Will reformat and reinstall this one and see if it still has the problem.
    Tuesday, June 14, 2011 2:41 PM
  • Hi,

    I just discovered the same problem with my VMs. After 2 days searches, I combined two of suggested solutions and it DID resolve my problem!

    On the host server, I issued the both 2 commands below :

    netsh int tcp set global chimney=disabled
    netsh int tcp set global NetDMA=disabled

    Another workaround which worked but was not satisfactory for me was to use hosts file on the guests.

    Hope this can help.


    • Proposed as answer by Rickkee Friday, September 30, 2011 3:20 AM
    Monday, June 20, 2011 10:06 AM
  • I had major problems with some machines win Vista first came out , with TCP Auto tuning.
    Since this is Vista server (2008, even R2) the problem will exist with some NICs.  After months of messing around and dealing with problems, I turned off TCP autotuning, and kablammm.. .It come up and work like a dream come true.   Try this first!

    netsh interface tcp set global autotuning=disabled

    Microsoft try to make it faster, but mess it up with Autotuning!

    More here:

    The best of luck to you with this most aggrevating problem.  Server 2008 and Hyper-v is cool, when it works but stoooopid settings like this ..... well go figure.

    Friday, September 30, 2011 12:50 AM
  • Update:  It worked for about 3 minutes.  I fussed and fussed and added in the two commands above.  It started working again... We'll see.
    Friday, September 30, 2011 3:16 AM
  • Hi.


    I have resolved this issue. Do these steps:


    0. Lets you have a physical computer with Windows Server, Hyper-V role and NIC named NIC. NIC is linked to your corporate network with DHCP, DNS, WINS etc.

    1. Open Hyper-V Networking management and create virtual switch in _Internal_ mode. Name it VNIC. Do not forget to specify VLAN ID.

    2. Link your VM to VNIC. Do not forget about VLAN ID again.

    2. Create network bridge between NIC and VSWITCH.

    3. Reboot physical PC.

    4. Star you VM. You can access to corporate network and host PC from VM.


    Wednesday, October 05, 2011 1:44 PM
  • Thanks guys... 


    >netsh int tcp set global chimney=disabled

    >netsh int tcp set global NetDMA=disabled

    >netsh interface tcp set global autotuning=disabled


    That fixed it for me!

    Friday, October 07, 2011 4:31 PM
  • Update... ugh, it did not really fix it.  Some VMs can see some files on the host now, but a lot of things still do not work, including DFS replication. 
    Tuesday, October 11, 2011 12:56 AM
  • In my opinion problem stays in folder permissions. I had the same problem. When I shared a folder on my hyperv host I deleted all accounts from the permission list. For the current folder a special user account was created and for which all privileges on that folder were granted. If I tried to connect to that folder from a user which was in a domain the same error appeared. The only solution that I could found was to grant everyone a read permission on that hyperv folder. I am not so comfortable to allow everyone on the network to see this backup folder however this is the only solution that worked for me and did not require a fresh reinstall..
    • Edited by mertoz Tuesday, November 08, 2011 12:33 AM
    Tuesday, November 08, 2011 12:31 AM