none
Printer not activated , error code -20 or -30

    Question

  • We are running Remote Desktop Services under Windows Server 2008 R2.

     

    Our Internal environment is a single 08 R2 server running RDS that users access at https://servername.domainname.local/rdweb where they are then presented their applications.

     

    Our External environment is two 08 R2 Servers with one server running gateway services and another running RDS services.  Users authenticate to an authentication device and then access 2<sup>nd</sup> server via https://Servername2.domainname.local/rdweb.

     

     

    We are publishing applications not publishing desktops.

     

    Issue:

     

    When user runs a report in an application on the internal environment that has an output to Display they are getting a pop-up that indicates Printer not activated, error code -20 or -30 after the report runs and attempts to display.

     

    The user is running Windows XP SP3, RDP client 7.0 and IE 8

     

    I have tested also on Windows 7 machine with IE 8 and received same error.

     

    2<sup>nd</sup> test was to access application via our External environment and the report ran without issue.  At the time there were no users logged into our external site/server.

     

    Google searches for the Printer not activated, error code -20 or -30 came up with a lot of issues from Intuit software that looks very similar but I’ve been unable to determine an appropriate path to resolution.

     

    It does seem to be very similar in that there may be a lock on the mechanism (printer) that is converting the report to be viewable via the display.  Thus, if one user is utilizing the mechanism then another user gets the error.  I have not tested with all the user’s log off and only with this one user log on but will do so tonight.

     

    In the meantime any ideas?

     

    Thanks,

    Tuesday, July 12, 2011 6:14 PM

All replies

  • Update:

     

    I logged into the internal site as myself, I’m an domain admin, and ran the report from FR100 and it displayed properly. I ran from my W7 workstation.

     

    Then I logged back into the internal site as the user and again attempted to run report and it ran fine.  Previous 4 attempts to run report gave error indicated.

     

    Definitely is starting to look like a locking issue?

    Tuesday, July 12, 2011 6:35 PM
  • Update 2

    Definately a locking issue with the print driver provided by the Manufacturer.  The manufacturer installs an Amyuni PDF driver on install and when running a report to display to screen it calls on this driver. 

    I contacted the manufacturer and am now updating the driver from a new install package that updates the printer driver from Amyuni document converter V3.0.0 to Ayumni document converter 300.

    We'll see if that works.

     

     

    Tuesday, July 12, 2011 9:37 PM
  • Did not work.  Back to Sq 1
    Wednesday, July 13, 2011 12:07 AM
  • 1. 2008 R2 - Apply hotfix 2549036 "0x0000000A" stop error occurs when several applications access the same network share file by using the MapViewOfFile() API on a computer that is running Windows 7 or Windows Server 2008 R2 http://support.microsoft.com/default.aspx?scid=kb;en-US;2549036  - update Rdbss.sys

    Reboot required

     2. install XP Hotfix

    When you print an XPS file on a Windows XP Service Pack 2 or Service Pack 3-based computer, the characters in the XPS file print incorrectly

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;946411

    Let us know how it goes.


    Ketan Thakkar | Microsoft Online Community Support
    Thursday, July 21, 2011 12:30 PM
    Moderator
  • Neither are applicable

    For the server its not crashing and I'm not getting the error indicated

    For the workstation

    running Windows 7 and Windows XP not printing to an XPS file.

    next?

     

     

    Monday, July 25, 2011 6:02 PM
  • I understand that is not the issue, can you please install the hotfixes in either case? That could resolve the issue.

    RDBSS.sys controls redirected printers and that hotfix is the latest.

     


    Ketan Thakkar | Microsoft Online Community Support
    Thursday, July 28, 2011 4:06 PM
    Moderator
  • When trying to install http://support.microsoft.com/default.aspx?scid=kb;en-US;2549036 I get this update is not applicable to your computer on my Windows Server 2008 R2 system.

    Rdbss.sys version I'm running is 6.1.7601.17514 while the update indicates should be 6.1.7601.21732. ???

    Monday, August 08, 2011 8:07 PM
  • Hi,

    Can you provide some data from the environment?

    I'll need MPS report from the Server http://www.microsoft.com/download/en/details.aspx?id=24745. You can send this to below email:

    blrforum-at-microsoft-com (remove '-')

    Can you only repro this with PDF driver? does it repro with otehr printers/drivers? Are you RDP'ing twice in this scenario?

    Make sure that driver is not isolated and you have disabled client side rendering on the RDS server http://blogs.technet.com/b/askperf/archive/2008/02/10/ws2008-client-side-rendering.aspx

    Also, to note, we don't recommand CSR on RDS.

     


    Ketan Thakkar | Microsoft Online Community Support
    Wednesday, August 10, 2011 4:52 PM
    Moderator
  • Hi,

    Check if you printer you are wanting to print from is the default printer to your system.

    You can make the printer your default printer by clicking ‘Start‘, and then click ‘Printers and Faxes‘ to open the ‘Printers‘ folder, if the desired printer does not have a check mark next to it, right-click the printer icon and then click ‘Set as Default Printer‘.

    You can right-click on the printer icon, and then click on the ‘Print Test Page‘ to print a Windows self-test page.

    http://printers.iyogi.com/errors/printer-not-activated-error-code-20.html

    Hope this information helps you.

     

     

    Wednesday, September 28, 2011 5:14 AM