none
Scheduled Task Failing (0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.) RRS feed

  • Question

  • OS:Windows 2003

    Application: Scheduled Tasks

    Problem: I have Scheduled Tasks failing on 2 servers. They are setup the exact same way on all servers but the status shows could not start even though the Last Result shows a 0x0. I have done everything in this technote http://support.microsoft.com/kb/308558

    I still get the following error:DailyLogBackup.job" (DailyLogBackup.bat) 12/21/2010 12:05:00 AM ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.

    Tuesday, December 21, 2010 4:07 PM

Answers

  • Hi,

    This problem may occur if the task account doesn’t have "logon as a batch job" privilege. Click Start, type "gpedit.msc", try to configure the following policy:
    [Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment]
    -Log on as a batch job.

    Add the account and Administrators, Backup Operators into the list.

    Could the task work properly?

    Or you can just add the account into Administrators group to test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 22, 2010 2:51 AM
    Moderator

All replies

  • Hi,

    This problem may occur if the task account doesn’t have "logon as a batch job" privilege. Click Start, type "gpedit.msc", try to configure the following policy:
    [Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment]
    -Log on as a batch job.

    Add the account and Administrators, Backup Operators into the list.

    Could the task work properly?

    Or you can just add the account into Administrators group to test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 22, 2010 2:51 AM
    Moderator
  • Hi,

    Have you tried the suggestions? Any update is welcomed. If there is any problem, please let us know the detailed error message. 

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 27, 2010 6:04 AM
    Moderator
  • Yep that fixed it.
    Monday, December 27, 2010 6:36 PM

  • Glad to hear the suggestions worked. If you have more questions in the future, you’re welcomed to this forum.

     Thanks. 


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 28, 2010 7:00 AM
    Moderator
  • Thanks - Yes it is working properly.

    Just I want to add a simple note - if it is under domain you have to use "gpupdate /force"

    Also I found this suggestion useful as I got same error when I try to run a virtual machine on Hyper-V (on Server 2012)


    Sunday, September 1, 2013 11:39 AM
  • This does not work for me.   When I bring up Log on as a batch job, the Add button is grayed out and there is a message at the bottom of the screen that says, "This setting is not compatible with computers running Windows 2000 Service Pack 1 or earlier. Apply Group Policy objects containing this setting only to computers running a later version of the operating system."

    I'm running Windows 7 Professional.   Why am I getting this error??

    Thursday, March 19, 2015 5:55 PM
  • Laurie,

    That means the setting is controlled by Group Policy on your domain. Contact your network administrator for assistance. Hope you can get it working. I have the same issue but my IT help desk has been good about making GPO exceptions for my needs.

    Take care,

    Andrew

    Monday, March 30, 2015 5:37 PM
  • I am having the same problem.

    I added Administrators, Backup Operators as well as the identifty that the web site is running under to the Local Group Policy Editor -> Computer Config ->Windows Setings->Security Settings -> Local Policies -> User Rights Assignment - Log on as batch job.

    Also ran 

    gpupdate /force

    No dice.

    Friday, April 10, 2015 1:29 PM
  • I want to run a scheduled task on a standalone laptop but I am getting this error. I am running Windows 7 on Intel Core i3. Anybody can help what this means in the case of a standalone computer?
    Thursday, October 8, 2015 4:01 PM