locked
Event ID 9 RRS feed

  • Question

  •  

    I get this error on my Windows 2008 Server that is hosting SQL Server 2005.  I have all the lastest patches installed.

     

     

    Target did not respond in time for a SCSI request. The CDB is given in the dump data.  Log Name System  Source iScsiPrt.

     

     

    How do I begin troublkeshooting this?

     

    Thanks!

    Shawn

    Friday, May 23, 2008 4:05 PM

Answers

  • Hello,

     

    Event ID 9 is logged when the target did not complete a SCSI command within the timeout period specified by SCSI layer.

    The dump data will contain the SCSI Opcode corresponding to the SCSI command.

     

    Please try the following resolution to solve this issue:
    ======================================


    1. On the Windows system, click Start, click Run, type regedit and press Enter.
    WARNING: As serious problems might occur if you modify the registry incorrectly,

    please refer to the following KB article to back up the registry before you modify it:

     

    How to back up and restore the registry in Windows

    http://support.microsoft.com/kb/322756/en-us

     

    2. In HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk,

    edit or add the TimeOutValue entry to set it to 60 seconds in decimal format (0000003c in hexadecimal).

    -- To edit the value for the TimeOutValue entry if it already exists, double-click the entry, enter the new value, and click OK.

     

    -- To add the TimeOutValue entry if it does not yet exist, right-click anywhere in the list of values, and then click New > DWORD value. Name the new value TimeOutValue, and then double-click it to edit the setting.

    Note:

    If you are not running iSCSI Initiator v1.05a, you can also check the following:

    Go to the registry value MaxRequestHoldTime at the following registry key:
    HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}
    Increase the value to 90. If that does not work, try 120.

    Meanwhile, please also contact to your iSCSI device manufacturer to confirm whether this issue is caused by the iSCSI device.

     

    Thanks. Smile

     

    Neo.

     
    Tuesday, May 27, 2008 10:34 AM