none
"(VM) Failed to Change State." RRS feed

  • Question

  • Hi all,

    None of my VMs will start.  Here's a copy and paste of the error:

     

    [Window Title]
    Hyper-V Manager

    [Main Instruction]
    An error occurred while attempting to start the selected virtual machine(s).

    [Content]
    'Win XP Pro x86' failed to change state.

    [Close]

    That's all I've got.  How can I find the issue?  I've tried creating new VMs and using the old VHDs.  Didn't help.  I'm not sure where to go from here.  Where else can I look for clues as to why HyperV isn't working?

    Thanks,


    Brandon

    Sunday, November 28, 2010 3:32 AM

All replies

  • Hi.

    We need some more details about your environment.

    When did this problem start? Do you have an x64 compatible processor with intel VT or AMD-V technology enabled ?

    Hardware Data Execution Prevention (DEP) mus also be available and enabled.

    If running antivirus, remember to exclude VMMS.exe, MMS.exe, VMWP.exe, VMSWP.exe, and also the directory that contains your VMs, VHD, avhd, vsv, iso, vfd, xml.

    Have to tried to recreate the VM, and attached the VHDs ?


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    Sunday, November 28, 2010 9:20 AM
  • Hi Kristian,

    Thank you for your reply.  This started after I had a harddrive lose power while the server was running and this shut the system down.  I do have an x64 compatible processor and virtualization is enabled and has run before fine for several months. 

    As mentioned in the first post, I have tried to recreate the VMs using the VHDs and it does no good.  I did not install an anti-virus just before this problem began, either.

     

    Thanks,


    Brandon

    Sunday, November 28, 2010 6:23 PM
  • Hi. 

    Sorry that I missed that you tried to recreate the vms in your first post.

    Please check the logs under: (Applications and Service Logs->Microsoft->Windows->) Hyper-V-Config, Hyper-V-Hypervisor, Hyper-V-VMMS, and Hyper-V-Worker.

    Many things can go wrong, and will go wrong when a server lose its power. Do you have a backup of your VMs ?


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    Sunday, November 28, 2010 6:43 PM
  • No worries.  :)

    When I try to check my logs, it just tells me that "Event log service is unavailable.  Verify that the service is running."

    I have and it is.  Hmmm...  this isn't a production machine, so it may just be time to reinstall.

    Any thoughts?  Many thanks for your help!

    Brandon

    Sunday, November 28, 2010 6:57 PM
  • :-)

    It sounds that there are other issues than just starting the VMs.

    You may have some errors on your disk. You could try to access the eventviewer from another machine in your network, and connect to your server.

    Anyhow, it may take some time to troubleshoot, and the errors seems to be related to your disk. So maybe a new disk and a re-install is the fastest way around this issue.

    Regards, 


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )
    Sunday, November 28, 2010 7:03 PM
  • Hi,

     

    Any progress with your issues?

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, November 30, 2010 9:43 AM
    Moderator