RemoteApp RDP does not work in another shell than explorer


  • Hi, we are new to remote apps.

    We have a WS08R2 server, we created a RDP file for our app, put RDP on our XP machines, start it by cmd line or double-clicking. Our app starts correctly as a RemoteApp. We then change the shell of the XP machines, the shell does not have any toolbar nor Start Menu. The remote app does not work: the mstsc windows appears, asks credentials, tries to connect but times out without showing any messages.

    So we made a RDP for windows calculator, does exactly the same as above. It works in explorer shell and not in ours.

    2 possibilities:

    - RDP file attributes needs to be modified.

    - our shell blocks something required by the remote app rdp.

    Note: in our shell when we mstsc.exe in cmd prompt, remote desktop starts without any problem.

    Thanks in advance

    Monday, November 15, 2010 11:34 PM

All replies

  • When a RemoteApp program starts, it is initialized by Rdpinit.exe and launches the seamless shell Rdpshell.exe before the program is displayed on the screen. This means that there is no Explorer.exe running in this user session. The seamless shell lacks some of the functionality that the full-blown Explorer shell has - for obvious reasons as there is no need for all the full desktop stuff.

    Now it seems like your client-side shell is not compatible to what Rdpshell.exe expects it to do in terms of graphics output.

    Hope that helps to solve the issue (or at least understand what's going on).


    Tuesday, November 16, 2010 9:51 AM
  • HI Benny,

    thanks for the reply. We thought of that after going here

    Do you think we are missing some services in our shell that are necessary for RemoteApp to work? Maybe we could start them manually to see if it works?

    We are looking into the shell to see what could block the graphic output.


    Tuesday, November 16, 2010 2:40 PM
  • Hi again Benny,

    We are seeing the possibility to modify our shell. Can you provide us with what needs to me implemented in order to satisfy the requirements for RemoteApp to work? Are there any tools that could help us?


    Tuesday, November 16, 2010 3:32 PM
  • Hi,


    I found one KB describes an issue when starting an application in Windwos Server 2008 RemoteApp session.


    An application does not start in a Windows Server 2008 Terminal Services RemoteApp session



    Hope this helps.

    Wednesday, November 17, 2010 7:04 AM
  • Terry,

    unfortunately I don't have a technical specification on API level that shows what is required to develop an alternative Windows shell that is compatible to RemoteApp. I hope that Microsoft is able to provide this. There may be some information available through MSDN.


    Wednesday, November 17, 2010 1:22 PM
  • Hi Terry,


    You can use the RDS application Compatiblity Analyzer with your application to see if you can pinpoint the issue.


    See this blog entry for more details.


    How to detect RDS-specific application compatibility issues by using the RDS Application Compatibility Analyzer



    Hope this helps.

    Thursday, November 18, 2010 2:34 AM
  • Hi, Terry.

    Have you solved the program?

    If yes, can you share the solution?

    I have the same program ...

    Friday, August 05, 2011 4:30 AM
  • Hi Ruikuan,

    we looked into using policies to restrict what we want/don't want the user to access. So we kept the explorer shell but removed some accesses. Therefore our RemoteApp starts correctly.

    • Edited by RemoteTerry Tuesday, October 04, 2011 6:40 PM
    Tuesday, October 04, 2011 6:38 PM
  • I hade the same problem. We have created a "connection application" that we start as the shell on Windows 7 Embedded clients, and normal RDP sessions worked just fine, but RemoteApp connections diden't.

    We found that if we manualy start rdpinit.exe RemoteApp also work without having to run Explorer.exe

    Best regards,
    Johan Christensson

    Thursday, March 15, 2012 7:43 PM
  • Hi Johan,

    we have exactly the same problem. What do you mean by manually starting the rdpinit.exe?

    The rdpinit.exe and the rdpshell.exe are already started in the user's session. Only the remoteapp is not executed. If we start the explorer.exe on the client's machine, the remoteapp is launched successfully.

    The only workaround is to use GPO's to cut down everything and let explorer.exe run so RemoteApps will work. But that's not an option for us.

    Thanks and regards


    Edit: I thought you mean starting rdpinit.exe on the client machine? Our terminals are using WinXP so there is no rdpinit.exe nor rdpshell.exe. After installing KB961742-V3 ( our terminal is booting in a loop :(

    • Edited by JanWrage Wednesday, March 28, 2012 10:13 AM
    Wednesday, March 28, 2012 9:00 AM