none
rd web access 2012 public computer / private computer radio button

    Question

  • In 2008 R2 you could modify the login.aspx page and change the default radio button selection on this page so that the "this is a private computer" option was selected by default.  (see this thread: http://social.technet.microsoft.com/Forums/windowsserver/en-US/320d979f-9067-4dcd-9424-ab65a7bf6486/this-is-a-private-computer?forum=winserverTS)

    now its seems this does not work.

    I have changed the code on login.aspx to reflect my wish to make the "Private" option radio buttonthe default selected one by adding checked="checked" to the proper Input section and removing it from the other, but it does nothing (and I restarted the website too):

                        <label><input id="rdoPblc" type="radio" name="MachineType" value="public" class="rdo" onclick="onClickSecurity()" /></label>
    ...

    ...

                       <label><input id="rdoPrvt" type="radio" name="MachineType" value="private" class="rdo" onclick="onClickSecurity()" checked="checked" /></label>
                     

    I have also looked through the renderscripts.jsp file but I dont't see an option to make the default checkbox change.

    So where is this option located now?

    Thanks!


                                         
    Tuesday, October 08, 2013 12:07 AM

Answers

  • Hi,

    If you want you can try the below change and see if it meets your needs.  Please note it has not been tested thoroughly, and that if the user wants Public mode they have to change it every time they log on.  I recommend making a backup copy of the original renderscripts.js and testing extensively to make sure you are happy with the new behavior and/or to discover any problems.

    In the renderscripts.js file, change the below line:

        document.getElementById("rdoPblc").checked = true;
    To the following:
     // document.getElementById("rdoPblc").checked = true;
    Thanks.

    -TP

    Monday, November 04, 2013 4:24 PM
    Moderator

All replies

  • Hi,

    In response to your post, I can prefer you to make small change and have a try, in accordance to “Modifying the default RDWebAccess web page “article. 

    Please change according as below:

    Instead of checked= "checked" just simply try change to checked:

    <label><input id=”rdoPrvt” type=”radio” name=”MachineType” value=”private” class=”rdo” onclick=”onClickSecurity()” checked /></label>

    Hope This Helps!
    Thanks.

    Wednesday, October 09, 2013 9:31 AM
    Moderator
  • yep I already tried that and it did not work. thanks though. that actually breaks the page. I wish it were that simple. this is a change from 2008r2. any other advice?

    Wednesday, October 09, 2013 2:37 PM
  • Hi,

    Firstly sorry for late reply.

    The method which provided is by default, just check again and it must solve the issue. Here providing the article which related for OWA (outlook web access) to select the default “This is private computer”. May be you can try to set the value of cookie time-out. For more information refer this article.

    For more detailed regarding coding, you can contact our MSDN Forum for better assistance.

    Hope it helps!
    Thanks.

    Monday, October 14, 2013 2:59 AM
    Moderator
  • I dont see why setting the cookie timeout value would have any bearing on which setting you pick first by default.  And the setting you keep saying works, DOES NOT work for me. Can you confirm it works for you in 2012 environment?

    THanks.  

    Thursday, October 17, 2013 10:50 PM
  • Sunday, October 20, 2013 8:46 AM
    Moderator
  • Hi,

    For this issue, please check the below steps:

    Please perform the following steps:

    --------------------------------------------

    1.     On the Web Access server, navigate to the following folder:
      %windir%\Web\RDWeb\Pages\en-US\

     

    1.     Backup the file logon.aspx to another place.

    1.     Right-click the login.aspx file and select Edit, the file will be open with Notepad or other default HTML editor.

     

    1.     Use Find feature to find the following code snippet:

    <label><input id=”rdoPblc” type=”radio” name=”MachineType” value=”public” onclick”onClickSecurity()”  checked /></label>
    and remove the checked from the code:
    <label><input id=”rdoPblc” type=”radio” name=”MachineType” value=”public” onclick”onClickSecurity()” /></label>

     

    1.     Use Find feature to find the following code snippet:

    <label><input id=”rdoPrvt” type=”radio” name=”MachineType” value=”private” onclick”onClickSecurity()” /></label>
    and add a checked properties in the label:
    <label><input id=”rdoPrvt” type=”radio” name=”MachineType” value=”private” onclick”onClickSecurity()” checked /></label>

     

      Save the change.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.&nbsp;

    Thursday, October 24, 2013 11:58 AM
  • This doesn't work in my S2012 environment - breaks the page.

    Terrence O'Leary KMHS Systems Integration Analyst


    • Edited by terrenceo Thursday, October 24, 2013 4:10 PM
    Thursday, October 24, 2013 4:09 PM
  • Hi,

    Sorry for the inconvenience. I suggest we change it back 1stly to recover the page. Besides, I'm consulting our global discussion group on this and will update you ASAP. Thanks.

    BR,

    Kevin Ni


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, November 04, 2013 2:50 PM
  • Hi,

    If you want you can try the below change and see if it meets your needs.  Please note it has not been tested thoroughly, and that if the user wants Public mode they have to change it every time they log on.  I recommend making a backup copy of the original renderscripts.js and testing extensively to make sure you are happy with the new behavior and/or to discover any problems.

    In the renderscripts.js file, change the below line:

        document.getElementById("rdoPblc").checked = true;
    To the following:
     // document.getElementById("rdoPblc").checked = true;
    Thanks.

    -TP

    Monday, November 04, 2013 4:24 PM
    Moderator
  • Thanks TP - that works!  Much appreciation! --Terrence

    Terrence O'Leary KMHS Systems Integration Analyst

    Monday, November 04, 2013 11:20 PM
  • For those looking for a 2012 R2 fix for this issue - make the below change in the renderscripts.js file:

    1. Find this line:

    function onClickSecurity() {
        var bPrivateMode = document.getElementById("rdoPrvt").checked;

    2. Change this line to:

    function onClickSecurity() {
        var bPrivateMode = document.getElementById("rdoPrvt").checked = true;


    3. Save your changes and test!

    Thursday, July 20, 2017 1:19 AM