none
Error 0x000003e3 when installing a print driver on Windows 7 32-Bit machines

    Question

  • Hi everyone,

    I have run out of ideas, so this forum is my last hope.

    I already read the following posts, but either it did not fix the problem or it was not reflecting my issue:

    • http://social.technet.microsoft.com/Forums/en-US/winserverprint/thread/d9676ceb-e18d-4bd8-ae09-9e9b50a8cf6f
    • http://social.technet.microsoft.com/Forums/en/itprovistaprinting/thread/9c14dd83-2c71-45d3-8829-7e9cabb04d86
    • http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/95284883-e9bf-45a8-99ed-43d14483fbd3
    • http://social.technet.microsoft.com/Forums/en/w7itproinstall/thread/a0cad96e-4a4f-404e-a553-8f5f891a9361

    This post seems to match my issue pretty well, unfortunately there is no helpful answer to it:

    • http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/1a3c9144-383d-48e6-bcc3-7eaab1fb84b1

    Here's some background about the issue and what I've already tried:

    • We have a fileserver which runs Windows 2008 Server Standard SP2 32-Bit.
    • The fileserver also works as print server.
    • All printers are network printers.
    • Printers used are HP LJ, HP CLJ, HP DesignJet, Zebra, Kyocera
    • We work in a Windows Domain (AD).
    • We have Windows XP (32 bit), Windows 7 (32 bit and 64 bit) running
    • All users have standard privileges

    The problem occurs only on Windows 7 32 bit machines with the Zebra ZM400 ZPL printer.

    The printer is installed on the print server via standard tcp/ip port. The latest zebra drivers are installed for x32 and x64. It is certified for Windows as stated here.

    When connecting the shared printer the driver installation starts (progression bar) but after some files it cancels with the error "0x000003e3". But only on the Windows 32 bit machines. There are no problems with the print driver installation on the XP or 64 bit machines whatsoever.

    I have tried several workarounds mentioned in different forums or posts in this forum without any luck unfortunately:

    • local printer: Does only work as local administrator with administrator privileges. Does not work with other user account neither with standard privileges nor with administrator privileges (results as described by "lneblett" on Saturday, March 12, 2011 7:34 PM)
    • creating new registry key manually: did not work at all
    • local printer

    I have then connected a second printer (same model) on a test machine (win7 32 bit) directly via USB using the same printer driver installation file. The driver was installed without any problems.
    Therefore I exclude the driver itself for causing the problem which leaves only the client or the print server.

    I have then installed the printer directly on my client machine running win7 x64 and shared it . I also installed the alternate driver for x32. After that I connected from my test machine to that printer. The print driver was again installed without any problems.
    Therefore I tend to exclude the client, too.

    I added the print server role to another Windows 2008 Server Standard SP2 64 bit and shared the printer the same way as on our 32 bit print server and connected from the client successfully.

    That leaves only the print server.

    Any help is very much appreciated.

    • Edited by Tristan_R Wednesday, May 23, 2012 3:44 PM additional tests
    Wednesday, May 23, 2012 2:22 PM

Answers

  • Hi,

    Please downloaded the latest printer driver for Zebra ZM400 ZPL  printer.


    Installed the driver on the Print server.

    Installed the drivers using the Zebra setup wizard to update manually.


    Then, try to add the Zebra ZM400 ZPL  printer through network share to test.


    Hope this helps!

    Best Regards
    Elytis Cheng


    Elytis Cheng

    TechNet Community Support


    Thursday, May 24, 2012 12:09 PM
    Moderator