none
Error 1920: "MetaCommunications Services Watcher" (MetaCommServicesWatcher) failed to start. Verify you have sufficient privileges to start system service." RRS feed

  • Question

  • While trying to install third party software "Metacomm server component" , i'm getting an error
    "Error 1920: "MetaCommunications Services Watcher" (MetaCommServicesWatcher) failed to start. Verify you have sufficient privileges to start system service."

    All the goggling suggests this is not a 3rd issue... its a common Windows generic error.. And i've tried adding "Administrator" group to gpedit, User rights management, Running the .exe as admin. and extending the timeout in registry Windows to wait for longer for a service to start..

    Event viewer points to "it cannot start in a timely manner" which suggested me to increase that in registry, but it didn't help, with the only other error in event view stated above.

    I'm running Windows 2008 R2.. SQL server 2008, with all SQL services running, including SQLAgent. However i don't think SQL is related to this...

    But all of the "fixes/workarounds" i've tried, have failed..

    During install, when the error appears, the service is listed in services.msc, I have tried to enter my local credentials under "logon" but i guess this won't work when 'installing' software, only when issues when service not starting when ''logging into windows'

    In any case, what how can i fix this?



    • Edited by TECH198 Monday, January 20, 2020 5:24 AM
    Monday, January 20, 2020 5:23 AM

All replies

  • Hi,

     

    >>"Error 1920: "MetaCommunications Services Watcher" (MetaCommServicesWatcher) failed to start. Verify you have sufficient privileges to start system service."

    It shows user that is logged on does not have sufficient privileges to install system services.

    Kindly refer to the following steps and check if it helps:

    1. Navigate to Group Policy Object Editor > Local Computer Policy.
    2. In the console tree, navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies >User Rights Assignment.
    3. In the details pane, double-click Log on as a service.
    4. Click Add User or Group and add the account to the list of accounts that have the Log on as a service right.

     

    Hope can help you. Have a nice day!

     

    Best Regards,

    Kiki


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 21, 2020 8:27 AM
  • Hi,

     

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

     

    Best Regards,

    Kiki


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 22, 2020 1:36 AM
  • Hi TECH198,

    Please confirm that the question has been resolved and do not forget to mark helpful replies as Answer.

    Thank you


    Hamid Sadeghpour Saleh Microsoft Solutions Architect
    Cloud and Datacenter Management (MVP)


    Wednesday, January 22, 2020 11:42 PM
    Moderator
  • I am not on a domain, and Group Policy Object Editor can only be use don a domain...

    This is on a local machine, so I  assumed  have to use Local (gpedit.msc)

    It didn't work.

    Thursday, January 23, 2020 1:09 AM
  • Hi,

     

    Sorry for delayed reply.

    Here are some posts with the similar issue with yours, just for your reference, you can try the method mentioned in them:

    • Error 1920 service failed to start. Verify that you have sufficient privileges to start system services

    https://stackoverflow.com/questions/20061057/error-1920-service-failed-to-start-verify-that-you-have-sufficient-privileges-t/30399143

    • Service failed to start error 1920

    https://stackoverflow.com/questions/4406595/service-failed-to-start-error-1920

    Note: These are third-party links and we do not have any guarantees on these website. And Microsoft does not make any guarantees about the content.

     

    Hope can help you. Have a nice day!

     

    Best Regards,

    Kiki


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 4, 2020 7:30 AM
  • Kindly refer to the following steps and check if it helps:
    1. Navigate to Group Policy Object Editor > Local Computer Policy.
    2. In the console tree, navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies >User Rights Assignment.
    3. In the details pane, double-click Log on as a service.
    4. Click Add User or Group and add the account to the list of accounts that have the Log on as a service right.

     

    Hope can help you. Have a nice day!

     

    Best Regards,

    Kiki


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Even as an Admin account ?

    Why should i be adding my own account to this list ? I'm logging on as an Administrator, not a local created user account that i would need to "grant" admin" access to.

    "Local" is already listed anyway in group policy Object editor, and I just added "Administrator" to the list, even though i knew it wouldn't help and i was right .... I got the same issue,, even tried re-startling afterward after adding but before running installer again.

    I've been away on holiday, so couldn't reply for a while.

    Issue is still unsolved.


    • Edited by TECH198 Tuesday, February 18, 2020 12:23 AM
    Tuesday, February 18, 2020 12:22 AM
  • I tried authenticating on the service when this error  comes up during installation, and then hit "retry" but didn't help.

    I would have thought "Run as administrator" would help. but it failed,, That's the first thing i tried.

    On a wild guess, could out-dated installer cause this ? As looking in the system requirements PDF for the app, there is no mention of running it with SQL 2008, only with SQL 2005, and they don't mention Windows 2008 specially either.

    The PDF says:"NOTE: The Server Installer application (ServerInstaller.exe) is designed to run on Windows 2000/2003 Server computers."

    However, installer does start to install on Windows Server 2008 R2

    Just a hunch.

    Based on theerror, its seems a windows error, not a app error, but still...


    • Edited by TECH198 Tuesday, February 18, 2020 12:33 AM
    Tuesday, February 18, 2020 12:32 AM

    • Edited by TECH198 11 hours 25 minutes ago
    11 hours 27 minutes ago