none
windows could not connect to the group policy client service

    Question

  • I know this forum has similar questions, but none of them have answered my problem so far.

    Case:

    My parents have moved to a new place, so they received a new modem with build-in wi-fi.

    I had an old Gigabyte wi-fi-adapter, so I mounted it, and after some trouble I had the right drivers,

    and the connection to the modem was established.

    Their computer is encrypted, so on boot you have to enter a password to access the drive, and then Windows 7 Home x64 will automatically boot

    into the desktop since there's only one administrator account on the PC.

    The error pop-up is "windows could not connect to the group policy client service", and in event viewer I can see two errors.

    First error Screenshot:

    dl.dropbox.com/u/19374914/error1.jpg

    Second error Screenshot:

    dl.dropbox.com/u/19374914/error2.jpg

    Hope someone has a qualified guess.


    Wednesday, December 26, 2012 4:25 PM

Answers

All replies

  • Hi,

    Based on my understanding, the issue should be not a group policy issue but should be caused by the Group policy client service is stopped, you can try to restart it manually.

    If it does not work, maybe we could refer to the following links:

    Windows connect the group policy client:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/why-wont-windows-connect-to-the-group-policy/b73107f8-8447-4599-87a5-65ecc6a63aa0

    About event ID 7000:

    http://kb.prismmicrosys.com/evtpass/evtpages/EventId_7000_ServiceControlManager_44391.asp

    In addition, i suggest that you can post the problem in the Windows 7 forum:

    http://social.technet.microsoft.com/Forums/en/category/w7itpro/

    Hope this help!

    Regards


    Vivian Wang
    TechNet Community Support


    Thursday, December 27, 2012 6:28 AM
    Moderator
  • I FOUND SOLUTION TO THIS PROBLEM!

    I had this issue on my laptop since November, and it really bugged me.  I sifted through the event log and found the pattern of events that preceded the issue, and, probably, caused it.

    In short, the pattern is as follows: Windows updates run automatically as scheduled, and when reboot is initiated after the updates are finished, the computer crashes (probably during reboot sequence).  When it boots up, it reports that the last shutdown was unexpected, and the issue begins to occur.

    I spent 2 days trying to dig out a solution from the Internet, to no avail, until I came across this page.  It doesn't say anything about this particular problem, but it gives more information about SVCHOST process that starts many services, including Group Policy Client.  It looks like during reboot a vital registry settings were lost during the crash and Group Policy Client simply "doesn't know" how to start.  Let me explain:

    There are two places to look in the registry:

    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services this path should contain gpsvc key (a folder), which is responsible for service parameters and configuration.  I found that the key was intact, so, you do not touch anything here - just check that the key exists.
    2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SVCHOST This is the most important path you should look into, as it must contain the keys and values referred in the key #1.  Below are descriptions what must be present there.
    • There must be Multi-String value called GPSvcGroup. My laptop was missing it.  So, you should create multi-string value named GPSvcGroup and assign it value GPSvc.
    • Next, you must create a key (a folder) and name it GPSvcGroup - this key normally should be there, but, again, it was missin on my laptop.
    • Then open newly-created GPSvcGroup folder and create 2 DWORD values:
    1. First called AuthenticationCapabilities and you must give it a value of 0x00003020 (or 12320 in decimal)
    2. Second is called CoInitializeSecurityParam and it must have value of 1.

    Once you complete all steps above, reboot the computer and the problem will be fixed.

    Here is the link to the video walkthrough if you have any troubles understanding what has to be done: http://youtu.be/4m5KEmckWK4

    I am so relieved I was able to fix it, and hope this will help others with the similar issue.



    • Proposed as answer by SQL-ER Saturday, February 02, 2013 5:22 AM
    • Edited by SQL-ER Sunday, February 17, 2013 8:50 AM
    Saturday, February 02, 2013 5:16 AM
  • Spot on with this answer. Thank you!
    Wednesday, April 10, 2013 8:01 AM
  • Thank you good sir, that fixed the issue!!!!
    Monday, July 22, 2013 12:10 AM
  • Great research!  Was banging my head against the wall until now...  Thanks you!
    Monday, July 22, 2013 6:12 PM
  • So how do you explain a completely error free machine, with no GP popups, doesn't have any of those entries in the registry?


    • Edited by Napa PC Wednesday, August 14, 2013 12:53 AM
    Wednesday, August 14, 2013 12:53 AM
  • Thank you so much for this!! Have never commented before but felt compelled to sign in to say thanks, as I too had been scouring the internet for solution. Your video was super simple and well put together. You are a gentleman and a scholar, be well!
    Monday, September 16, 2013 1:34 PM
  • Send this to Microsoft, may be they will be able to explain. I can't.
    Friday, September 27, 2013 7:23 PM
  • Fixed it for me.  Thanks!
    Sunday, December 01, 2013 5:02 PM
  • Thanks !!!!
    Friday, August 01, 2014 12:52 AM
  • I found this to work for me as well.  If you want to save some typing create a new document in notepad and copy this in:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost]
    "GPSvcGroup"=hex(7):47,00,50,00,53,00,76,00,63,00,00,00,00,00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost\GPSvcGroup]
    "AuthenticationCapabilities"=dword:00003020
    "CoInitializeSecurityParam"=dword:00000001

    then save it as [what ever you want].reg with the file type set to all files. then double click on the file.

    Saturday, August 30, 2014 8:49 AM
  • This worked for me as well.  Note: I was running 64bit windows, but I chose the 32bit DWORD value and it worked.

    Thursday, February 19, 2015 4:54 PM
  • Thanks. This one works perfectly!
    Tuesday, February 24, 2015 6:04 PM
  • Thanks, fixed the issue I was having!
    Wednesday, February 25, 2015 11:09 PM
  • Thanks worked a treat for me
    Friday, September 25, 2015 3:56 PM
  • My wife's Dell ultrabook (windows 8.1) had this issue.  She could not logon.  The logon went to "logging off" and the message about Group Policy Client service (gpsvc) was on the screen.  The logoff took several (~10) min.  I tried this a couple of times with the same result.  I then tried logging in with the administrator account with no problem.  Note well that if you always login with an administrator account, you will probably not see this problem even though it may happen.  Admin accounts do not get processed by gpsvc.

    I looked at the event logs (System, Application) and noticed that the gpsvc had some issues starting (warnings).  There were some app errors overnight.  One app update with the issue was Skype.  The warnings occurred whenever there was a non-admin logon failure.  The error was an automated update.  I don't think some app updates go through the Windows Update process.  Should this one have not been automated?

    I looked at the prescription in this forum entry and decided I would not do any heroic registry changes before further investigation.  I decided to reboot!  After the reboot, non-admin user accounts would logon.  I checked the logs and did not see the warnings about gpsvc.  So I am happy.  Could the above prescription just have been accompanied by a reboot?

    I don't like this solution!  Reboot is not a solution although many ills may be cured by it.  It is very unsatisfying to me.  Likewise the prescription above is unsatisfying because in the registry I did not find the items that the prescription said to add.  Was that just a workaround?  It seems to me that the gpsvc not running is the real problem and the solution is to find out why the gpsvc did not restart.  It apparently does now.

    I wrote this because I think the information may be useful to others who encounter the same problem.  I see that it has occurred in many versions of Windows over many years.  Should windows update processes verify that essential services are running afterward?  If there are errors, maybe some resolution is needed.  It's probably not only windows update that caused the problem for others.

    I've spent a lot of time already on this.  Good luck.

    Tuesday, December 22, 2015 4:20 PM
  • Hello,


    This simple solution worked for me in Win8:


    Creating a new account.


    That's all...

    Tuesday, December 29, 2015 8:46 AM
  • Thank you! This worked for me as I was also missing the GPSvcGroup key and also fixed another issue I started having at the same time, a blank screen instead of the normal Windows Update screen (which prevented me from getting new updates).
    • Edited by Win10-64bit Wednesday, February 24, 2016 10:54 PM
    Wednesday, February 24, 2016 10:50 PM
  • Still works on Windows 10, thanks a ton for this!
    Wednesday, June 01, 2016 2:07 PM
  • This worked for me -- thank you!

    Sunday, July 17, 2016 8:01 PM