none
hyper-v issue: Mouse pointer invisible in Linux Mint 17 (run in hyper-v of windows 10)

    Question

  • Hi everyone:

        my problem is, after I installed the Linux mint 17 in windows 10 hyper-v, the mouse was invisible in the guest OS (Linux Mint 17). While the mouse really works, I can click the buttons in the guest OS, it's just invisible. anyone know what happened? I've tried to download the Hyper-v Linux integration services and tried to install it in Linux Mint and failed to do it. The setting of hyper-v shows that all the "integration services" are offered except the "guest services".

    Wednesday, November 04, 2015 12:08 PM

Answers

  • Hi Woods,

    Thanks for your sharing and I'm glad your issue was solved.

    If you have any questions later, welcome to post in the forum.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Woods Chen Friday, November 06, 2015 11:46 AM
    Friday, November 06, 2015 5:28 AM
    Moderator

All replies

  • OK, finally I installed the mate desktop instead of cinnamon. Then it works well now.
    Thursday, November 05, 2015 10:58 AM
  • Hi Woods,

    Thanks for your sharing and I'm glad your issue was solved.

    If you have any questions later, welcome to post in the forum.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Woods Chen Friday, November 06, 2015 11:46 AM
    Friday, November 06, 2015 5:28 AM
    Moderator
  • Thank you very much...
    Friday, November 06, 2015 11:49 AM
  • I have the same issue running Cinnamon on Linux Mint 17.3 "Rosa" within a Windows 10 gen2 Hyper-V vm...

    Leo, I do not think that ditching Cinnamon for Mate is a valid solution to Woods' problem, even though he is satisfied with that work around.

    Do you have a solution, or other information that would explain the cause, for the rest of us who wish to run Cinnamon? A response would be most appreciated, thank you :)

    Regards,
    Nick




    • Edited by gxtoast Sunday, February 14, 2016 5:40 AM
    Sunday, February 14, 2016 4:24 AM
  • Enabling RemoteFX 3D Video Adapter gave me a dot, although Mint was still only using 2D rendering.
    Sunday, February 14, 2016 5:56 AM
  • I have the same issue running Cinnamon on Linux Mint 17.3 "Rosa" within a Windows 10 gen2 Hyper-V vm...

    Leo, I do not think that ditching Cinnamon for Mate is a valid solution to Woods' problem, even though he is satisfied with that work around.

    Do you have a solution, or other information that would explain the cause, for the rest of us who wish to run Cinnamon? A response would be most appreciated, thank you :)



    Never fear, I is here. I've been working on this issue for 4+ hours and counting.

    FIRSTLY, this bug is DISTRO AGNOSTIC a.k.a. not related to Mint! All installations of *Cinnamon* on any GNU\Linux running on any version of Hyper-V is affected. (I think I remember the cursor working in a much older version of Cinnamon running on a Generation One Hyper-V VM. I'm currently using latest Cinnamon on Generation Two type VM.) 

    ALSO, I <3 Cinnamon and I <3 Server 2012 R2 Update 1 so rest assured I will spend at least an entire day working on a solution.

    Here is what I've tried so far so nobody else has to bother trying these:

    --The most obvious issue is lack of hardware acceleration. So lets edit xorg.conf and add under Display section add Option "HWCursor" "off" AND Option "SWCursor" "on" then it should work right? Wrong :-(

    --Loading Cinnamon from gdm3 instead of lightdm FAIL

    --Next I suspected, based on the fact the cursor works for the first few seconds of Cinnamon startup before becoming invisible, that the theme engine was the issue. So I went into /etc/share/ and found the Adwaita theme (Default theme for GNOME & Cinnamon) files and (after cp ./* ../backup/) rm -Rfv ./* all the cursor icon files hoping to force Cinnamon to leave the standard Xorg cursor intact. However, Ms. Cinnamon Cursor had me cursing out loud when she pulled her usual disappearing act after a fresh logon (following after a service lightdm restart.)

    So it has become apparently obvious that the solution lies somewhere in the Cinnamon configuration / user profile settings. It is not a issue with X nor a issue with the theming engine. Something in Cinnamon is forcing Xorg to attempt hardware acceleration of mice even though I always use Cinnamon in software rendering mode regardless.

    I will post back in this thread regardless of if I find a solution or not, just so we can say whether |or| NOT the current "Solution/Fix" is *really* to abandon the window manager of our choosing. Unfortunately, I am quite new to Cinnamon. I was a GNOME 2 user for most of my Linux using life but when GNOME 3 became standard I switched to Window Maker. No I am not joking, if I had a penny for every time I've typed apt-get install wmaker I would be able to purchase a Monster energy drink. (Of which, one or two, would be extremely useful at this moment as this task is frustrating me!) I spent hours manually handpicking the perfect combination of packages from either the Debian Stretch or Debian Sid repositories with LIS (Linux Integration Services) baked in to create the ideal Debian Hyper-V image for sharing with the community only to have this single, daunting bug ruining the whole project for everyone. ANYWAY, (wow I am tangential today) my point is that I've never so much as taken a peek at what a Cinnamon config file even looks like. (I have every single Window Maker option memorized but that isn't going to help us with Cinnamon :-/ .)

    Things to try next:

    --Figure out where the config files are located, what their filenames are, and what format they are coded in. Then experiment with different options.

    --Build the beta branch of Cinnamon from source to see if it's already been fixed upstream.

    --(The Opposite) use apt to remove the entire desktop-base and cinnamon packages and manually select the Cinnamon packages from Jessie or Wheezy. (Yuck, I really hope this isn't the "solution" either.)

    --Clone Microsoft's git repository of LIS source code and look over the code in the mouse kernel module for clues. (Comparing hid_hyperv diff between version for Gen 1 VM against the version for Gen 2 VM.)

    --Continue to search forums such as this one with Google and pray that the answer to our question lies elsewhere already. Additionally, I will check the official development site's bugtracker for an existing entry, and ultimately if none currently exists, file a report myself. (Which, knowing the Linux dev community, will probably be closed with the proposed "solution" being to format Microsoft Windows off all my disks and install Linux with Xen or VirtualBox as my virtualization platform...

    ~WiSh Me LuCk 

    ~Sincerely FøxysWorkplace

    Friday, March 18, 2016 12:56 PM
  • Enabling RemoteFX 3D Video Adapter gave me a dot, although Mint was still only using 2D rendering.

    Not a solution (especially for me as I have no GPU in my server so I can't DISM the RemoteFX feature for Windows Server and thus this setting can't be applied in my Hyper-V) nor does a dot a good cursor make :-) although I bet it's way better than the nothingness I have.

    THAT BEING SAID I want to thank you for this post. It 100% confirms my theory.

    Since your server has a GPU could you kindly run the following command inside the terminal shell of your Mint guest/vm please?

    lsmod|grep hv > ~/hv_mods.txt && lsmod|grep hyperv > ~/hyperv_mods.txt

    Run this command as one solid single line of commands (a.k.a. just copy>paste the whole thing and press enter) under a normal user account and please, please copy>paste the contents of the two text files it creates in your home folder to this thread.

    This code can not harm your system, especially since you won't be root, but even then they are harmless and more importantly this will tell me if enabling RemoteFX caused modprobe to detect some device and load an additional LIS kernel modules that we can manually load without enabling RemoteFX.

    AGAIN, this is NOT a solution but it might help me track down the problem in the Cinnamon config that is the real issue and get a nice pointer icon instead of dot or nothing. To reiterate, PLEASE, this will benefit the entire community of all us HyperV-Cinnamon users. (OK so maybe a niche group, but still a good deed!)

    p.s. Mint will always use "2D"/software rendering regardless of RemoteFX as Microsoft only provides vGPU driver for Windows, the way LIS renders is via framebuffer (hyperv_fb) but as you noted it definitely did SOMETHING and I just need to figure out what exactly...

    • Proposed as answer by PowerMonkey500 Sunday, January 08, 2017 5:31 AM
    Friday, March 18, 2016 2:17 PM
  • PRAISE ALL THAT IS HOLY!

    gsettings set org.cinnamon.settings-daemon.plugins.cursor active false

    The hardest part is opening a terminal window in Cinnamon without being able to see the cursor!

    Once you get your terminal open simply type the code above and press enter, YOUR MOUSE WILL INSTANTLY APPEAR!

    This must be done from within a X-terminal and using the user you will be logging on with (not as root, unless you are using Cinnamon as root, which is a REALLY bad idea.)

    DON'T FORGET TO VOTE/GIVE ME POINTS, I WORKED *HARD* ON THIS!

    SOLVED!

    Edit: I will prepare a shell script to automate this process if I receive a request.


    • Proposed as answer by FøxysWorkplace Friday, March 18, 2016 3:13 PM
    • Edited by FøxysWorkplace Friday, March 18, 2016 3:16 PM Added P.S. / Punctuation
    Friday, March 18, 2016 3:13 PM
  • Great catch!  Worked as stated.
    Friday, May 06, 2016 12:16 AM
  • worked perfectly!!  thank you!!

    Sunday, May 22, 2016 9:09 AM
  • Perfect.  Thanks.  Include a bitcoin donation address next time - I'd have gladly send you a couple bucks for this find!
    Wednesday, May 25, 2016 1:36 AM
  • If I could hug you I would, thank you so much for working on this and saving me hours of smashing things with a hammer.
    Monday, August 15, 2016 7:32 PM
  • PRAISE ALL THAT IS HOLY!

    gsettings set org.cinnamon.settings-daemon.plugins.cursor active false

    SOLVED!

    Edit: I will prepare a shell script to automate this process if I receive a request.


    Excellent work I just love it when hitting something that looks like it's going to give me lots of hard work digging into a problem (all be it small but very annoying) and then within a couple of mins of searching I found some lovely person did the hard work already and shared the results.  


    Saturday, August 27, 2016 9:18 AM
  • PRAISE ALL THAT IS HOLY!

    gsettings set org.cinnamon.settings-daemon.plugins.cursor active false

    The hardest part is opening a terminal window in Cinnamon without being able to see the cursor!

    Once you get your terminal open simply type the code above and press enter, YOUR MOUSE WILL INSTANTLY APPEAR!

    This must be done from within a X-terminal and using the user you will be logging on with (not as root, unless you are using Cinnamon as root, which is a REALLY bad idea.)

    DON'T FORGET TO VOTE/GIVE ME POINTS, I WORKED *HARD* ON THIS!

    SOLVED!

    Edit: I will prepare a shell script to automate this process if I receive a request.


    You are a god amongst gods.  Thank you!
    Tuesday, September 27, 2016 6:01 PM
  • Thx for gutting that out.  I'm sure it was a serious pain...
    Saturday, December 31, 2016 5:18 PM
  • PRAISE ALL THAT IS HOLY!

    gsettings set org.cinnamon.settings-daemon.plugins.cursor active false

    The hardest part is opening a terminal window in Cinnamon without being able to see the cursor!

    Once you get your terminal open simply type the code above and press enter, YOUR MOUSE WILL INSTANTLY APPEAR!

    This must be done from within a X-terminal and using the user you will be logging on with (not as root, unless you are using Cinnamon as root, which is a REALLY bad idea.)

    DON'T FORGET TO VOTE/GIVE ME POINTS, I WORKED *HARD* ON THIS!

    SOLVED!

    Edit: I will prepare a shell script to automate this process if I receive a request.


    Thankyou!!! 

    To make it easy for everyone else, use ctrl-alt-t to open a terminal window

    Saturday, January 28, 2017 2:39 AM
  • I have this SAME ISSUE but Linux Mint 18.1.
    Saturday, February 18, 2017 4:57 PM
  • That worked for me too! Will it last every reboot? We will have to see...
    Saturday, February 18, 2017 5:05 PM
  • I love you. Thank you so much. This was driving me bat-ish insane.
    Friday, April 21, 2017 5:02 AM
  • Works fine in Cinnamon 18.1. Great job!
    Saturday, June 03, 2017 10:41 PM
  • Works fine in Cinnamon 18.1. Great job!
    Saturday, June 03, 2017 10:41 PM
  • This quit working in linux Mint 18.2 

    Sunday, August 06, 2017 6:41 PM
  • Got it working in Linux Mint 18.2 by appending "Hidden=true" to /etc/xdg/autostart/cinnamon-settings-daemon-cursor.desktop

    Just run this in a terminal window and reboot:

    sudo sh -c "echo 'Hidden=true' >> /etc/xdg/autostart/cinnamon-settings-daemon-cursor.desktop"


    Gruß Daniel Haas

    Monday, August 14, 2017 9:39 AM
  • .. Linux Mint 18.2 ..

    sudo sh -c "echo 'Hidden=true' >> /etc/xdg/autostart/cinnamon-settings-daemon-cursor.desktop"


    Gruß Daniel Haas

    Thank you!  That worked for me on Linux Mint 18.2 using Cinnamon.  For others attempting this don't leave out ANY of the quotation marks.  Type it exactly as it looks above.

    Thursday, November 23, 2017 12:50 AM