locked
Hyper-V Win10 guest OS fatal error during VSS snapshot. Most current integration services installed. RRS feed

  • Question

  • Am having a Server Backup issue on my WS2012R2 server where any Win10 Guest OS is reported as (Offline).  When it attempts a scheduled backup of the Win10 Hyper-V VMs, the guest OS encounters a "fatal error 0xEF..."

    When I run the Get-VMIntegrationservices command on the WS2012R2 host, all is OK except for:

    VSS. Enabled = True, but PrimaryStatus shows "Non-Recoverable Error" and SecondaryStatus shows "The Protocol Version of the component..."

    The guest OS appears to be crashing when the Server Backup attempts to take a snapshot.

    Is there anything that can be done to correct this VSS error? or restore VSS functionality within the guest.  I suspect this was caused by some sort of Windows Update on the host but cannot seem to pinpoint it.

    I understand Integration Services for Win 10 are now done via Windows Update.  When I attempt to mount the Integration Services .ISO on the guest and run setup, it reports that the most current integration services have been installed within the Win 10 guest OS.  I cannot find a way to force a re-install or repair.

    Thanks.

    Sunday, August 21, 2016 3:07 PM

Answers

  • Hi Miles267,

    It seems it is a know issue and there are people investigating it.

    If I got any updates, I would post here.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 26, 2016 6:19 AM

All replies

  • Hi Miles267,

    Are you using Windows Server backup on host to backup Win10 VMs?

    >>The guest OS appears to be crashing when the Server Backup attempts to take a snapshot.

    What about taking a snapshot manually?

    Follow the troubleshooting guide of Windows Server backup to find the cause of the backup failure:

    https://technet.microsoft.com/en-us/library/ee692290%28WS.10%29.aspx?f=255&MSPPError=-2147217396#BKMK_ErrorList

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 22, 2016 2:52 AM
  • Hi Leo,

    Yes, I am using the Windows Server Backup on the host (WS2012R2) to backup Win 10 VMs.  I've confirmed any VM running a Windows version other than Win 10 works without issue.  And is reported as being Online to the host.  Clearly there is an incompatibility between the most current WS2012R2 integration services and those available to Win 10 via Windows Update.

    I've discovered this thread is exactly the same issue:

    https://social.technet.microsoft.com/Forums/en-US/d8291224-1826-4502-a94f-110a9a997da7/hyperv-2012r2-and-vm-windows10-the-protocol-version-of-the-component-installed-in-the-virtual?forum=winserverhyperv

    If you're able to help us you'll be a hero!

    Monday, August 22, 2016 3:01 AM
  • Hi,
    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, August 24, 2016 5:33 AM
  • Hi Miles267,

    It seems it is a know issue and there are people investigating it.

    If I got any updates, I would post here.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 26, 2016 6:19 AM