none
How to change WSUS 2012 port to 80??? RRS feed

  • Question

  • I have installed Windows Server 2012 on a brand new server, intention is to get rid of Windows Server 2008 R1, WSUS 3.0. SP2 on obsolete hardware.

    Port 8530 is NOT a option since we are talking about 5000+ clients without domain, that are configured to use port 80.

    Registry targeting is done by ip without port and manually changing them is NOT an option

    Br,

    Tommi


    • Edited by t_kolkka Wednesday, November 7, 2012 7:56 PM
    Wednesday, November 7, 2012 7:49 PM

Answers

  • Thanks to you too!

    But I solved it..... I tried it before it did not help, now it did...confused...

    C:\Program Files\Update Services\Tools\WSUSutil usecustomwebsite false !!! (Since 8530 is default in WSUS 2012)

    And to Lawrence, to ease your head:

    I run a centralized WSUS (Service Provider) for multiple customers who might or might not have AD (some could have GPOs), DMZ-machines and such...

    and their and our firewall is only open for WSUSip:80

    Tommi

    • Marked as answer by t_kolkka Thursday, November 22, 2012 6:42 PM
    Wednesday, November 7, 2012 9:48 PM
  • Not true, blank Windows Server 2012, add Role WSUS -> installs on 8530 without asking (of course it installs IIS and such at the same time)
    Hmmm... this defies every documented principal of installation for WSUS. I've not personally checked this, but I am quite intrigued. (Why would Microsoft change the standard behavior of the product for the past six years?) If that's what it does, then I'd say there is no way to install it to port 80.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, November 7, 2012 10:14 PM
    Moderator

All replies

  • Port 8530 is NOT a option since we are talking about 5000+ clients without domain, that are configured to use port 80.

    Registry targeting is done by ip without port and manually changing them is NOT an option

    First, I gotta say, I'm really trying to wrap my head around a 5000+ node network that hasn't deployed Active Directory, but is investing in Windows Server 2012 *and* deploying WSUS on Windows Server 2012.

    Having said that, though, there is only one way to install WSUS on port 80 -- install it on a server that isn't already using port 80 for something else. The WSUS installation defaults to port 80, and the only time it forces installation on port 8530 is when port 80 is already in use.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, November 7, 2012 8:50 PM
    Moderator
  • Hi!

    Thanks for the reply

    Not true, blank Windows Server 2012, add Role WSUS -> installs on 8530 without asking (of course it installs IIS and such at the same time)

    Tommi

    Wednesday, November 7, 2012 9:09 PM
  • Go in IIS manager, edit the bindings for the WSUS website and add one on port 80; disabling or adding host headers to any other site that's already using port 80.

    Make sure 8530 is reachable by your remote clients though, as the clients will still initially connect on port 80 as per their registry, but then they will at some point during the conversation notice that the server was installed on 8530.

    Wednesday, November 7, 2012 9:27 PM
  • Thanks to you too!

    But I solved it..... I tried it before it did not help, now it did...confused...

    C:\Program Files\Update Services\Tools\WSUSutil usecustomwebsite false !!! (Since 8530 is default in WSUS 2012)

    And to Lawrence, to ease your head:

    I run a centralized WSUS (Service Provider) for multiple customers who might or might not have AD (some could have GPOs), DMZ-machines and such...

    and their and our firewall is only open for WSUSip:80

    Tommi

    • Marked as answer by t_kolkka Thursday, November 22, 2012 6:42 PM
    Wednesday, November 7, 2012 9:48 PM
  • Not true, blank Windows Server 2012, add Role WSUS -> installs on 8530 without asking (of course it installs IIS and such at the same time)
    Hmmm... this defies every documented principal of installation for WSUS. I've not personally checked this, but I am quite intrigued. (Why would Microsoft change the standard behavior of the product for the past six years?) If that's what it does, then I'd say there is no way to install it to port 80.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, November 7, 2012 10:14 PM
    Moderator
  • Hi Mr. Garvin,

    "Why would Microsoft change the standard behavior of the product for the past six years?" Do you know the answer for this question? I have the same problem and did the same action, but I am not sure if it is safe or how it could be impact on WSUS.

    Friday, May 19, 2017 4:14 PM
  • Unfortunately Lawrence passed away a couple of years ago (Feb 2015).

    WSUS is just a repository for updates. Nothing more. Clients ask for a list, WSUS gives it. Clients request files and WSUS Gives it. So long as communication can talk over a port, WSUS will work.


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    Saturday, May 20, 2017 3:48 AM
  • Yes thanks!  The solution "wsusutil.exe usecusomwebsite false" changes WSUS to use port 80 from the default WSUS Administration web site listening on TCP 8530 and 8531 and puts all the WSUS virtual directories and web applications under the Default Web Site.  It seems to take about a minute of munching the bits and bytes after you run the command and a reboot afterwards is a good idea. 

    Now why can't Microsoft tell us these things in the configuration wizard ????  All my inter-site WAN firewall rules are set up for port 80 (no need for the SSL overhead since it's private) Thaaannnnkkkssss!


    anthony maw/mcse/vancouver/canada



    • Edited by Anthony Maw Wednesday, July 12, 2017 9:15 PM
    Wednesday, July 12, 2017 6:51 PM