locked
USMT Tool Exclude "This Computer" RRS feed

  • Question

  • Hello Everyone,

    I've recently started to play with the USMT tool and have a pretty good understanding of how it works and what it should do. But I have a question which I can't seem to find an answer to. I'm really hoping that one of you may be able to help me with this issue.

    Goal: Use the USMT tool to migrate a Domain Profile from Domain A to Domain B. I'm trying to keep all programs and data attached to this User. 

    Bit more information - I am staying within the same Windows 7 machine I have. 

    I've ran the following command

    Scanstate.exe D:\%CustomPath%\MyStore /o /c /i:migdocs.xml /i:migapps.xml /ui:%DomainName%\%Username% /ue:%ComputerName%\* 

    What I'm trying to do is to exclude the "This Computer" portion of the tool since it seems to take 40GB worth of information with it, while my domain profile is only 5GB of information.

    So is there a way to exclude "This computer" from being transferred using the USMT?



    • Edited by DMike162 Wednesday, September 18, 2013 11:19 PM
    Wednesday, September 18, 2013 11:17 PM

Answers

  • USMT captures data 'for each user ' then 'once per system'

    In your scenario you should use the miguser.xml instead of migdocs.xml

    This will stop usmt from using the mighelper functions that capture data outside of user profiles.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    • Marked as answer by Cloud_TS Sunday, October 6, 2013 7:09 AM
    Wednesday, September 25, 2013 9:56 AM
  • you have the correct scanstate command to target one specific profile on the computer and exclude all others.  I suspect that USMT is working as you intend it to, it's just collecting more data than you would expect.  Take a look at the migapps.xml file.  In that file it contains all the folders to be scanned and transferred by USMT.  There are numerous references to application data, which I think is causing your data set to be larger than you anticipated.  You can edit that file to include or exclude whatever specific folders or file types you wish.  By default it does a very thorough capture of many settings and file types outside of what might typically be considered "user data"   
    • Marked as answer by Cloud_TS Sunday, October 6, 2013 7:09 AM
    Thursday, September 19, 2013 7:58 PM

All replies

  • you have the correct scanstate command to target one specific profile on the computer and exclude all others.  I suspect that USMT is working as you intend it to, it's just collecting more data than you would expect.  Take a look at the migapps.xml file.  In that file it contains all the folders to be scanned and transferred by USMT.  There are numerous references to application data, which I think is causing your data set to be larger than you anticipated.  You can edit that file to include or exclude whatever specific folders or file types you wish.  By default it does a very thorough capture of many settings and file types outside of what might typically be considered "user data"   
    • Marked as answer by Cloud_TS Sunday, October 6, 2013 7:09 AM
    Thursday, September 19, 2013 7:58 PM
  • USMT captures data 'for each user ' then 'once per system'

    In your scenario you should use the miguser.xml instead of migdocs.xml

    This will stop usmt from using the mighelper functions that capture data outside of user profiles.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    • Marked as answer by Cloud_TS Sunday, October 6, 2013 7:09 AM
    Wednesday, September 25, 2013 9:56 AM