none
Remote Desktop Session Host server is within its grace period, but the RD Session Host server has not been configured with any license server RRS feed

  • Question

  • We have one terminal server with Win Server 2012 R2, and one Linux file server. The Linux file server is also the Domain Controller.

    The Windows server should be running terminal services for the business programs which need a Windows platform. We are continuously getting the following error message: "Remote Desktop Session Host server is within its grace period, but the RD Session Host server has not been configured with any license server".

    When I try in the RD Licensing Diagnoser to connect to Remote Desktop Session Host Server, it shows the above error message.

    The Windows server RD Licensing Manager has 20 Licenses installed, but shows as never issued.

    The error message suggested resolution says "Configure a license server for the Remote Desktop Session Host server. If you have an existing license server, specify that license server for the RD Session Host server. Otherwise, install RD Licensing on a computer on your network and Configure RD Session Host server to use it". When I try to specify a Remote Desktop Session Host server by connecting to the Windows server, again the above message shows in the RD Licensing Diagnoser: "Configure a license server... to use it".

    In the Server Manager program, when I attempt to Add Roles or Features, I get to Deployment Type, and it shows the RD Connection Broker to be the apparently correct server. I select 'Standard Deployment' and click Next. Error message shows: "Could not retrieve the deployment information from the RD Connection Broker server XXXX".

    Please advise.

    Tuesday, December 2, 2014 4:07 AM

Answers

  • Hi russellrussel,

    I think that you just have to specify the Remote Desktop Licensing server and License Mode on your Remote Desktop Session Host (on W2012 R2 server) and then the problem will be fixed.

    Follow the instruction below to configure /specify RD Licensing server and License Mode :

    > From W2012 R2 server, from Modern UI, type : GPEDIT.MSC

    > Navigate until : Computer Configuration | Administrative Template | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Licensing 

    > You have to configure the two following parameters : 

    The first parameter (Use the specified ...) must be enabled and you have to specify the hostname of the RD Licensing server. if you are using a standalone server, so you have to enter the W2012 R2 RDS Server name.

    The second parameter (Set the Remote ...) must be enabled and you have to choose the License Mode corresponding to RDS CALs you bought.

    PLEASE NOTE THAT IF YOU HAVE A RDS Per-Device CAL, this will resolve your problem.

    If the RDS CAL you bought are a Per-User Mode, in this case, you have to deploy an Active Directory domain because the CAL RDS that will be assigned to remote users must be stored on MS Active directory database.

    Hope that can you helps u.

    HK.


    Hicham KADIRI | Just Another IT Guy


    Tuesday, December 2, 2014 8:49 PM
  • Hi,

    To create a full RDS deployment the broker (and other RDS servers) need to be joined to a Microsoft Active Directory domain.  From your description it seems you may be using a samba DC, which is not supported.  I have not heard of anyone being able to get RDS 2012/2012 R2 deployment working with  non-MS domain controller, however, perhaps it is possible.

    An alternative to having a full RDS deployment would be to just have RDSH and RD Licensing Role Services installed.  This will permit users to connect to the RDSH and get a full desktop connection.  To make this work you can configure the licensing mode and licensing server name via group policy setting on the RDSH server using gpedit.msc.  For Per User licensing the tracking mechanism will not work properly if the server is not part of a domain.  I do not believe tracking will work properly with non-MS domain but you can always give it a try if you want.

    Please note that if you do not have a RDS deployment then you will not be able to use the RDS gui in Server Manager to configure settings, manage connections, create collections, publish/unpublish RemoteApps, etc.  Most RDS powershell commands will not work either. You can use group policy, wmi, registry edits, command line programs like query session, etc., to work with the server.

    Thanks.

    -TP

    Tuesday, December 2, 2014 11:43 AM
    Moderator
  • Actually, I managed to find the answer here:

    http://anilgprabhu.blogspot.co.nz/2014/05/reset-trial-terminal-license-on-windows.html

    Simply delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod
    Only leaving the default.

    Monday, January 19, 2015 3:47 AM

All replies

  • Hi,

    To create a full RDS deployment the broker (and other RDS servers) need to be joined to a Microsoft Active Directory domain.  From your description it seems you may be using a samba DC, which is not supported.  I have not heard of anyone being able to get RDS 2012/2012 R2 deployment working with  non-MS domain controller, however, perhaps it is possible.

    An alternative to having a full RDS deployment would be to just have RDSH and RD Licensing Role Services installed.  This will permit users to connect to the RDSH and get a full desktop connection.  To make this work you can configure the licensing mode and licensing server name via group policy setting on the RDSH server using gpedit.msc.  For Per User licensing the tracking mechanism will not work properly if the server is not part of a domain.  I do not believe tracking will work properly with non-MS domain but you can always give it a try if you want.

    Please note that if you do not have a RDS deployment then you will not be able to use the RDS gui in Server Manager to configure settings, manage connections, create collections, publish/unpublish RemoteApps, etc.  Most RDS powershell commands will not work either. You can use group policy, wmi, registry edits, command line programs like query session, etc., to work with the server.

    Thanks.

    -TP

    Tuesday, December 2, 2014 11:43 AM
    Moderator
  • Hi russellrussel,

    I think that you just have to specify the Remote Desktop Licensing server and License Mode on your Remote Desktop Session Host (on W2012 R2 server) and then the problem will be fixed.

    Follow the instruction below to configure /specify RD Licensing server and License Mode :

    > From W2012 R2 server, from Modern UI, type : GPEDIT.MSC

    > Navigate until : Computer Configuration | Administrative Template | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Licensing 

    > You have to configure the two following parameters : 

    The first parameter (Use the specified ...) must be enabled and you have to specify the hostname of the RD Licensing server. if you are using a standalone server, so you have to enter the W2012 R2 RDS Server name.

    The second parameter (Set the Remote ...) must be enabled and you have to choose the License Mode corresponding to RDS CALs you bought.

    PLEASE NOTE THAT IF YOU HAVE A RDS Per-Device CAL, this will resolve your problem.

    If the RDS CAL you bought are a Per-User Mode, in this case, you have to deploy an Active Directory domain because the CAL RDS that will be assigned to remote users must be stored on MS Active directory database.

    Hope that can you helps u.

    HK.


    Hicham KADIRI | Just Another IT Guy


    Tuesday, December 2, 2014 8:49 PM
  • Actually, I managed to find the answer here:

    http://anilgprabhu.blogspot.co.nz/2014/05/reset-trial-terminal-license-on-windows.html

    Simply delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod
    Only leaving the default.

    Monday, January 19, 2015 3:47 AM
  • This fixed my issue, I only had set the " set the remote desktop licensing mode" and not the use specified remote desktop license server.  

    Thanks

    Thursday, April 2, 2015 2:20 PM
  • Thank you very much. It helped. i had the same issue. But first of all I had this:
     https://social.technet.microsoft.com/Forums/windowsserver/en-US/ebc032e2-ab2d-4acd-aef7-28ed548be569/how-to-set-up-remote-desktop-licensing-mode-in-windows-server-2012?forum=winserverTS

    And removing the registry key helped. Also I needed to use specified program to delet it: . https://www.raymond.cc/blog/full-control-permission-to-delete-or-edit-restricted-windows-registry/

    The issue started after end of 120 days tryal sessions.

    I hope it will help someone :)
    Wednesday, July 1, 2015 12:52 PM
  • This worked for me. Thanks mate!
    Thursday, October 15, 2015 3:49 PM
  • Are you saying that we have to have Active Directory if we want to use Per-User mode?
    Tuesday, March 7, 2017 8:34 AM
  • You are an absolute genius! Thank you!
    Thursday, March 23, 2017 2:59 PM
  • thank you so much, it worked perfectly
    Wednesday, January 15, 2020 4:13 PM