none
WSUS Clients Not Receiving Updates

    Question

  • Hi,

    I have approximately 60 clients which connect to a machine running WSUS 3.0 SP1. The OS is Server 2003 R2 SP2.  This machine is also used for managing ForeFront clients. The box also has the ForeFront client installed on it. This was clean install and has no other purpose other than WSUS and Forefront.  It had been functioning without problems since March 08 when it was commissioned.


    Over the past couple of month machines have stopped communicating with the WSUS day range from 29 to 59 days without communication.

    Around the time the machines stopped around the time the machines stopped communicating we introduced a proxy server.

    However WSUS is able to download updates and machines are able to access the machine using the URL: Http://ForeFront and Http://ForeFront/SimpleAuthWebService/SimpleAuth.asmx. Displaying 

    "SimpleAuth


    The following operations are supported. For a formal definition, please review the Service Description.


    I found information at one forum which suggested IIS authentication problems which I have addressed. (See link below)

    http://www.wsus.info/forums/lofiversion/index.php?t5928.html

    I have also run the Client Diagnose Tool with the following results.


    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is running. . . PASS
            Wuaueng.dll version 7.1.6001.65 . . . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
                    Option is from Policy settings

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy
                    http://pad1.some.com/proxy.pac
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer = Http://ForeFront
                    WUStatusServer = Http://ForeFront
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    VerifyWUServerURL() failed with hr=0x80190197

    No Error description could be found

    Press Enter to Complete

    With my  update log looking like

    2008-10-29 16:43:26:660 1084 1558 Report WARNING: Discarding a batch of 1 events because they have expired.
    2008-10-29 16:43:26:722 1084 1558 PT WARNING: Cached cookie has expired or new PID is available
    2008-10-29 16:43:26:723 1084 1558 PT Initializing simple targeting cookie, clientId = c958317a-511e-4920-bb6f-46dcc78c9eac, target group = , DNS name = support-01.headoffice.centaman
    2008-10-29 16:43:26:723 1084 1558 PT   Server URL = Http://ForeFront/SimpleAuthWebService/SimpleAuth.asmx
    2008-10-29 16:43:26:773 1084 1558 PT WARNING: GetAuthorizationCookie failure, error = 0x8024401B, soap client error = 10, soap error code = 0, HTTP status code = 407
    2008-10-29 16:43:26:774 1084 1558 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x8024401b
    2008-10-29 16:43:26:774 1084 1558 PT WARNING: PopulateAuthCookies failed: 0x8024401b
    2008-10-29 16:43:26:774 1084 1558 PT WARNING: RefreshCookie failed: 0x8024401b
    2008-10-29 16:43:26:774 1084 1558 PT WARNING: RefreshPTState failed: 0x8024401b
    2008-10-29 16:43:26:774 1084 1558 PT WARNING: PTError: 0x8024401b


    I have a variety of clients ranging from W2k, XP, Server 2003, Vista and Server 2008.

     

    Also when I run “proxycfg.exe -?” from a command prompt  I get the following error message.

    “C:\>proxycfg.exe -?

    'proxycfg.exe' is not recognized as an internal or external command,

    operable program or batch file.”



    I'm not sure what else to check now, any guidance would be apprecidated and welcomed thanks.


    Adam
    Tuesday, October 28, 2008 8:50 PM

Answers

  • The page in your link above has moved and there's no content available. I have the same issue in my environment. Please suggest what steps you took to make the clients point to the server.

    Calvin, this Technet article contains a reference to the legacy proxycfg.exe parameters, and a link to the netsh winhttp command syntax.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, November 21, 2012 12:23 AM
    Moderator
  • You've pretty much answered your own question...


    > Around the time the machines stopped around the time the machines stopped communicating we introduced a proxy server. 

    > Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy
                    http://pad1.some.com/proxy.pac
                    User IE AutoDetect
                    AutoDetect not in use

    > Checking Connection to WSUS/SUS Server
                    WUServer = Http://ForeFront
                    WUStatusServer = Http://ForeFront
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    > VerifyWUServerURL() failed with hr=0x80190197

    0x80190197 is an HTTP 407 error -- Proxy Authentication Required


    The problem here is fairly simple. You reconfigured =IE= on the clients to use the proxy, but did not reconfigure =WinHTTP= to use the proxy.
    And, unfortunately, configuring WinHTTP via autoconfig is not an option.

    You'll need to manually configure each client to have WinHTTP bypass the proxy server for local connections.






    Lawrence Garvin, M.S., MCITP(x2), MCTS(x5), MCP(x7), MCBMSP
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    • Marked as answer by Agilbert2003 Sunday, November 02, 2008 3:17 AM
    Thursday, October 30, 2008 5:10 PM
    Moderator

All replies

  • You've pretty much answered your own question...


    > Around the time the machines stopped around the time the machines stopped communicating we introduced a proxy server. 

    > Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy
                    http://pad1.some.com/proxy.pac
                    User IE AutoDetect
                    AutoDetect not in use

    > Checking Connection to WSUS/SUS Server
                    WUServer = Http://ForeFront
                    WUStatusServer = Http://ForeFront
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    > VerifyWUServerURL() failed with hr=0x80190197

    0x80190197 is an HTTP 407 error -- Proxy Authentication Required


    The problem here is fairly simple. You reconfigured =IE= on the clients to use the proxy, but did not reconfigure =WinHTTP= to use the proxy.
    And, unfortunately, configuring WinHTTP via autoconfig is not an option.

    You'll need to manually configure each client to have WinHTTP bypass the proxy server for local connections.






    Lawrence Garvin, M.S., MCITP(x2), MCTS(x5), MCP(x7), MCBMSP
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2009)
    • Marked as answer by Agilbert2003 Sunday, November 02, 2008 3:17 AM
    Thursday, October 30, 2008 5:10 PM
    Moderator
  • Thanks very much Lawrence.

    Got it working now. I found the site below helpful for commands for running proxcfg, and vista syntax, for who want to configure WinHttp

    http://www.codeplex.com/WSUS/Release/ProjectReleases.aspx?ReleaseId=6933

    Adam
    Sunday, November 02, 2008 3:20 AM
  • Hi Agilbert2003,

    The page in your link above has moved and there's no content available. I have the same issue in my environment. Please suggest what steps you took to make the clients point to the server.

    Monday, November 19, 2012 12:06 PM
  • The page in your link above has moved and there's no content available. I have the same issue in my environment. Please suggest what steps you took to make the clients point to the server.

    Calvin, this Technet article contains a reference to the legacy proxycfg.exe parameters, and a link to the netsh winhttp command syntax.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, November 21, 2012 12:23 AM
    Moderator
  • Thanks a lot Lawrence, your post really helped me!

    Friday, March 15, 2013 6:15 PM