Slow Connection Rd Gateway & Certificates RRS feed

  • Question

  • Hi,

    I took my "project" to publish my architecture rds on the web. Locally, everything works fine . The sso works perfectly.
    Here is my architecture rds :
    1 broker server, webaccess , gateway (v- broker.domain.local & )
    4 Session Host servers office RDS1 v- distance , 2,3,4 . Domain.local )
    Locally, so everything is ok , the web access has me the correct certificate , and this certificate rds defined in the console that I built with my CA.
    Via the web I have small problems certificates, I do my tests with a pc that was already joined to the domain , and trust my CA.
    From the outside , I have access to , I can log me . I run an app , and there is a very long over ( almost 2min ) after this I get a message that it is impossible to verify the identity of my RDS server. What seems normal because the certificate presented is a self-signed certificate issued to v- rds4.domaine.local .
    Once I clicked on Yes, we go for 45seconde before the app starts.
    How come is it that it is this one that is present , not the one shown on the console?
    Is it normal that it is much slower , or it comes from the certificate problem ?
    Thank you for your help

    • Edited by Tony84700 Wednesday, February 5, 2014 7:29 AM
    Wednesday, February 5, 2014 7:16 AM


  • Hi Tony,

    Thanks for your posting in Windows Server Forum.

    What’s the RDP version you are using for your client system?
    I can suggest you to install RDP 8.0 for better performance.

    When the remote desktop web access & RemoteApp performance is very slow, is there any particular event log in the Event Viewer?

    Which remoteapp you are trying to use which give slowness issue?
    Did you try to publish notepad as remoteapp and check the result? 

    Please check this thread. Please also check the AV and firewall settings, you can disable the 3rd security software to see whether same issue still exists.
    Hope it helps!

    Thursday, February 6, 2014 7:23 AM