none
Redirecting RDWeb Default site

    Question

  • OK

    I have to enabel external Access to my gatway using 443 only.  To do this I must remove the redirect in IIS, because this breaks the 443 connection.  I can't use a host header because this does the same thing.  I tried makingt he default website path point to the c:\windows\web\rdweb\pages and to c:\windows\web\rdweb but this only starts a string of permissions errors, and I do NOT want to reduce the security of my windows folder.   How can I possibly make the default website for my IIS Server ruinning RDWeb on it be the RDWeb website??

     

     

    Thursday, September 16, 2010 9:28 PM

Answers

  • Hi ScottFree,

    I realize this is a month later, but I encountered the same issue with a Server 2008 R2 box running RDWeb and RDGateway.  I'm assuming the issue you are having is that when you attempt to enable redirection for the base level to redirect to the RDWeb it breaks authentication with the internal Remote Desktop server.

    For example, you are trying to redirect http://www.domain.com to https://www.domain.com/RdWeb

    Instead of using "https://www.domain.com/RdWeb" use "/RDWeb/Pages/default.aspx" and change the redirect behavior to Only redirect requests to content in this directory with a Permanent (301) status code.

    This appears to have fixed the issue for me.

    Wednesday, October 26, 2011 1:53 PM

All replies

  • Hi,

     

    can you please be more specific. You are trying to have RDS Gateway and RD Web on the same box? In W2008 R2 Secure HTTP port is used by default, so unless you put some Webpage on top of it or use RDS Gateway on the same host there should be problems.


    PubForum.net Founder, TS Training in Europe! Love Microsoft &its people to bits!
    Saturday, September 18, 2010 1:23 PM
    Moderator
  • I have RDS Gateway and RDWeb on the same box.   All I am trying to do is set the default site to be the RDWeb website without using the http Redirect or a host header, in IIS 7, since this definitely breaks 443.

    The only thing I can think to do is redirect the default physical path to the c:\windows\web\RDWeb\pages directory, but this doesn't work because security errors come up like crazy.  Is there another way to do this??

     

      

    Monday, September 20, 2010 8:12 PM
  • This wont be possible by design and MSFT may correct me here - but I'm very sure it wont. RDWeb & RDS Gateway wil not work together for external people on the same machine.


    PubForum.net Founder, TS Training in Europe! Love Microsoft &its people to bits!
    Monday, September 20, 2010 8:30 PM
    Moderator
  • Did you ever find a solution for this issue?  I have the same problem but my RDS system breaks only after I want to use redirect.  For example:  webaccess.domain.com gets redirected to webaccess.domain.com/RDWeb.  Once I do that the RPC site breaks and no one can log into any systems on the network remotely.  I get "Log in Failure"

    Thanks

    Joe

     

    Tuesday, September 06, 2011 4:24 PM
  • Using TMG2010, I have both RDWeb and RDGateway working on the same server.

    I have a publishing rule for the /rpc path and another for the /rdweb path. 3rd rule for path of / denies and redirects to /rdweb.

    Tuesday, October 04, 2011 2:46 AM
  • Hi ScottFree,

    I realize this is a month later, but I encountered the same issue with a Server 2008 R2 box running RDWeb and RDGateway.  I'm assuming the issue you are having is that when you attempt to enable redirection for the base level to redirect to the RDWeb it breaks authentication with the internal Remote Desktop server.

    For example, you are trying to redirect http://www.domain.com to https://www.domain.com/RdWeb

    Instead of using "https://www.domain.com/RdWeb" use "/RDWeb/Pages/default.aspx" and change the redirect behavior to Only redirect requests to content in this directory with a Permanent (301) status code.

    This appears to have fixed the issue for me.

    Wednesday, October 26, 2011 1:53 PM
  • Jason,

    That is what I was looking for. I made your recommended change and it worked.  I can now use RDWeb or the RDP Client to the RDS Gateway and both work.

    Thanks

    Joe

     

    Friday, November 04, 2011 6:23 PM
  • Jason,

    Perfect solution for me too. This has been bugging me but working now.

    Thursday, November 10, 2011 7:06 PM
  • Thanks for this. It works fine if I browse to http://domain.com, and I get redirected to https://domain.com/RDWeb/Pages/sv-SE/Default.aspx.

     

    However, if I browse to https://domain.com I still get the IIS 7 default page. Is it possible to make this redirect work for HTTPS as well? This is just a minor issue, since users are probably not typing https.

    Friday, January 13, 2012 12:57 PM
  • It's work for me,

    Thanx

    Thursday, December 06, 2012 8:35 AM