Windows Server 2008 R2 Remote Assistance Disabled


  • Hi,

    I am currently trying to configure remote desktop inside Windows Server 2008 R2. I have setup the server inside an Oracle VirtualBox environment and I want the ability to remote into it so I can utilize fullscreen capabilities.

    When I navigate to the "Remote" tab of the "System Properties", I am able to select "Allow connections from computers running any version of Remote Desktop".

    I am not able to check the Allow Remote Assistance connections to this computer checkbox as it is greyed out. How do I get around this?

    Tuesday, May 24, 2011 8:14 AM


All replies

  • Hello,

    When the option is greyed out this useally means the option is set by "Group Policy". Verify you GPO's locally and in Active Directory. Second is to be able to RDP onto a server you do not need the option "Allow Remote Assistance" but only "Allow Remote Desktop Connections".

    regards Robert Maijen
    Tuesday, May 24, 2011 10:56 AM
  • Remote Assistance needs to be installed as a feature (via Server Manager) under Windows Server 2008 R2; however Remote Assistance is different to Remote Desktop.

    You don't need to enable Remote Assistance to use Remote Desktop.

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Proposed as answer by Alvin - Catus Friday, June 29, 2012 2:52 PM
    Tuesday, May 24, 2011 11:50 AM
  • Thanks for the reply. I have this option set, however I am still unable to connect to it from my host machine. I've tried using the IP address and the machine name, but neither works. Is there another server setting I need to configure?
    Wednesday, May 25, 2011 8:43 AM
  • Have you checked the firewall. Does it allow RDP connections?
    regards Robert Maijen
    Friday, May 27, 2011 3:56 PM
  • Hi,

    I agree with Robert point of view, have you checked the 3rd firewall or security software.

    Looking forward to your feedback.

    Technology changes life……
    • Proposed as answer by Vvulcan07 Saturday, November 10, 2012 2:39 PM
    • Unproposed as answer by Vvulcan07 Saturday, November 10, 2012 2:39 PM
    Tuesday, May 31, 2011 3:28 PM