none
Remote Media Streaming doesn't work in Server 2012 and Microsoft isn't fixing it RRS feed

  • General discussion

  • Does Microsoft actually fix things from user reported problems here?

    WHERE IS THE REMOTE MEDIA STREAMING FIX FOR SERVER 2012?  I've seen 4 or 5 threads that moderators end up referring people to the Home Server 2011 thread.  Or ensure port 80 is turned on.  Or, comically, reduce the number of files in your media folders.  Seriously?

    All you mods are doing is what's known as "the HEISMAN", which means you're stiff arming the issue and running.  I've looked all over the web for a fix for this.  And you know what?  There isn't one.  And I shouldn't have to look that hard.  Remote media streaming works with small libraries, but NOT large ones.  So your port 80 theories don't fly, nor does reducing the file count.  Did it ever occur to you moderators that it really doesn't work with large libraries and the Server guys should look into it?

    I have been a Microsoft guy for almost three decades, but I am taking you guys to task.  You are failing your customers with this mickey mouse support.  Users are telling you that media streaming is not working, it is obviously a trend, and you are not fixing the problem.  How about setting this up in a lab, troubleshooting it by adding 20,000 files, figuring out what the problem is and fix it?

    I'm seriously questioning Microsoft's quality and motives here.  In case you haven't noticed, media streaming is a big deal now.  People aren't buying NAS devices to stream a few songs.  They're buying them because you abandoned Home Server, your current server doesn't stream media to their phones, and your moderators are simply deflecting the real problem.  Do you want people to buy your products?  Do you want it to actually work without people cursing?

    Here's a concept.  How about doing something innovative for home storage solutions that your mother could buy and turn on?  Nah, forget it.  You guys couldn't possibly do something like that.  Even if you did, your marketing department is incapable of making people want one.  They'll just have people dancing around on TV for 30 seconds.  So I'll just keep recommending to people to buy a Synology NAS.  They just work.  And it's funny how the two guys that started that company came from Microsoft.  Maybe they're onto something?


    Saturday, April 5, 2014 4:52 AM

All replies

  • I'm assuming you are running 2012 Essentials?

    And I believe Microsoft is looking to Xbox for their media streaming going forward based on the keynotes at BUILD.

    What's the size of your file storage you are attempting to stream?


    Unfortunately TechNet subscriptions aren't coming back, sorry folks :-(

    Saturday, April 5, 2014 10:42 PM
  • Susan,

    Server 2012 R2 Standard, Essentials role and media pack.  Nothing else because it's just to serve documents and stream media.  Roughly 30,000 files of songs, pictures and videos. 

    But I'm not interested in fixing it for myself, or even keeping the server.  I'm fed up with it.  I bought a Synology NAS and it just works.  I'm only here to help the poor saps still trying to get it to work, and to hammer these moderators giving crap advice.  All they're doing is sending users down a rabbit hole and then marking the issue as "answered".  Yet, the issue still exists and it's irritating.

    Your comment about Xbox isn't relevant, regardless of their plans.  I'm talking about IT support in resolving an issue.  They still have a product on the street that isn't working as they say it should.  And this isn't just about home enthusiasts trying to get it to work.  This is also about the small businesses that need it to work.  They're not going to buy an Xbox to stream training or demo videos.  They're going to stream to their laptops or tablets offsite, or with their phones.  So in essence, they're crippling the very target that Essentials is designed to help.  A server is to serve files, and do so reliably.  It shouldn't matter if they have 100 videos or 10,000.  If people are raising a common issue, no matter by what means they're reporting it, this is a trend and it MUST get back to the Server team to fix it.  There is no other acceptable result, deflection, excuse, or half-asked advice.  The way it stands now, I can see a frustrated small business owner who ends up copying what's thought to be needed to a laptop and getting on a plane, wondering why they're even running a server.  Microsoft has failed that business owner.

    As for Xbox streaming, fat chance.  This is another huge miscalculation by Microsoft.  Aside from Xbox music being in complete shambles, it's obvious that they don't grasp the potential impact of Comcast acquiring Time Warner.  Or Comcast and Verizon squeezing Netflix.  Or that Apple is trying to do a deal with Comcast.  Am I one of the few seeing the writing on the wall?  Some key words in Comcast's and Verizon's vocabulary and planning:  video on demand revenue loss, people cutting cable, high bandwidth costs.  Solution?  Pretty simple.  Gain control of smaller companies like Time Warner to instantly get more customers and impose data caps.  That'll legally keep them from externally streaming in one fell swoop.  They control the video kingdom now.  Judging by how absolutely greedy that Comcast and Verizon truly is, that's exactly their intent.  You just watch.  Charter will be the next to fall after the TWC deal is done.  Unless Nadella plans on rolling out an unlimited internet service with those rose colored glasses he's wearing, that Xbox won't stream squat unless it's from an antenna in your attic.

    Sunday, April 6, 2014 11:01 AM
  • Would you like me to open a support case?  A free one?  Please email susan-at-msmvps.com (change the -at- to @) as posting here won't work for two reasons.  1.  This isn't the essentials forum and since you are referring to 2012 r2 essentials role, you need to post about that in the Essentials forum.  and 2.  I'm not aware that R2 had a media streaming problem.  You do have to manually download a plug in for the R2 platform due to some reason that probably involved export rules. 

    You have the plug in installed and it's still not working?  If so, let's get you a support case so they can look at logs and see what's going on. Forum support only works so well and after that you need a support case.

    And seriously watch the BUILD keynotes, when they refer to the home and home storage, they are talking Xbox.  They are no longer talking about a NAS.  Finally Microsoft can't compete on the NAS front because they have no workgroup server and everything else has too high of a price tag.  Buy a WD mycloud drive and it also works well with Apple who keeps changing smb settings each update and thus it's much easier to support a multi platform world with a Linux based nas to be honest.


    Unfortunately TechNet subscriptions aren't coming back, sorry folks :-(

    Sunday, April 6, 2014 5:43 PM
  • http://social.technet.microsoft.com/Forums/windowsserver/en-US/1d922d2f-846c-4c0b-80de-52fc2413cffe/wse-2012-r2-remote-media-streaming?forum=winserveressentials

    Okay I see the frustration here.  Okay let me see if we can get to the bottom of this pain.   Hang loose.


    Unfortunately TechNet subscriptions aren't coming back, sorry folks :-(

    Sunday, April 6, 2014 5:46 PM
  • Is this going to get fixed?

    Sunday, April 13, 2014 4:47 PM
  • I need someone to help me.  I need someone experiencing this to volunteer to have me open a support case for them.

    I'm not running this platform so I can't open it.  Can you please email me at susan-at-msmvps.com (change the -at- to @) and I'll get a support case opened.


    Unfortunately TechNet subscriptions aren't coming back, sorry folks :-(

    Sunday, April 13, 2014 4:54 PM
  • I talked to a couple different server guys in the few days after this, and nothing since. I can only assume that this will either die on the vine or they can't (or won't) fix this. Not that I had any confidence that they would. I'm not even surprised at the silence.

    I advocated for Microsoft for years but I'm beginning to reconsider.  They're half-asked approach to everything is just astonishing.  Pick any product.  You'll find design flaws, missing features, bad decisions, name changes, confusion, or they simply abort it.  They'll come out with something really good and either wreck it, or cancel it.  Lame has become Microsoft's persona in the public's eyes. 

    It's a shame, too, because Microsoft is the only company that could theoretically cover the needs of every single type of user.  From the business person to the home user to the gamer.  But they find some way to blow it.

    Windows is at the crux of this, because it has run its course.  It is the most bloated OS on the planet, and it's name has even become loathsome. It's to the point that if it has Windows in it's name, people don't want it.

    What Microsoft needs to do is move away from Windows and get Midori on the street, or whatever they're going to call it.  An entirely new OS that's lightweight, stable, well designed, secure, and works across all devices and processors is what's needed, and it's needed now.  And not everyone wants their stuff in a cloud.  If this isn't in Microsoft's vision, they are doomed.

    Monday, June 2, 2014 2:46 AM
  • I've been searching now for two days trying to get streaming to work, even after downloading the media pack but it wont let me stream, only lets me download. I've searched forums and anything I can find, and I come up with nothing. I rebuilt my Ducati Monster by searching forums and was able to find anything I needed, it was amazing.

    Microsoft is such a bullshit company, they only care about directing customers, enthusiasts, or users to upgrading existing products or newer products. Their support is non-existent, I'm so goddamn fed up with it. I've worked at Microsoft as a contractor off/on from 2000-2007 and I swear I will never work at that shitbox again.

    Right now I am running an evaluation version of Essentials 2012 R2 and am glad I have not paid for it. F'ing BS, I am so sick of not being able to run their products correctly.

    Saturday, July 26, 2014 6:55 AM
  • How big of a file are you trying to stream?  Because it does work.  Just on large files/databases it has issues.

    Unfortunately TechNet subscriptions aren't coming back, sorry folks :-(

    Saturday, July 26, 2014 7:34 AM
  • I can stream audio/wma files fine, but cannot stream video (WMA) of any size. I thought maybe it was because the video files were too large so I searched for wma in the %systemroot% (in build wma) and found one under 1MB. Guess what? didn't stream, only let me download.

    Here is the interesting thing: the browser automatically opens the audio player (Silverlight or whatever it is) and streams audio files. When I go to the media library and try to stream a non-protected video, it opens the video player right away and closes it and only lets me download it.

    Listen, I have installed the media pack, and Microsoft advertises that this OS streams media. I'm so fed up with this, I would buy a NAS but ive spent so much time on this, I am determined to get it to work. UGH!

    Monday, August 18, 2014 6:27 PM
  • Susan, I will give you an account on my server and let you see for yourself, is there an email address I can send you a login and password as a standard user?
    Monday, August 18, 2014 6:30 PM
  • I finally fixed it, on my own. Ripping a DVD to disk as wmv doesn't work when streaming, ironically. I tried ripping as MP4, and now I can stream video. Look, this is another example of everything that is wrong with Microsoft. They come out with a new server OS that does not support their own file format, but instead only streams mp4, which if I am correct is an Apple (AAC) format. Nothing surprises me anymore about Microsoft.
    Wednesday, August 20, 2014 4:35 AM