none
Windows 2008 R2 - Slow Connection Microsoft-ds Client-Ports < Port ~49404

    Question

  • Problem:

    Every client-connection to our most used Fileserver is extremly slow (~500 Kb/s; we have 400Mbit) when the used dynamic Port from microsot-ds is under Port 49307. Every Connection to this server >= port 49404 works maximum-speed (Client 100Mbit). If we use Sysinternals TCP-View to close a slow connection (microsoft-ds) and new used Port is >= 49404 the connection is immediatly perfect.

    Server:
    Windows 2008 R2 - Fully patched (without SP1) - 24 configured DFS-Replications, 300 direct Users, no printers

    Client: 
    Vista-32bit Clients - Fully patched (Sp2)
    All Clients have only speed-problems with this server. At the same time they every other connection also in the "slow-portrange) to other servers 2008-servers works fine.

    Our network team controlled all settings and traffic. They found nothing.

    Does anybody knows something about this strange problem?

    Tuesday, March 15, 2011 8:37 AM

Answers

  • Problem solved.

    We deleted the network-team on the server. Then we resettet all network-connect-slots to factory-default, reconfigured the team and after those steps the network-problem was gone.

    We are happy, that the problem is solved and the reason was in the hardware-section and was not a software-problem.

    This was a nasty problem, then the behavior shown with the port-ranges was the reason for us to search the solution more in the software-section then in the hardware-section. Of course we controlled allready at the beginning the network-cards....

    Many thanks to everybody who helped me in this thread. An I learned new things...

    Cu - all

    Friday, April 15, 2011 6:44 AM

All replies

  • Hi Customer,
     
          According to  your description, all clients have speed-problems with this server. For other serveres, the speed is normal. Obviously, some port based QoS settings work on this server end.

     

         1.Please check if there is any windows 2008 server QoS policy, Edit GPO,  under Computer Configuration\Policies\Windows Settings\Policy-based QoS

         2.Check the network topology between client and server, check every network device's QoS setting
         3.Try disabling TCP Auto Tuning feature on one Vista host

     
            netsh interface tcp set global autotuninglevel=disabled
        

         4.Use the netmon 3.4 to capture speed-problems traffic to investigate.

      
    Microsoft Network Monitor 3.4
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en
     
    How to use Network Monitor to capture network traffic
    http://support.microsoft.com/kb/812953 
     
    Regards, Rick Tan
    • Proposed as answer by RUOK2 Thursday, April 14, 2011 7:20 PM
    Wednesday, March 16, 2011 8:51 AM
    Moderator
  • Thanks for your help.

    1. QoS isnt configured
    2. Network-Topologie has no QoS Settings

    We have a lot other Servers, and they have all no Problems (Same Hardware, Same Network-Switch)

    3. Disabling auto-tuning on client-side doesnt change the speed  (with reboots....)
    4. I have only little experience in Network-Monitoring. With my knowledge I can not see anything special.

    On my computer is vm-workstation: At the same time, the vista-client has connection-speed-problems, the test-machine with Windows7 has no performance-problems (also in the section of the "slow-port-range").

    hmmm...

    Thursday, March 17, 2011 9:09 AM
  • Hi Customer,

        

    Please try to test if speed-problems on windows 2008 R2 side (copy files from issue Vista), monitor Win2008 and Vista system(CPU/Memory) performance status while  speed-problems copy time.

     

    Additional two KB you could try to install on Vista.

     

    http://support.microsoft.com/kb/955427

     

    http://support.microsoft.com/kb/958702


    Regards, Rick Tan
    Friday, March 18, 2011 8:11 AM
    Moderator
  •  

    Tks for the tip. I installed one of those two hotfixes without a improvement.

    The other Hotfixes was not possible to install.

    Still searching a solution.

    Tuesday, March 22, 2011 1:41 PM
  • Hi Customer,

     

       Please post the “netsh int tcp show global” result on Vista client, download SG_Vista_TcpIp_patch , try to test using patch optimize Tcpip (choice Y) and reset Tcpip value (choice D)  on each one vista.

     

        

    SG_Vista_TcpIp_patch

    http://www.speedguide.net/downloads.php

     

     

    Important Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.


    Regards, Rick Tan
    Friday, March 25, 2011 9:55 AM
    Moderator
  •  

    Hello

    There was no improvement with those Settings. After tests, i reseted all settings back to standard-settings.

    Original Settings of a Vista-Client:
    http://www.lebonetz.ch/downloads/Zeugs/netsh.JPG

    • Proposed as answer by RUOK2 Thursday, April 14, 2011 7:19 PM
    Tuesday, April 05, 2011 7:12 AM
  • Hi Customer,

         The TCPIP setting is ok, then please test if the SMB (file server) traffic issue.

    1. Try to check below patch if installed on Vista

    http://support.microsoft.com/kb/950836

    http://support.microsoft.com/?id=948572

    2. Check two file servers 2008 SMB 2.0 if same and enabled

    SMB: The SMB 2.0 file sharing protocol should be enabled

    http://technet.microsoft.com/en-us/library/ff645214(WS.10).aspx

    3. Using SMB 2.0 on Vista to copy file (Disabled SMB1.0)   

    Two Minute Drill: Overview of SMB 2.0

    http://blogs.technet.com/b/askperf/archive/2008/05/30/two-minute-drill-overview-of-smb-2-0.aspx


    Regards, Rick Tan
    • Proposed as answer by RUOK2 Thursday, April 14, 2011 7:18 PM
    Wednesday, April 06, 2011 9:55 AM
    Moderator
  • I have found a fix for a very slow file transfer from a Windows 2008 R2  box that has an Intel PRO 1000 MT NIC with a default MAC address for the adapter being FF FF FF FF FF FF FF  from the factory.....After changing the MAC addresss ( user asigned within the NIC Driver Settings) my Windows 2008 R2 box is now fast a speedy with file copies.

     

    Doing an IPConfig, check to see what the Network Adapter Mac address is of all network adapters in the Windows 2008 box. and the system you may be copying from, IF you should see an FF FF FF FF FF FF as a Mac address ...this is an issue, and some network adapter drivers allow the user to asign a specific MAC address.

    Others here may not have this specific issue and this may not apply to their specific situation.

    Physical MAC address being FF FF FF FF FF FF FF FF, will be an issue, change it to one that does not interfere with other MAC addresses on the network....and you will see drastic performance with file copies.


    RF
    Thursday, April 14, 2011 7:30 PM
  • Problem solved.

    We deleted the network-team on the server. Then we resettet all network-connect-slots to factory-default, reconfigured the team and after those steps the network-problem was gone.

    We are happy, that the problem is solved and the reason was in the hardware-section and was not a software-problem.

    This was a nasty problem, then the behavior shown with the port-ranges was the reason for us to search the solution more in the software-section then in the hardware-section. Of course we controlled allready at the beginning the network-cards....

    Many thanks to everybody who helped me in this thread. An I learned new things...

    Cu - all

    Friday, April 15, 2011 6:44 AM