none
"The virtual machine could not be started because the hypervisor is not running" Problem

    Question

  • I have downloaded Windows 2008 server R2 Enterprise Edition from MSDN and configured Hyper-V in it. We are planning to migrate a few vmware based VM to Hyper-V. From the steps that i went through, i found installation of Hyoer-V was successful (Last pop up window at the end of installation)

    Converted *.vmdk file to *vhd file and started creating VM. Once after going through all the steps we tried to start the VM. When click on start VM or hit the power button,  got the message "The virtual machine could not be started because the hypervisor is not running" detail event log is below.

    The virtual machine could not be started because the hypervisor is not running.  The following actions may help you resolve the problem:
    1) Verify that the processor of the physical computer has a supported version of hardware-assisted virtualization.
    2) Verify that hardware-assisted virtualization and hardware-assisted data execution protection are enabled in the BIOS of the physical computer.  (If you edit the BIOS to enable either setting, you must turn off the power to the physical computer and then turn it back on.  Resetting the physical computer is not sufficient.)
    3) If you have made changes to the Boot Configuration Data store, review these changes to ensure that the hypervisor is configured to launch automatically.

    Following is my Hardware architecture : Dell PowerEdge R710. I found it certified with Windows 2008 R2 but not sure, if that means it is certified for Hyper-V. Following is MS URL.
    http://windowsservercatalog.com/item.aspx?idItem=c422b2a5-68f6-5a5e-bd80-fd17827e41dc&bCatID=1282

    As per the Hyper-V deployment guide,
    Hardware-enforced Data Execution Prevention (DEP) must be available and enabled. Specifically, you must enable Intel XD bit (execute disable bit) or AMD NX bit (no execute bit). is required.

    I have done DEP enabled or on from bcdedit. I read in MS weblink http://msdn.microsoft.com/en-us/library/aa906211.aspx for editing that. I dont know how to do the second one ...
    "Specifically, you must enable Intel XD bit (execute disable bit)" could not find any material which explains how to do this.

    Also in the deployment guide says update KB950050 is required prior to Hyper-V installation and not required for Windows Server 2008 SP2. I have Windows server 2008 R2. Do i need the update ? I have not installed the update as i presumed it to be there.

    But my Hyper-V VM is not getting started. I have seen many people posted similar problem but nowhere was clear steps and requirement given. Not even in the deployment guide.

    Thanks for reading.

     

     

    Friday, December 11, 2009 3:35 AM

Answers

  • Correct the in this case the DEP is the same as the XD so your good there. What you need to look for is the VT enable setting.  This is typically under the advanced section in the BIOS.  Once you do that cold boot the server and you will be fine.  The R710 is a great server for virtualization.


    Joseph Noga MCITP, MCSE, MCSA, MCTS CCNA,CCDA,CCVP Managing Consultant Artemis Technology LLC
    • Marked as answer by TechTop Friday, December 11, 2009 8:00 PM
    Friday, December 11, 2009 4:08 AM
  • Hello TechTop,

    Please try to Enable Virtualization Technology in the DELL BIOS setting. These settings can be found under the CPU info section of the Dell BIOS. (F2 to enter Dell Bios on the PowerEdge)

    Goto

    CPU Information..........................ENTER

    Virtualization Technology.................Enabled.

    Save the setting to BIOS, reboot the server and try again.

    Best Regards,
    Wilson Jia



    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by TechTop Friday, December 11, 2009 8:00 PM
    Friday, December 11, 2009 8:41 AM

All replies

  • Correct the in this case the DEP is the same as the XD so your good there. What you need to look for is the VT enable setting.  This is typically under the advanced section in the BIOS.  Once you do that cold boot the server and you will be fine.  The R710 is a great server for virtualization.


    Joseph Noga MCITP, MCSE, MCSA, MCTS CCNA,CCDA,CCVP Managing Consultant Artemis Technology LLC
    • Marked as answer by TechTop Friday, December 11, 2009 8:00 PM
    Friday, December 11, 2009 4:08 AM
  • Hello TechTop,

    Please try to Enable Virtualization Technology in the DELL BIOS setting. These settings can be found under the CPU info section of the Dell BIOS. (F2 to enter Dell Bios on the PowerEdge)

    Goto

    CPU Information..........................ENTER

    Virtualization Technology.................Enabled.

    Save the setting to BIOS, reboot the server and try again.

    Best Regards,
    Wilson Jia



    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by TechTop Friday, December 11, 2009 8:00 PM
    Friday, December 11, 2009 8:41 AM
  • Enabling Virtualization technology from DELL BIOS solved my problem. Exellent reply from Wilson and Joseph. I wish these two steps were documented in Hyper-V deployment guide. Though they are quite obvious for seasoned professional, but for a newbie like me in virtualization it could save a great deal of time and furstation with the product.

    I also want to point out that, while migrating the *.vmdk file *.vhd file vmtoolkit utility vmd2vhd did not work for me. I spent quite a few hours there. Finally Starwind came for my rescue. Please find the tool here http://www.starwindsoftware.com/download/1/StarWindConverter.exe 

    vmd2vhd may not be compatible with Windows 2008 server R2.

    Any guidance on networking managemet will be appreciated. As my old VM was on VMware on a different server and had different ip address. The new server has different ip and dhcp enabled. Will the VM pick the new ip by default or i will have to administer it ? My VM guest is Linux RHEL 5 Enterprise Ed.

    Thanks,
    Niranjan



    Friday, December 11, 2009 8:00 PM
  • Niranjan,

    Glad to help.  What you will need to do is make your virtual network in Hyper-V and then install the Integration Components on the guest VM.   Most likely when the server is brought up on the Hyper-V server it will not have any network connections as the VMware components are no longer valid.  Once the Hyper-V components are installed on the guest VM you will then have to administer it and assign it an IP.


    Joseph Noga MCITP, MCSE, MCSA, MCTS CCNA,CCDA,CCVP Managing Consultant Artemis Technology LLC
    Friday, December 11, 2009 11:58 PM
  • Solution:

    - Most of the machines have "Virtualization" Disabled by default in their BIOS. So the first thing you need  to make sure Virtualization is Enabled or turned on in the BIOS setting.

    - When you install Hyper-V in Windows Servers, it automatically disables desktop features like Hybernation / Sleep.  You can enable those features (sleep / hybernation) by changing the 'Start' Value from 1 to 3 in  
    Y_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\hvboot\Start = DWORD 3

    - This will give the error message  
     "the virtual machine could not be started because the hypervisor is not running"
    even though you have "Virtualization" Enabled in the BIOS setting.

    - Since you have changed the Registry value for "hvboot" to enable Hybernation / Sleep feature,  you will need to start the Hypervisor manually.

    Do this: Open Command Prompt window with Administrative privilege and run the following command > net start hvboot

    Start the Virtual Machine and there you go.... Problem Solved

    Thursday, September 9, 2010 8:10 PM
  • I have exactly same problem with a HP DL-385p server. I could not power on the guests. After some internet research i found the following KB

    http://support.microsoft.com/kb/2568088

    and this solved my problem. The issue was "Virtual machine does not start on a computer that has an AMD CPU that supports the AVX feature and that is running Windows Server 2008 R2"

    Monday, April 15, 2013 4:06 AM