none
how to use http with web enrollment RRS feed

  • Question

  •  

    I have machine running windows server 2008 its configured with Certifcation Authority when i try to request certificate using the web HTTP it told me that i must connect with HTTPS. i cannot use the submit button its dimmed

     

    how can i use only HTTP to request Certificates?

    Monday, May 26, 2008 4:44 PM

Answers

  • Hi,

     

    I'd like to know whether you request the certificate in Windows Vista client.

     

    The new web enrollment pages for Vista does require HTTPS and ActiveX control installation. If you are using Vista clients, please refer to the following Microsoft Knowledge Base article:

     

    -      How to use Certificate Services Web enrollment pages together with Windows Vista or Windows Server 2008

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922706

     

    In addition, please try to add the site into the IE Trusted Sites.

     

    1.    In the Internet Explorer, tools--->Internet Options--->Security tab--->Trusted Sites.

    2.    Click Sites, clear the option "Require server verification (httpsSmile for all sites in this zone" and add the current CA web enrollment site into the list.

     

     

    Thursday, May 29, 2008 3:43 AM
    Moderator

All replies

  • Hello,

     

    In the IIS Manager (Sites--->Default Web Site--->CertSrv), double click SSL Settings and check to clear the option "Require SSL". Then apply the change and check how it works.

     

    Tuesday, May 27, 2008 10:04 AM
    Moderator
  • the SSL option is not even Enabled the full message i receive is " In order to complete certificate enrollment, the Web site for the CA must be configured to use HTTPS Authentication" any other suggestions ?

     

    Tuesday, May 27, 2008 11:50 AM
  • Hi,

     

    I'd like to know whether you request the certificate in Windows Vista client.

     

    The new web enrollment pages for Vista does require HTTPS and ActiveX control installation. If you are using Vista clients, please refer to the following Microsoft Knowledge Base article:

     

    -      How to use Certificate Services Web enrollment pages together with Windows Vista or Windows Server 2008

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922706

     

    In addition, please try to add the site into the IE Trusted Sites.

     

    1.    In the Internet Explorer, tools--->Internet Options--->Security tab--->Trusted Sites.

    2.    Click Sites, clear the option "Require server verification (httpsSmile for all sites in this zone" and add the current CA web enrollment site into the list.

     

     

    Thursday, May 29, 2008 3:43 AM
    Moderator
  • Hi,

    I've added the site into the Trusted Sites and cleared https-requirement as well, but still end up with the error message above.
    SSL requirement in IIS is also cleared.
    The DC and Certification Authority are running on a Server 2008 R2 Beta.

    Are there any other Ideas how to solve this problem?

    regards,

    Patrik
    Tuesday, February 10, 2009 3:59 PM
  • Is the computer requesting the certificate Vista? Or Vista SP1?

    Since you have turned off SSL, make sure that your IE settings enable "Initialize ActiveX unsafe for scripting" You can find this under Tools->Internet Options->Security. Select the zone [trusted, internet, intranet, etc...] and then select the "Custom Level..." button. You should find this option in the list.

    • Proposed as answer by clrsky Friday, January 21, 2011 12:40 PM
    Wednesday, February 11, 2009 1:28 AM
  • I had a similar issue with this.  For the most part the accepted answer for this thread will get you fixed up, but also make sure that you do create and install/bind a certificate for SSL on your CertSrv site.

    Doing that and following Andrew bernat's advice resolved my issue.

    Hope this helps.
    Thursday, February 12, 2009 9:02 PM
  • Hi,

    @andrew: thank you for your answer, it worked. 

    I figured the easyest way is to set the Intranet security level to "low".
    Thursday, February 12, 2009 9:11 PM
  • Hi Andrew

    I have same problem like YaseerG the only thing is that i have Windows Server 2008 SP2.

    Answer provided by you helped me after looking it on so many blogs and forums.

    I just wanted to thank u
    Saturday, February 6, 2010 12:06 PM
  • Like Devang, I also wanted to say thank you, Andrew.
    Thursday, February 18, 2010 1:31 AM
  • Thank you very much Andrew..

    That was a very vital tip  :)

    Friday, January 21, 2011 12:40 PM
  • Andrew, You are a Star! That worked fie me as well.
    Friday, April 1, 2011 7:54 AM
  • THANK YOU Andrew!!!
    Wednesday, May 25, 2011 12:57 PM
  • thanks Andrew
    Thursday, June 21, 2012 1:37 PM