none
Win32 error code returned by the print processor: 5. Access is denied.

    Question

  • I am trying to print a document to a redirected printer using remote desktop over a vpn.  The server is running Win server 2008 R2.  The pirint failed and the following error message was in it's event log.

    Anny ideas why this has happened and how do I fix it.

    The document Microsoft Word - 201106202009 - D23 - xxxxxxxxxxx, owned by xxxx, failed to print on printer HP LaserJet 1200 Series PCL 6 on PERRY (redirected 4). Try to print the document again, or restart the print spooler.
    Data type: RAW. Size of the spool file in bytes: 4549. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\MYSERVER1. Win32 error code returned by the print processor: 5. Access is denied.

    Monday, June 20, 2011 7:52 PM

Answers

  • By no means are we experts, but i found your post searching for a fix for the exact same problem.  We just got our client printer to print from WAN thru RDP by disabling "Use RD Easy Print driver first."  We did install the printer driver on our terminal server.  Not sure if that was necessary now, but we are not going to take it off to find out.  We also enabled write access to our clients in the system32/spools/printers, rmb for properties, then security then check the settings of your users.  Write was not enabled for ours so we enabled it.  Again, not sure this is part of the fix, but at this point we are not going to change anything.  btw, we are running 2008 R2 as well.  This particular client is running win7 home 32 bit.....

     

    hope this helps....

    Wednesday, June 22, 2011 2:56 PM

All replies

  • By no means are we experts, but i found your post searching for a fix for the exact same problem.  We just got our client printer to print from WAN thru RDP by disabling "Use RD Easy Print driver first."  We did install the printer driver on our terminal server.  Not sure if that was necessary now, but we are not going to take it off to find out.  We also enabled write access to our clients in the system32/spools/printers, rmb for properties, then security then check the settings of your users.  Write was not enabled for ours so we enabled it.  Again, not sure this is part of the fix, but at this point we are not going to change anything.  btw, we are running 2008 R2 as well.  This particular client is running win7 home 32 bit.....

     

    hope this helps....

    Wednesday, June 22, 2011 2:56 PM
  • Thanks,

    i had the same problem today. Just enabled write access to our clients in the system32/spools/printers  and problem solved.

    Wednesday, March 21, 2012 5:00 PM
  • That is what I did to solve my problem and we now have a number of different printers working OK for our users; I believe they are all using the Easy Print driver.

    Wednesday, March 21, 2012 7:53 PM
  • Thank you for this post! The GPO structure is a little different for 2k8r2, but I did everything close to  JonJennings with respect to the GPO. No avail. 

    Then I granted write permission to system32/spools/printer to GPO Users... Presto!

    I did not install the printer driver on the terminal server.

    Thursday, October 25, 2012 12:50 AM
  • Just given the write access in system32/spools/printers, works fine now, thanks all for ur support.
    Sunday, September 8, 2013 9:24 AM
  • Thank you so much.  I had been dealing with these issues for several days to no avail.  This helped us! 
    Wednesday, January 8, 2014 7:21 PM
  • This also helped me resolve my issue.  Grant write permissions to the system32\spool\printers directory.
    Saturday, April 26, 2014 7:35 PM
  • the directory is only system32\spool\printers just to clarify the above answer.
    Monday, October 20, 2014 6:52 PM
  • Hi guys!

    Just you have to do two acts:

    1) In Windows 2008 R2 server, you be install drivers compatible with your clients prints. 

    2) Give permission in directory: C\Windows\System32\Spool to read and wirte. 

    I have three models prints and this post help with my problems. 

    Thank you guys!

    Thursday, December 11, 2014 2:09 PM
  • Where do I enable this write access

    Tuesday, February 10, 2015 5:17 PM
  • thx its work for me i just do this part

    "enabled write access to our clients in the system32/spools/printers, rmb for properties, then security then check the settings of your users"

    on  windows server 2008R2 and windows multisession 2011
    • Edited by PezhmanRS Wednesday, December 23, 2015 1:08 PM add more details
    Wednesday, December 23, 2015 1:07 PM
  • Disabling Advanced printing features resolved this error for me.
    Wednesday, January 6, 2016 7:29 PM
  • I changed the rights of folder "Printer" and "prtprocs" and it works!

    THANKS!

    Monday, January 11, 2016 6:33 PM
  • Opening permissions to the spooling server worked for me also.

    Thursday, October 20, 2016 3:49 PM