none
WMIC - Access Denied when trying to connect remotely with an Admin account RRS feed

  • Question

  • I'm trying to use the command below from a remote workstation:

    wmic /node:"HOSTNAME" /user:"ADMIN_USER" /password:"PASSWORD" logicaldisk

    I keep getting Access Denied. The user account is a member of Administrators. If I use the built-in administrator account, it works fine.

    This is non-domain machine with it's user accounts configured locally.

    Any ideas?

    Tuesday, June 10, 2014 8:50 PM

Answers

  • Hi Frank,

    Please refer to following operations and check if can help you.

    1. wmic /node:"HOSTNAME" /user:"ADMIN_USER" /password:"PASSWORD" logicaldisk

    Please replace HOSTNAME with IP address, then monitor the result.

    2. Please open Control Panel, select User Accounts and click Manage another account. Then select the user account which you will use in WMIC command. Then please select Change the account type and check if you have set it as Administrator. If no, please set it as Administrator and check if this issue still persists.

    3. Please refer to the following thread and check if can help you.

    WMI Remote "Access Denied"

    If this issue still persists, please let me know the edition information of Windows OS that this issue occurred in. Meanwhile, you described “The user account is a member of Administrators.” Would you please let me summarily know how operate?

    Hope this helps.

    Best regards,

    Justin Gu

    Thursday, June 12, 2014 7:48 AM
    Moderator